Bug 77990 - Add network device crashes every time.
Add network device crashes every time.
Status: CLOSED DUPLICATE of bug 77708
Product: Red Hat Linux
Classification: Retired
Component: netcfg (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-16 19:07 EST by Roger Warnock
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-23 17:48:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roger Warnock 2002-11-16 19:07:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; T312461; Hotbar 4.0)

Description of problem:
In System Configure Network and Add a device a crash results. This happens 
after eth0 was deleted and an attempt to Add back a device was made.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to add a network device in Configure Network
2.
3.
	

Actual Results:  Process crashs every time.

Expected Results:  I should have been able to add eth0 device.

Additional info:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 473, in on_deviceAddButton_clicked
    interface = NewInterfaceDialog()
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/gui/NewInterfaceDialog.py", line 82, in __init__
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/gui/EthernetInterface.py", line 101, in __init__
    self.hwDruid = ethernetHardware(self.toplevel)
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/gui/EthernetHardwareDruid.py", line 64, in __init__
    self.setup()
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/gui/EthernetHardwareDruid.py", line 118, in setup
    list.append(modInfo[i]['description'])
KeyError: description

Local variables in innermost frame:
modInfo: <netconfpkg.Conf.ConfModInfo instance at 84d3980>
list: ['RealTek RTL8129', 'Raytheon Raylink/WebGear/Aviator PCMCIA 
wireless', 'SMC Ultra32 EISA', 'DEC 21*40 and clones', 'Lucent Orinoco/Melco 
PCMCIA wireless (alternate)', 'SMC 91c92 series PCMCIA', 'Aironet 4500 PCI-ISA-
i365 wireless', 'Intel EtherExpress/1000', 'PCI NE2000 clones', 'MiCom-Interlan 
NI5010', '3Com 3c515 Corkscrew', 'SMC 83c170 EPIC/100', 'NI5210 
ethernet', 'AT1500, HP J2405A, most NE2100/clone', 'MyriCOM MyriNET 
SBUS', '3Com EtherLink16', 'AT&T/Lucent/Hitachi ISA WaveLAN', 'SiS 
900/7016CI', 'Cabletron E2100', 'NE1000, NE2000, and compatible', 'Intel 
EtherExpress Pro 100B', 'Allied Telesis AT1700', 'Greenwigh GIrBIL 
IrDA', 'Older DEC 21040, most 21*40', 'NSC IrDA', 'Sun Quad', 'ICL EtherTeam 
16i/32 EISA', '3Com 3c590/3c595/3c90x/3cx980', '3Com 3c589 series PCMCIA', 'Sun 
BigMac', 'ThunderLAN', '3Com 3c574 series PCMCIA', 'Ansel Communications Model 
3200', 'Aironet 4500 PCMCIA wireless', 'Xircom CBE-100 CardBus', 'General 
Instruments SB1000']
self: <netconfpkg.gui.EthernetHardwareDruid.ethernetHardware instance at 
853f050>
i: defxx
Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
   _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 473, in on_deviceAddButton_clicked
    interface = NewInterfaceDialog()
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/gui/NewInterfaceDialog.py", line 82, in __init__
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/gui/EthernetInterface.py", line 101, in __init__
    self.hwDruid = ethernetHardware(self.toplevel)
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/gui/EthernetHardwareDruid.py", line 64, in __init__
    self.setup()
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/gui/EthernetHardwareDruid.py", line 118, in setup
    list.append(modInfo[i]['description'])
KeyError: description

Local variables in innermost frame:
modInfo: <netconfpkg.Conf.ConfModInfo instance at 84d3980>
list: ['RealTek RTL8129', 'Raytheon Raylink/WebGear/Aviator PCMCIA 
wireless', 'SMC Ultra32 EISA', 'DEC 21*40 and clones', 'Lucent Orinoco/Melco 
PCMCIA wireless (alternate)', 'SMC 91c92 series PCMCIA', 'Aironet 4500 PCI-ISA-
i365 wireless', 'Intel EtherExpress/1000', 'PCI NE2000 clones', 'MiCom-Interlan 
NI5010', '3Com 3c515 Corkscrew', 'SMC 83c170 EPIC/100', 'NI5210 
ethernet', 'AT1500, HP J2405A, most NE2100/clone', 'MyriCOM MyriNET 
SBUS', '3Com EtherLink16', 'AT&T/Lucent/Hitachi ISA WaveLAN', 'SiS 
900/7016CI', 'Cabletron E2100', 'NE1000, NE2000, and compatible', 'Intel 
EtherExpress Pro 100B', 'Allied Telesis AT1700', 'Greenwigh GIrBIL 
IrDA', 'Older DEC 21040, most 21*40', 'NSC IrDA', 'Sun Quad', 'ICL EtherTeam 
16i/32 EISA', '3Com 3c590/3c595/3c90x/3cx980', '3Com 3c589 series PCMCIA', 'Sun 
BigMac', 'ThunderLAN', '3Com 3c574 series PCMCIA', 'Ansel Communications Model 
3200', 'Aironet 4500 PCMCIA wireless', 'Xircom CBE-100 CardBus', 'General 
Instruments SB1000']
self: <netconfpkg.gui.EthernetHardwareDruid.ethernetHardware instance at 
853f050>
i: defxx
Comment 1 Michael Schwendt 2002-11-23 17:48:40 EST
Duplicate of bug #76446.
Comment 2 Roger Warnock 2002-11-26 03:07:49 EST

*** This bug has been marked as a duplicate of 77708 ***

Note You need to log in before you can comment on or make changes to this bug.