Bug 787569 - RFE: add support for multiple monitors on QXL device
Summary: RFE: add support for multiple monitors on QXL device
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Kletzander
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 770842 842298 842305 842310 842411
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-06 07:40 UTC by Oved Ourfali
Modified: 2013-01-25 12:33 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-08 17:47:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 770842 None None None Never
Red Hat Bugzilla 787578 None None None Never

Internal Links: 770842 787578

Description Oved Ourfali 2012-02-06 07:40:08 UTC
Description of problem:

To get n monitors emulated in the guest currently required n pci qxl devices.
This has several problems:
 needless waste of memory.
 hard to support for linux guests (Xinerama required, Xrandr doesn't allow
different cards)

See planned qemu support in bug #770842.

Suggested solution:
Perhaps using the "heads" property to specify the number of monitors?

Comment 2 Daniel Berrangé 2012-02-06 10:23:59 UTC
> Perhaps using the "heads" property to specify the number of monitors?

Yes, that is the correct way to model video cards which have multiple outputs.

Comment 3 Daniel Berrangé 2012-07-23 12:25:54 UTC
Talking to Alon on #spice last week, I learnt that there is not actually any host visible configuration required in order to support multiple monitor mode with QXL. It is all negotiated directly between the SPICE client and the guest QXL driver. So I'm not sure there's any work to be done in libvirtd itself afterall.

Comment 4 Martin Kletzander 2012-07-23 13:16:09 UTC
Sounds good. But maybe there is a initial configuration that might be exposed? I mean the 'heads' parameter should mean how many monitors will be 'connected' at start (something like the proposed -global qxl-vga.num_displays=2 or similar).

I think that if this is supported than we should modify the behavior in this way as well.

Comment 5 Alon Levy 2012-07-23 14:11:57 UTC
Martin,

 The way this was designed there is no need to involve the host in the number of monitors - and conversely there is no way for the host to request a limitation to the number of monitors. Practically the number of monitors will be limited by either the guest actions directly (xrandr / gnome-control-center) or by client triggered (initial MonitorsConfig sent when client connects).

 So there is no need or meaning to have a heads parameter.

 If you would say what you are trying to accomplish it would be possible to discuss a fix for it.

Alon

Comment 6 Martin Kletzander 2012-07-23 19:02:15 UTC
(In reply to comment #5)
I was just trying to clarify if anything is needed and you basically answered my question, so from my point of view this could be closed as NOTABUG.

What is your opinion, Oved?

Comment 7 Dave Allan 2012-08-08 17:47:46 UTC
(In reply to comment #6)
> I was just trying to clarify if anything is needed and you basically
> answered my question, so from my point of view this could be closed as
> NOTABUG.

That seems correct to me, so I'm closing as NOTABUG, but if I'm wrong about that of course reopen.

Comment 8 Oved Ourfali 2012-08-08 18:56:20 UTC
Sorry for the late reply.
According to the latest comments it looks like nothing is indeed needed.

Thank you,
Oved


Note You need to log in before you can comment on or make changes to this bug.