Bug 788264 - nfs-utils is not installable due to requirement of modutils
nfs-utils is not installable due to requirement of modutils
Status: CLOSED DUPLICATE of bug 788571
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Alpha/F17AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-02-07 17:28 EST by Tim Flink
Modified: 2012-02-08 10:56 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-08 10:56:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Flink 2012-02-07 17:28:16 EST
nfs-utils requires modutils which was provided by module-init-tools.

The newest build of kmod obsoletes module-init-tools (but provides module-init-tools) and makes nfs-utils non-installable.

Please change the requires:modutils to module-init-tools so that nfs-utils is installable
Comment 1 Tim Flink 2012-02-07 17:42:18 EST
Installer image composition will fail without nfs-utils, so I'm proposing this as a blocker for F17 Alpha.
Comment 2 Daniel Berrange 2012-02-08 07:03:10 EST
This is preventing us rebuilding libvirt for F17 features too.
Comment 3 Daniel Berrange 2012-02-08 07:04:39 EST
See also

https://lists.fedoraproject.org/pipermail/devel/2012-February/162334.html

"  Error: Package: 1:nfs-utils-1.2.5-11.fc17.x86_64 (@rawhide)
           Requires: modutils >= 2.4.26-9
           Removing: module-init-tools-3.16-5.fc17.x86_64 (@rawhide)
               modutils = 3.16
           Obsoleted By: kmod-5-4.fc17.x86_64 (rawhide)
               Not found

IIUC this suggests either that nfs-utils should be changed to depend
on kmod (but does this provide all of modutils?) or else kmod should
be changed to 'Provides' modutils.

The modutils explicit dependency was added ages ago:

  * Thu Mar 11 2004 Bill Nottingham <notting at redhat.com>
  - rpc_pipefs mounting and aliases are now in modutils; require that 

whatever that means .. rpc_pipefs is in nfs-utils, so it could be the
dependency is now bogus."
Comment 4 Harald Hoyer 2012-02-08 10:56:17 EST

*** This bug has been marked as a duplicate of bug 788571 ***

Note You need to log in before you can comment on or make changes to this bug.