Bug 789641 - WARNING: at include/linux/rcupdate.h:242 __atomic_notifier_call_chain+0xf1/0x130()
WARNING: at include/linux/rcupdate.h:242 __atomic_notifier_call_chain+0xf1/0x...
Status: CLOSED DUPLICATE of bug 799303
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
: 789642 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-11 18:30 EST by Jóhann B. Guðmundsson
Modified: 2012-03-02 14:26 EST (History)
5 users (show)

See Also:
Fixed In Version: kernel-3.3.0-0.rc3.git7.2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-02 14:26:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (64.46 KB, text/plain)
2012-02-11 18:30 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2012-02-11 18:30:24 EST
Created attachment 561164 [details]
dmesg output

Description of problem:

[    0.614605] ------------[ cut here ]------------
[    0.614614] WARNING: at include/linux/rcupdate.h:242 __atomic_notifier_call_chain+0xf1/0x130()
[    0.614617] Hardware name: HP Pavilion dm1 Notebook PC
[    0.614619] Modules linked in:
[    0.614623] Pid: 0, comm: swapper/0 Not tainted 3.3.0-0.rc3.git3.1.fc17.x86_64 #1
[    0.614626] Call Trace:
[    0.614633]  [<ffffffff8106047f>] warn_slowpath_common+0x7f/0xc0
[    0.614638]  [<ffffffff810604da>] warn_slowpath_null+0x1a/0x20
[    0.614642]  [<ffffffff816a1d71>] __atomic_notifier_call_chain+0xf1/0x130
[    0.614646]  [<ffffffff816a1dc6>] atomic_notifier_call_chain+0x16/0x20
[    0.614650]  [<ffffffff813e7299>] notify_write+0x29/0x30
[    0.614654]  [<ffffffff813e813b>] vt_console_print+0x1ab/0x3c0
[    0.614658]  [<ffffffff8106063d>] __call_console_drivers+0x8d/0xb0
[    0.614662]  [<ffffffff81060899>] _call_console_drivers+0x49/0x70
[    0.614666]  [<ffffffff81060c84>] console_unlock+0x114/0x290
[    0.614670]  [<ffffffff810613b2>] vprintk+0x482/0x600
[    0.614675]  [<ffffffff810a27bf>] ? local_clock+0x6f/0x80
[    0.614679]  [<ffffffff81691134>] printk+0x51/0x53
[    0.614683]  [<ffffffff81022bff>] amd_e400_idle+0x11f/0x130
[    0.614688]  [<ffffffff81018266>] cpu_idle+0x106/0x140
[    0.614693]  [<ffffffff81677b8f>] rest_init+0x133/0x144
[    0.614696]  [<ffffffff81677ad5>] ? rest_init+0x79/0x144
[    0.614701]  [<ffffffff81ef6c42>] start_kernel+0x3fc/0x407
[    0.614705]  [<ffffffff81ef6346>] x86_64_start_reservations+0x131/0x135
[    0.614708]  [<ffffffff81ef644a>] x86_64_start_kernel+0x100/0x10f
[    0.614713] ---[ end trace 6d450e935ee1897c ]---
[    0.614715] ------------[ cut here ]------------


Version-Release number of selected component (if applicable):

kernel-3.3.0-0.rc3.git3.1.fc17.x86_64

How reproducible:

Always

Steps to Reproduce:
1. boot
2. run dmesg
3.
  
Actual results:

The above msg

Expected results:

No msg

Additional info:
Comment 1 Dave Jones 2012-02-12 17:36:18 EST
*** Bug 789642 has been marked as a duplicate of this bug. ***
Comment 2 Josh Boyer 2012-02-13 21:06:11 EST
I believe this might be fixed by https://lkml.org/lkml/2012/1/24/441
Comment 3 Josh Boyer 2012-02-13 21:27:42 EST
Can you try this scratch build when it completes and let me know if this traceback goes away:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3788809
Comment 4 Jóhann B. Guðmundsson 2012-02-14 10:05:06 EST
Yup the traceback went away
Comment 5 Josh Boyer 2012-02-14 10:11:40 EST
Thank you for testing.  I've committed the changes and it should be in f17/rawhide soon.
Comment 6 Fedora Update System 2012-02-16 08:22:47 EST
kernel-3.3.0-0.rc3.git6.2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.0-0.rc3.git6.2.fc17
Comment 7 Fedora Update System 2012-02-16 14:26:09 EST
Package kernel-3.3.0-0.rc3.git6.2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.0-0.rc3.git6.2.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1820/kernel-3.3.0-0.rc3.git6.2.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-02-17 15:13:20 EST
kernel-3.3.0-0.rc3.git7.2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.0-0.rc3.git7.2.fc17
Comment 9 Fedora Update System 2012-02-20 21:22:35 EST
kernel-3.3.0-0.rc3.git7.2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Josh Boyer 2012-02-21 20:18:34 EST
Have to reopen this, as the patch checked in seems to have caused some large slowdowns for people (see bug 795050)
Comment 11 Jóhann B. Guðmundsson 2012-02-21 20:32:54 EST
(In reply to comment #10)
> Have to reopen this, as the patch checked in seems to have caused some large
> slowdowns for people (see bug 795050)

Lot of slowness drama on that bug report. 

I'm running 3.3.0-0.rc4.git0.1.fc17.x86_64 here on F16 without experiencing all that slowness epicness...
Comment 12 Josh Boyer 2012-03-02 14:26:36 EST

*** This bug has been marked as a duplicate of bug 799303 ***

Note You need to log in before you can comment on or make changes to this bug.