Bug 799303 - (rcu_cpuidle_warning) [abrt] kernel: WARNING: at include/linux/rcupdate.h:242 perf_output_begin+0x3c1/0x400()
[abrt] kernel: WARNING: at include/linux/rcupdate.h:242 perf_output_begin+0x3...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:a84de37afa188f629b16cb5a8d2...
:
: 789641 794998 797443 798066 798067 798068 799304 799305 799307 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 07:50 EST by Paul Alesius
Modified: 2012-03-02 14:32 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-02 14:32:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Alesius 2012-03-02 07:50:31 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.3.0-0.rc5.git3.1.fc17.x86_64 root=UUID=a6045f60-c942-4e04-b303-6405d36076e3 ro noipv6 rd.md=0 rd.lvm=0 rd.dm=0 LANG=sv_SE.UTF-8 KEYTABLE=sv-latin1 rd.luks=0 selinux=0 SYSFONT=True rhgb quiet
event_log:      2012-03-02-15:49:02* (exited with 9)
kernel:         3.3.0-0.rc5.git3.1.fc17.x86_64
reason:         WARNING: at include/linux/rcupdate.h:242 perf_output_begin+0x3c1/0x400()
smolt_data:     Unable to save UUID to /etc/smolt/hw-uuid.  Please run once as root.
time:           fre  2 mar 2012 15:48:19

backtrace:
:WARNING: at include/linux/rcupdate.h:242 perf_output_begin+0x3c1/0x400()
:Hardware name: HP Mini 210-3000
:Modules linked in: cpufreq_stats fuse lockd sunrpc xts gf128mul dm_crypt hp_wmi sparse_keymap arc4 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core microcode videodev v4l2_compat_ioctl32 media btusb ath9k ath9k_common bluetooth ath9k_hw ath i2c_i801 snd_hda_codec_idt iTCO_wdt mac80211 snd_hda_intel iTCO_vendor_support cfg80211 snd_hda_codec snd_hwdep rfkill snd_pcm snd_page_alloc snd_timer r8169 snd mii soundcore uinput wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
:Pid: 0, comm: swapper/1 Tainted: G        W    3.3.0-0.rc5.git3.1.fc17.x86_64 #1
:Call Trace:
: [<ffffffff810a2c0f>] ? local_clock+0x6f/0x80
: [<ffffffff8113eda5>] ? __perf_event_header__init_id+0xb5/0xf0
: [<ffffffff81060d6f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81060dca>] warn_slowpath_null+0x1a/0x20
: [<ffffffff81146c23>] ? perf_prepare_sample+0x63/0x120
: [<ffffffff81146e5d>] __perf_event_overflow+0x17d/0x300
: [<ffffffff8114a641>] perf_output_begin+0x3c1/0x400
: [<ffffffff810c71cd>] ? trace_hardirqs_off+0xd/0x10
: [<ffffffff810a2c0f>] ? local_clock+0x6f/0x80
: [<ffffffff81146e15>] ? __perf_event_overflow+0x135/0x300
: [<ffffffff810c4913>] ? tick_broadcast_oneshot_control+0x83/0x130
: [<ffffffff8113eda5>] ? __perf_event_header__init_id+0xb5/0xf0
: [<ffffffff810bd904>] ? ktime_get+0x64/0xe0
: [<ffffffff81147031>] perf_swevent_overflow+0x51/0xd0
: [<ffffffff81146c23>] ? perf_prepare_sample+0x63/0x120
: [<ffffffff81146e5d>] __perf_event_overflow+0x17d/0x300
: [<ffffffff8114711f>] perf_swevent_event+0x6f/0x90
: [<ffffffff811471d6>] perf_tp_event+0x96/0x100
: [<ffffffff81146e15>] ? __perf_event_overflow+0x135/0x300
: [<ffffffff8113d332>] perf_trace_power+0xc2/0xe0
: [<ffffffff810c4913>] ? tick_broadcast_oneshot_control+0x83/0x130
: [<ffffffff81519335>] ? cpuidle_idle_call+0x2a5/0x540
: [<ffffffff81519335>] cpuidle_idle_call+0x2a5/0x540
: [<ffffffff810bd904>] ? ktime_get+0x64/0xe0
: [<ffffffff81147031>] perf_swevent_overflow+0x51/0xd0
: [<ffffffff81018225>] cpu_idle+0xc5/0x140
: [<ffffffff81677ccf>] rest_init+0x133/0x144
: [<ffffffff81677c15>] ? rest_init+0x79/0x144
: [<ffffffff8114711f>] perf_swevent_event+0x6f/0x90
: [<ffffffff811471d6>] perf_tp_event+0x96/0x100
: [<ffffffff81ef8c42>] start_kernel+0x3fc/0x407
: [<ffffffff8113d332>] perf_trace_power+0xc2/0xe0
: [<ffffffff81519335>] ? cpuidle_idle_call+0x2a5/0x540
: [<ffffffff81ef8346>] x86_64_start_reservations+0x131/0x135
: [<ffffffff81519335>] cpuidle_idle_call+0x2a5/0x540
: [<ffffffff81018225>] cpu_idle+0xc5/0x140
: [<ffffffff81ef844a>] x86_64_start_kernel+0x100/0x10f
Comment 1 Paul Alesius 2012-03-02 07:52:19 EST
This happened when I ran the command 'powertop'
Comment 2 Josh Boyer 2012-03-02 09:59:30 EST
*** Bug 799307 has been marked as a duplicate of this bug. ***
Comment 3 Josh Boyer 2012-03-02 10:00:32 EST
*** Bug 799305 has been marked as a duplicate of this bug. ***
Comment 4 Josh Boyer 2012-03-02 10:00:43 EST
*** Bug 799304 has been marked as a duplicate of this bug. ***
Comment 5 Josh Boyer 2012-03-02 14:25:34 EST
*** Bug 798068 has been marked as a duplicate of this bug. ***
Comment 6 Josh Boyer 2012-03-02 14:25:45 EST
*** Bug 798067 has been marked as a duplicate of this bug. ***
Comment 7 Josh Boyer 2012-03-02 14:25:53 EST
*** Bug 798066 has been marked as a duplicate of this bug. ***
Comment 8 Josh Boyer 2012-03-02 14:26:11 EST
*** Bug 797443 has been marked as a duplicate of this bug. ***
Comment 9 Josh Boyer 2012-03-02 14:26:36 EST
*** Bug 789641 has been marked as a duplicate of this bug. ***
Comment 10 Josh Boyer 2012-03-02 14:32:13 EST
The convoluted story here is that some new RCU warnings were added to the 3.3 kernel in the cpu idle paths.  These show up trivially when running 'powertop' on a kernel with lockdep enabled.

After some debugging upstream:

https://lkml.org/lkml/2012/1/24/203

Paul McKenney and Steven Rostedt came up with a large batch of patches to fix all the assorted issues:

https://lkml.org/lkml/2012/2/3/459
https://lkml.org/lkml/2012/2/13/528

However, those patches are queued for the 3.4 kernel and are somewhat too large to throw into the 3.3 release at this point.

The warnings aren't really exposing anything new in terms of functionality.  They are mostly just pointing out "issues" that have been present for some time now.  Also, they will go away when we disable the debugging options (except in kernel-debug of course).

For now, we're going to close this bug as UPSTREAM.  When the patches hit Linus' tree during the 3.4 merge window, some of them might get brought back into the 3.3 stable series.
Comment 11 Josh Boyer 2012-03-02 14:32:57 EST
*** Bug 794998 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.