Bug 795050 - f17 kernel SSSLOOOWWDOOOWN SLOW boot after update
f17 kernel SSSLOOOWWDOOOWN SLOW boot after update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 802081 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-18 18:05 EST by Reartes Guillermo
Modified: 2012-03-25 19:10 EDT (History)
13 users (show)

See Also:
Fixed In Version: kernel-3.3.0-0.rc4.git1.4.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-28 05:55:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
messages of the slowed down system (275.52 KB, text/plain)
2012-02-18 19:31 EST, Reartes Guillermo
no flags Details
dmesg of slowed down system (80.55 KB, text/plain)
2012-02-18 19:32 EST, Reartes Guillermo
no flags Details
i may help (1.47 KB, text/plain)
2012-02-18 19:33 EST, Reartes Guillermo
no flags Details
messages of a reinstalled f17 rc2 (1.08 MB, text/plain)
2012-02-22 15:33 EST, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-02-18 18:05:28 EST
Description of problem:

I installed F17 KDE LiveCD on my main AMD BOX,
FX6100 + SABERTOOTH 990FX, 16GB of RAM.

I had to report some bugs, notably the one that wiped my mbr. After the
first update, booting the box seems to be vveeeeerrrrryyyyyy sssssslllloooowww,
i don't know what is going on, but the kernel is SLOW, sometimes i seems like
it got frozen but minutes later boot continues, but alwats SSSLLLLOOOOOOOW.

I tried: selinux0 | nomodeset 1 | rd_NO_MD rd_NO_LUKS, rd_NO_DM, but it is allways slow, the slow kernel is: i will tell the version once the system boots or i reset it again (i will let it one hour time to reach something) (but the version was git7 somethinf)

this is when fedora switches to SLOW mode:

[8.xx] firewire_core: created device dw0: GUID 0017fc600001634b0, S400
timeout, giving up waiting for workers to finish
[38.x] dracut: switching root
[38.x]
[113.x]
and below, the typical time is [430.x] which is slooooww.

sorry, i took a photo, but it is something like that. each new dracut line takes
longer and longer.

the original kernel booted ok (with the new grub i was forced to install) with these
minimal parameters: ro root=/dev/sda5

after the update, neither kernel boots, so it is some userspace program.

Version-Release number of selected component (if applicable):
F17 alpha tc2

How reproducible:
allways

Steps to Reproduce:
1. install 
2. boot
3. update
4. slllllloooooooowwwwnnnneeeeeeesss
  
Actual results:
i still don't know if the sytstem boots due to it new inherent slowness.

Expected results:
normal boot

Additional info:
Comment 1 Reartes Guillermo 2012-02-18 18:12:01 EST
The kernel version is: 3.3.0-0.rc3.git7.2.fc17.x86_64
Comment 2 Reartes Guillermo 2012-02-18 19:31:48 EST
Created attachment 564102 [details]
messages of the slowed down system
Comment 3 Reartes Guillermo 2012-02-18 19:32:38 EST
Created attachment 564103 [details]
dmesg of slowed down system
Comment 4 Reartes Guillermo 2012-02-18 19:33:28 EST
Created attachment 564104 [details]
i may help
Comment 5 Reartes Guillermo 2012-02-18 19:36:31 EST
By waiting i managed to boot and reach console.

I was unable to enable sshd.service with systemclt, dbus problem or similar so i
launched it by hand:

# /sbin/sshd -c /etc/ssh/sshd_config

and flushed the firewall:

# iptables -F

This is my yum.log:

# cat yum.log 
Feb 18 02:42:00 Updated: libselinux-2.1.9-9.fc17.x86_64
Feb 18 02:42:00 Updated: libsemanage-2.1.6-3.fc17.x86_64
Feb 18 02:42:00 Updated: libselinux-python-2.1.9-9.fc17.x86_64
Feb 18 02:42:01 Updated: setroubleshoot-plugins-3.0.27-1.fc17.noarch
Feb 18 02:42:01 Updated: setroubleshoot-server-3.1.3-1.fc17.x86_64
Feb 18 02:42:02 Updated: authconfig-6.2.0-1.fc17.x86_64
Feb 18 02:42:02 Updated: 1:NetworkManager-glib-0.9.3-0.2.git20120215.fc17.x86_64
Feb 18 02:42:02 Updated: syslinux-4.05-1.fc17.x86_64
Feb 18 02:42:04 Updated: selinux-policy-3.10.0-89.fc17.noarch
Feb 18 02:42:04 Updated: sssd-client-1.8.0-4.fc17.beta3.x86_64
Feb 18 02:42:05 Updated: gstreamer-plugins-base-0.10.35-5.fc17.x86_64
Feb 18 02:42:05 Installed: libnl3-3.2.7-1.fc17.x86_64
Feb 18 02:42:06 Updated: 1:NetworkManager-0.9.3-0.2.git20120215.fc17.x86_64
Feb 18 02:42:06 Updated: createrepo-0.9.9-11.fc17.noarch
Feb 18 02:42:06 Installed: mactel-boot-0.9-1.fc17.x86_64
Feb 18 02:42:07 Updated: libipa_hbac-1.8.0-4.fc17.beta3.x86_64
Feb 18 02:42:07 Installed: hfsplus-tools-540.1.linux1-1.fc17.x86_64
Feb 18 02:42:07 Updated: mdadm-3.2.3-5.fc17.x86_64
Feb 18 02:42:07 Updated: openldap-2.4.29-1.fc17.x86_64
Feb 18 02:42:07 Updated: fcoe-utils-1.0.22-2.fc17.x86_64
Feb 18 02:42:07 Updated: thai-scalable-fonts-common-0.5.0-1.fc17.noarch
Feb 18 02:42:07 Updated: mesa-dri-filesystem-8.0.1-1.fc17.x86_64
Feb 18 02:42:10 Updated: mesa-dri-drivers-8.0.1-1.fc17.x86_64
Feb 18 02:42:10 Updated: mesa-libGL-8.0.1-1.fc17.x86_64
Feb 18 02:42:10 Updated: libdb-5.2.36-5.fc17.x86_64
Feb 18 02:42:10 Updated: libdb-utils-5.2.36-5.fc17.x86_64
Feb 18 02:42:11 Updated: mesa-libGLU-8.0.1-1.fc17.x86_64
Feb 18 02:42:11 Updated: 2:phonon-backend-gstreamer-4.6.0-1.fc17.x86_64
Feb 18 02:42:12 Updated: thai-scalable-waree-fonts-0.5.0-1.fc17.noarch
Feb 18 02:42:14 Updated: anaconda-17.9-1.fc17.x86_64
Feb 18 02:42:15 Updated: sssd-1.8.0-4.fc17.beta3.x86_64
Feb 18 02:42:33 Updated: selinux-policy-targeted-3.10.0-89.fc17.noarch
Feb 18 02:42:33 Updated: syslinux-extlinux-4.05-1.fc17.x86_64
Feb 18 02:42:34 Updated: authconfig-gtk-6.2.0-1.fc17.x86_64
Feb 18 02:42:34 Updated: setroubleshoot-3.1.3-1.fc17.x86_64
Feb 18 02:42:34 Updated: libsemanage-python-2.1.6-3.fc17.x86_64
Feb 18 02:42:34 Updated: libselinux-utils-2.1.9-9.fc17.x86_64
Feb 18 02:42:34 Updated: libsss_sudo-1.8.0-4.fc17.beta3.x86_64
Feb 18 02:42:34 Updated: 1:oxygen-gtk3-1.0.1-1.fc17.x86_64
Feb 18 02:42:35 Updated: alsa-utils-1.0.25-1.fc17.x86_64
Feb 18 02:42:35 Updated: 2:libpng-1.5.8-2.fc17.x86_64
Feb 18 02:42:35 Updated: qca-ossl-2.0.0-0.13.beta3.fc17.x86_64
Feb 18 02:42:35 Updated: python-kitchen-1.1.1-1.fc17.noarch
Feb 18 02:42:36 Updated: libpciaccess-0.12.902-5.fc17.x86_64
Feb 18 02:42:36 Updated: gpgme-1.3.0-6.fc17.x86_64
Feb 18 02:42:36 Updated: db4-4.8.30-9.fc17.x86_64
Feb 18 02:42:36 Updated: djvulibre-libs-3.5.24-3.fc17.x86_64
Feb 18 02:42:37 Updated: iptables-1.4.12.2-3.fc17.x86_64
Feb 18 02:42:37 Updated: ql2500-firmware-5.06.05-1.fc17.noarch
Feb 18 02:42:37 Updated: oxygen-gtk2-1.2.1-1.fc17.x86_64
Feb 18 02:42:37 Updated: 2:libpng-compat-1.5.8-2.fc17.x86_64
Feb 18 02:42:48 Installed: kernel-3.3.0-0.rc3.git7.2.fc17.x86_64
Feb 18 21:08:34 Updated: liberation-fonts-common-1.07.2-3.fc17.noarch
Feb 18 21:08:34 Updated: kross-interpreters-4.8.0-2.fc17.x86_64
Feb 18 21:08:34 Updated: kross-python-4.8.0-2.fc17.x86_64
Feb 18 21:08:35 Updated: liberation-sans-fonts-1.07.2-3.fc17.noarch
Feb 18 21:08:36 Updated: liberation-mono-fonts-1.07.2-3.fc17.noarch
Feb 18 21:08:38 Updated: liberation-serif-fonts-1.07.2-3.fc17.noarch
Feb 18 21:08:38 Updated: apper-0.7.1-0.7.20120218.fc17.x86_64
Feb 18 21:21:34 Installed: systemd-analyze-43-1.fc17.x86_64
Comment 6 Reartes Guillermo 2012-02-18 19:47:44 EST
# dmesg | grep stack
[    4.497904] cryptomgr_test used greatest stack depth: 6232 bytes left
[    4.498145] cryptomgr_test used greatest stack depth: 6056 bytes left
[    4.506426] modprobe used greatest stack depth: 4896 bytes left
[    7.461824] ata_id used greatest stack depth: 4592 bytes left
[    7.496256] ata_id used greatest stack depth: 3600 bytes left
[  306.657428] kworker/u:1 used greatest stack depth: 3496 bytes left
[  306.658180] kworker/u:10 used greatest stack depth: 3336 bytes left
[  455.627198] udevd used greatest stack depth: 2688 bytes left
[ 5189.938548] prelink used greatest stack depth: 2544 bytes left

I think i never saw this 'stack' messages in the past.
Comment 7 Reartes Guillermo 2012-02-20 12:57:14 EST
I downgraded systemd but no effect.

Once in xorg failsafe, individual (ad hoc definition: program that seems to not
to use some service or librarie) programs do work at normal speed. For example
glxgears worked, but firefox exhibited the slowness.
Comment 8 Reartes Guillermo 2012-02-21 15:50:43 EST
It seems to me that it is system specific and not a general issue.

Alpha TC2 KDE LiveCD:
 * boots correctly in an AMD FX + 990FX Chipset
 * installs correcly in an AMD FX + 990FX Chipset
 * becomes SLOW after updating installed system AMD FX + 990FX Chipset

 * boots correctly in an Intel Core2 Duo Laptop
 * boots correctly in an Intel Corei i5 Laptop

 I only installed it on one system.

Alpha TC3 KDE LiveCD:
 
 * boots correctly in an Intel Corei i5 Laptop

 * boots SLOW on an AMD FX + 990FX Chipset

 Since the same media behaves diferently, it seems to indicate a system specific isuse wich affects the AMD system. And remember that the AMD system worked perfectly with the Alpha TC2 KDE LiveCD and Installed system (with no updates).
Comment 9 Reartes Guillermo 2012-02-21 16:00:27 EST
The Alpha TC3 KDE LiveCD image did not finish to load on the AMD system, 
the livesys service faulted and i got firstboot instead. not very useful.

I will attach some hw info about the affected system from my main os. (F15)
Comment 10 Reartes Guillermo 2012-02-21 16:32:58 EST
The board is an Asus Sabertooth 990FX with an AMD FX6100 CPU:

# cat /sys/devices/virtual/dmi/id/board_name 
SABERTOOTH 990FX

# cat /sys/devices/virtual/dmi/id/board_version 
Rev 1.xx

# cat /sys/devices/virtual/dmi/id/bios_version 
0813

# lspci -nn 
00:00.0 Host bridge [0600]: ATI Technologies Inc RD890 PCI to PCI bridge (external gfx0 port B) [1002:5a14] (rev 02)
00:00.2 Generic system peripheral [0806]: ATI Technologies Inc Device [1002:5a23]
00:02.0 PCI bridge [0604]: ATI Technologies Inc RD890 PCI to PCI bridge (PCI express gpp port B) [1002:5a16]
00:04.0 PCI bridge [0604]: ATI Technologies Inc RD890 PCI to PCI bridge (PCI express gpp port D) [1002:5a18]
00:05.0 PCI bridge [0604]: ATI Technologies Inc RD890 PCI to PCI bridge (PCI express gpp port E) [1002:5a19]
00:06.0 PCI bridge [0604]: ATI Technologies Inc RD890 PCI to PCI bridge (PCI express gpp port F) [1002:5a1a]
00:09.0 PCI bridge [0604]: ATI Technologies Inc RD890 PCI to PCI bridge (PCI express gpp port H) [1002:5a1c]
00:11.0 SATA controller [0106]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] [1002:4391] (rev 40)
00:12.0 USB Controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397]
00:12.2 USB Controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396]
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397]
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396]
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 42)
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller [1002:439d] (rev 40)
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384] (rev 40)
00:14.5 USB Controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI2 Controller [1002:4399]
00:15.0 PCI bridge [0604]: ATI Technologies Inc SB700/SB800 PCI to PCI bridge (PCIE port 0) [1002:43a0]
00:15.1 PCI bridge [0604]: ATI Technologies Inc SB700/SB800 PCI to PCI bridge (PCIE port 1) [1002:43a1]
00:16.0 USB Controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397]
00:16.2 USB Controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] Family 15h Processor Function 0 [1022:1600]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] Family 15h Processor Function 1 [1022:1601]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] Family 15h Processor Function 2 [1022:1602]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] Family 15h Processor Function 3 [1022:1603]
00:18.4 Host bridge [0600]: Advanced Micro Devices [AMD] Family 15h Processor Function 4 [1022:1604]
00:18.5 Host bridge [0600]: Advanced Micro Devices [AMD] Family 15h Processor Function 5 [1022:1605]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc NI Caicos [AMD RADEON HD 6450] [1002:6779]
01:00.1 Audio device [0403]: ATI Technologies Inc NI Caicos HDMI Audio [AMD RADEON HD 6450] [1002:aa98]
02:00.0 SATA controller [0106]: JMicron Technology Corp. JMB362 AHCI Controller [197b:2362] (rev 10)
03:00.0 SATA controller [0106]: JMicron Technology Corp. JMB362 AHCI Controller [197b:2362] (rev 10)
04:00.0 USB Controller [0c03]: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller [1b21:1042]
05:00.0 USB Controller [0c03]: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller [1b21:1042]
06:05.0 Multimedia audio controller [0401]: Creative Labs CA0106 Soundblaster [1102:0007]
06:07.0 FireWire (IEEE 1394) [0c00]: VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller [1106:3044] (rev c0)
08:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
Comment 11 Adam Williamson 2012-02-21 18:34:18 EST
There is no TC3. Are you rather talking about RC2 compared to RC3?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Adam Williamson 2012-02-21 18:35:24 EST
If so, the suspect here is almost certainly the kernel, which was bumped to 3.3.0-0.rc3.git7.2.fc17 in RC3. udev was not touched.
Comment 13 Reartes Guillermo 2012-02-21 18:58:35 EST
Sorry, yes, RC2 and RC3.

RC4 is being downloaded at the momment.
Comment 14 Josh Boyer 2012-02-21 19:28:50 EST
The upstream shortlog between -git5 (what I'm guessing was in the 'non-slow' version of RC) and -git7.2 is:

Adrian Hunter (1):
      mmc: sdhci-pci: set Medfield SDIO as non-removable

Axel Lin (1):
      regulator: Fix getting voltage in max8649_enable_time()

Benjamin Herrenschmidt (3):
      powerpc/wsp: Permanently enable PCI class code workaround
      powerpc/wsp: Fix IRQ affinity setting
      powerpc: Fix WARN_ON in decrementer_check_overflow

Brian King (1):
      powerpc/pseries: Fix partition migration hang in stop_topology_update

Daniel T Chen (1):
      ALSA: intel8x0: Fix default inaudible sound on Gateway M520

David Miller (1):
      regulator: Fix mc13xxx regulator modular build (again)

Girish K S (2):
      mmc: core: Fix low speed mmc card detection failure
      mmc: core: Fix PowerOff Notify suspend/resume

Guennadi Liakhovetski (2):
      mmc: tmio_mmc: fix card eject during IO with DMA
      mmc: sh_mmcif: fix late delayed work initialisation

Jaehoon Chung (1):
      mmc: core: add the capability for broken voltage

Jan Beulich (1):
      xenbus_dev: add missing error check to watch handling

Jean-Christophe PLAGNIOL-VILLARD (1):
      mmc: of_mmc_spi: fix little endian support

Jerry Huang (2):
      mmc: esdhc: add PIO mode support
      mmc: esdhc: set the timeout to the max value

Jurgen Heeks (1):
      mmc: core: Fix comparison issue in mmc_compare_ext_csds

Konrad Rzeszutek Wilk (3):
      xen/bootup: During bootup suppress XENBUS: Unable to read cpu state
      xen/smp: Fix CPU online/offline bug triggering a BUG: scheduling while atomic.
      xen/pci[front|back]: Use %d instead of %1x for displaying PCI devfn.

Kuninori Morimoto (1):
      ASoC: fsi: fixup fsi_pointer() calculation method

Linus Torvalds (11):
      Merge tag 'sound-fixes' of git://git.kernel.org/.../tiwai/sound
      Merge tag 'stable/for-linus-fixes-3.3-rc3' of git://git.kernel.org/.../konrad/xen
      Merge tag 'mmc-fixes-for-3.3-rc4' of git://git.kernel.org/.../cjb/mmc
      Merge branch 'merge' of git://git.kernel.org/.../benh/powerpc
      Merge tag 'for-linus' of git://git.kernel.org/.../broonie/regulator
      i387: fix sense of sanity check
      i387: fix x86-64 preemption-unsafe user stack save/restore
      i387: move TS_USEDFPU clearing out of __save_init_fpu and into callers
      i387: don't ever touch TS_USEDFPU directly, use helper functions
      i387: do not preload FPU state at task switch time
      i387: move AMD K7/K8 fpu fxsave/fxrstor workaround from save to restore

Ludovic Desroches (1):
      mmc: atmel-mci: save and restore sdioirq when soft reset is performed

Michael Ellerman (1):
      powerpc/powernv: Disable interrupts while taking phb->lock

Philip Rakity (1):
      mmc: core: UHS sdio card that fails should not exceed 50MHz

Rabin Vincent (1):
      mmc: block: Init ro_lock sysfs attr to fix lockdep warnings

Roy Zang (1):
      mmc: esdhc: fix errors when booting kernel on Freescale eSDHC version 2.3

Seungwon Jeon (1):
      mmc: dw_mmc: Fix PIO mode with support of highmem

Srikar Dronamraju (1):
      powerpc: Implement GET_IP/SET_IP

Stefano Stabellini (1):
      xen pvhvm: do not remap pirqs onto evtchns if !xen_have_vector_callback

Sujit Reddy Thumma (1):
      mmc: core: Ensure clocks are always enabled before host interaction

Takashi Iwai (5):
      ALSA: hda - Fix mute-LED VREF value for new HP laptops
      ALSA: hda - Fix initialization of secondary capture source on VT1705
      ALSA: hda - Fix silent speaker output on Acer Aspire 6935
      Merge branch 'fix/acer-alc889-fix' into fix/hda
      Merge tag 'asoc-3.3' of git://git.kernel.org/.../broonie/sound into for-linus

Thadeu Lima de Souza Cascardo (1):
      powerpc/pseries/eeh: Fix crash when error happens during device probe


So basically some ALSA, powerpc, and mmc changes, along with Linus' i387 reworking.  Nothing that immediately strikes me as causing major slowness.

On the Fedora side, we have a patch added to fix an mce rcu splat (789644), another to fix RCU usage during cpu idle (789641), the compat-wireless stuff is disabled, and a couple of other minor changes.

The only thing that looks like it could possibly cause slowdowns is the patch for bug 789641, but even that is somewhat iffy.
Comment 15 Loïc Yhuel 2012-02-21 19:41:24 EST
I have the same issue on a Toshiba Satellite Pro A300 laptop (Core2 Duo T5870 CPU).
I'm running F16 x86_64, and the problem appeared when trying rawhide kernels.

The problem is fixed if I remove x86-Avoid-invoking-RCU-when-CPU-is-idle.patch.
Comment 16 Josh Boyer 2012-02-21 20:01:39 EST
(In reply to comment #15)
> I have the same issue on a Toshiba Satellite Pro A300 laptop (Core2 Duo T5870
> CPU).
> I'm running F16 x86_64, and the problem appeared when trying rawhide kernels.
> 
> The problem is fixed if I remove x86-Avoid-invoking-RCU-when-CPU-is-idle.patch.

Thanks for the pointer.  I don't see that in any of my local testing, but I'll drop that patch for now and follow up with upstream.
Comment 17 Josh Boyer 2012-02-21 20:03:44 EST
I've started a build with this patch removed:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3809140

I would appreciate it if people experiencing the slowness could test it out when  it finishes building.
Comment 18 Fedora Update System 2012-02-22 14:58:13 EST
kernel-3.3.0-0.rc4.git1.4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.0-0.rc4.git1.4.fc17
Comment 19 Reartes Guillermo 2012-02-22 15:31:20 EST
I reinstalled the system again and tested http://koji.fedoraproject.org/koji/taskinfo?taskID=3809140

and found that it boot at normal speed :-)
so, it seems to fix the hyper-slowness issue.



This message (short form) appears each boot:

[ INFO: possible recursive locking detected ]
3.3.0-0.rc4.git1.4.fc17.x86_64 #1 Not tainted
---------------------------------------------
pulseaudio/1255 is trying to acquire lock:

CPU0----

lock(&(&substream->self_group.lock)->rlock/1);
lock(&(&substream->self_group.lock)->rlock/1);

*** DEADLOCK ***



After log-in, it slows down a bit (but nothing compared to previous issue).

I will attach the messages file to see if this related to this issue or another bugreport should be opened.

Thanks.
Comment 20 Reartes Guillermo 2012-02-22 15:33:01 EST
Created attachment 565094 [details]
messages of a reinstalled f17 rc2
Comment 21 Loïc Yhuel 2012-02-22 15:46:01 EST
(In reply to comment #17)
> I've started a build with this patch removed:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3809140
> 
> I would appreciate it if people experiencing the slowness could test it out
> when  it finishes building.

With this kernel, the boot is a little slow (but a lot faster than kernels with the RCU patch), X is quite slow (high CPU usage).
But this is because it's a debug kernel, the same kernel with a release configuration behaves correctly.

I don't have any unusual kernel message.
Comment 22 Fedora Update System 2012-02-23 17:31:05 EST
Package kernel-3.3.0-0.rc4.git1.4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.0-0.rc4.git1.4.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2304/kernel-3.3.0-0.rc4.git1.4.fc17
then log in and leave karma (feedback).
Comment 23 Reartes Guillermo 2012-02-23 22:10:43 EST
i have opened another bugreport for the deadlock issue.
Comment 24 Adam Williamson 2012-02-27 19:42:34 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 Adam Williamson 2012-02-28 00:41:25 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 26 Fedora Update System 2012-02-28 05:55:54 EST
kernel-3.3.0-0.rc4.git1.4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Josh Boyer 2012-03-12 09:43:07 EDT
*** Bug 802081 has been marked as a duplicate of this bug. ***
Comment 28 Harald Reindl 2012-03-25 19:10:23 EDT
this isse seems to be back in F16 with 3.3 kernels
https://bugzilla.redhat.com/show_bug.cgi?id=806548

Note You need to log in before you can comment on or make changes to this bug.