Bug 790607 - F17 Alpha KDE desktop background is blank (all black)
F17 Alpha KDE desktop background is blank (all black)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: beefy-miracle-kde-theme (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
AcceptedNTH RejectedBlocker
:
Depends On:
Blocks: F17Alpha-accepted/F17AlphaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-02-14 17:22 EST by Kevin Kofler
Modified: 2012-02-20 21:23 EST (History)
9 users (show)

See Also:
Fixed In Version: kde-settings-4.8-5.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-20 21:23:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2012-02-14 17:22:19 EST
Description of problem:
Due to an error in the brand new F17 artwork, the desktop background in KDE Plasma is all black by default. Updates fixing this are already queued for stable and we really want them in the Alpha, so feedback for the new artwork can be obtained, "sneek preview" reviews show working artwork in screenshots etc.

Version-Release number of selected component (if applicable):
beefy-miracle-kde-theme-16.91.0-1.fc17

How reproducible:
Always

Steps to Reproduce:
1. Boot the KDE Live CD.
  
Actual results:
Black desktop background.

Expected results:
Useful desktop background.

Additional info:
The fix: https://admin.fedoraproject.org/updates/beefy-miracle-kde-theme-16.91.0.1-1.fc17,kde-settings-4.8-5.fc17
Comment 1 Fedora Update System 2012-02-14 17:28:57 EST
kde-settings-4.8-5.fc17, beefy-miracle-kde-theme-16.91.0.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/beefy-miracle-kde-theme-16.91.0.1-1.fc17,kde-settings-4.8-5.fc17
Comment 2 Tim Flink 2012-02-14 17:36:30 EST
I'm pretty much +/- 0 on blocker for this. AFAIK, the alpha artwork criterion is primarily there to make sure we don't get confusion between Fn and Fn+1 alpha. A black desktop, however ugly, isn't likely to be confused with the F16 artwork for KDE.

I'm definitely +1 NTH, though. Updating the artwork is relatively low-risk and good to have for Alpha.

If a tested fix is available, the difference between the two is mostly academic, though.
Comment 3 Kevin Kofler 2012-02-14 17:44:47 EST
I'm OK with NTH as long as the fix gets in. :-) (The issue being that there's talk of going straight to RC1 instead of TC3, which means it'd need to be pulled in immediately. FWIW, I don't think rushing ahead of schedule is that great an idea.)
Comment 4 satellitgo 2012-02-14 18:23:13 EST
1-) Fedora-17-Alpha-TC2-i686-Live-KDE.iso has "Vern" background running live CD with enforcing=0

2-)Last successful nightly compose:
 Fedora-17-Nightly-20120210.09-i686-Live-kde.iso has "Vern" background running live CD with enforcing=0

3-) without enforcing=0:
Fedora-17-Nightly-20120210.09-i686-Live-kde.iso has "Vern" background 
"unable to log in live user"

Does this only apply to installs from non live media?
Comment 5 Kevin Kofler 2012-02-14 18:30:05 EST
This got changed post TC2.

Try the 20120214 nightly:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3790203
http://koji.fedoraproject.org/koji/taskinfo?taskID=3790202
It has the affected builds.
Comment 6 Kevin Kofler 2012-02-14 18:32:14 EST
Minor correction:

> Version-Release number of selected component (if applicable):
> beefy-miracle-kde-theme-16.91.0-1.fc17

Actually, the faulty NVR is:
beefy-miracle-kde-theme-16.91.0-2.fc17

It's fixed in 16.91.0.1 in any case.
Comment 7 Adam Williamson 2012-02-14 19:52:50 EST
+1 nth, -1 blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 satellitgo 2012-02-14 19:59:20 EST
(In reply to comment #4)
> 1-) Fedora-17-Alpha-TC2-i686-Live-KDE.iso has "Vern" background running live CD
> with enforcing=0
> 
> 2-)Last successful nightly compose:
>  Fedora-17-Nightly-20120210.09-i686-Live-kde.iso has "Vern" background running
> live CD with enforcing=0
> 
> 3-) without enforcing=0:
> Fedora-17-Nightly-20120210.09-i686-Live-kde.iso has "Vern" background 
> "unable to log in live user"
> 
> Does this only apply to installs from non live media?

5-)Fedora-17-Nightly-20120214.09-i686-Live-kde
*Error Message:
 (^) Logging in liveuser...
 Warning: Cannot open consolekit session: Unable to open session: Unable to get information about the calling process
*'''Fireworks Background - NEW Artwork''' while loading. Then fades to black background
*Logout /login liveuser
: get Fireworks background again while loading  Then fades to black background
>Get the same results on enforcing=0 on boot line
Comment 9 satellitgo 2012-02-14 20:03:30 EST
no repomd file when invoking yum install
Comment 10 satellitgo 2012-02-14 20:06:12 EST
(In reply to comment #9)
> no repomd file when invoking yum install

https://bugzilla.redhat.com/show_bug.cgi?id=790530
Comment 11 Kevin Kofler 2012-02-14 21:18:31 EST
> Warning: Cannot open consolekit session: Unable to open session: Unable to get
> information about the calling process

Already reported at:
https://bugzilla.redhat.com/show_bug.cgi?id=787855#c3
Comment 12 Adam Williamson 2012-02-15 16:43:16 EST
Marking as accepted NTH, rejected blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 satellitgo 2012-02-16 03:41:34 EST
(In reply to comment #8)
> (In reply to comment #4)
> > 1-) Fedora-17-Alpha-TC2-i686-Live-KDE.iso has "Vern" background running live CD
> > with enforcing=0
> > 
> > 2-)Last successful nightly compose:
> >  Fedora-17-Nightly-20120210.09-i686-Live-kde.iso has "Vern" background running
> > live CD with enforcing=0
> > 
> > 3-) without enforcing=0:
> > Fedora-17-Nightly-20120210.09-i686-Live-kde.iso has "Vern" background 
> > "unable to log in live user"
> > 
> > Does this only apply to installs from non live media?
> 
> 5-)Fedora-17-Nightly-20120214.09-i686-Live-kde
> *Error Message:
>  (^) Logging in liveuser...
>  Warning: Cannot open consolekit session: Unable to open session: Unable to get
> information about the calling process
> *'''Fireworks Background - NEW Artwork''' while loading. Then fades to black
> background
> *Logout /login liveuser
> : get Fireworks background again while loading  Then fades to black background
> >Get the same results on enforcing=0 on boot line

2012 feb  15 - RC2 netinstall x86-64 of 6 desktops - (customize now) :LDXE, Gnome, KDE Plasma, KDE Plasma (Failsafe) ,Openbox, Sugar, Xfcd session.

KDE Plasma (and Failsafe) have black background after startup sequence shows fireworks background.

LDXE; Gnome3.3.5; Xfce have the fireworks background. Openbox has grey screen.
Comment 14 satellitgo 2012-02-16 08:41:52 EST
KDE black background fixed by right corner screen [Desktop-toolbox]/Desktop settings/View/wallpaper image/Beefy Miracle [apply]
Then fireworks background is correct
Comment 15 Adam Williamson 2012-02-16 12:23:27 EST
A network install is not a good way to test, because you won't necessarily get the fixed packages. If you look you'll find you have the older versions of beefy-miracle-kde-theme and kde-settings, because there hasn't been an F17 updates push yet.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Fedora Update System 2012-02-20 21:23:35 EST
kde-settings-4.8-5.fc17, beefy-miracle-kde-theme-16.91.0.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.