Bug 79271 - bad PS font substitutions
bad PS font substitutions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: libgnomeprint22 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
: Triaged
: 107862 (view as bug list)
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-12-09 07:56 EST by Tim Waugh
Modified: 2007-04-18 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 11:10:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2002-12-09 07:56:24 EST
Description of Problem:
Sorry this is so vague, but: when printing an (HTML format) email, sometimes the
font is substituted for a ridiculous one.

Version-Release number of selected component (if applicable):
evolution-1.2.0-3

For instance, an email containing <font face="Verdana, Arial, Helvetica"
color="003399" size="2"> generated PS output like this:

[...]
%%DocumentSuppliedResources: procset gnome-print-procs-0.35
%%+ font GnomeUni-AmericanIndian-Regular
%%+ font GnomeUni-Helvetica
%%+ font GnomeUni-Helvetica-Bold
%%EndComments
[...]

(AmericanIndian is a symbol font I happen to have installed.)
Comment 1 Jeremy Katz 2002-12-09 12:30:59 EST
This is all gnome-print...
Comment 2 Owen Taylor 2003-01-14 12:42:01 EST
Can you re-test with gnome-print-0.37?
Comment 3 Tim Waugh 2003-01-16 08:47:12 EST
It's different behaviour, certainly.  Rather than picking 'AmericanIndian' it
now picks '4MyLover'.

It happened to be legible, but it's not by any means appropriate!

Relevant PS snippet again:

%%DocumentSuppliedResources: procset gnome-print-procs-0.37
%%+ font GnomeUni-4-my-lover-Regular
%%+ font GnomeUni-Helvetica
%%+ font GnomeUni-Helvetica-Bold
%%EndComments

Comment 4 Tim Waugh 2003-02-06 10:17:31 EST
gedit used to do the same thing for any text, but now seems to be fixed.

But evolution still does the same thing.
Comment 5 Tim Waugh 2003-06-04 04:58:44 EDT
State of rawhide:

gedit is still behaving itself, but now evolution is worse than before: now the
message doesn't have to be HTML.  A plain text email comes out in the wrong font.

$ rpm -q evolution; rpm -q --whatprovides $(rpm -q --requires evolution | grep
gnomeprint)
evolution-1.3.92-1
libgnomeprint22-2.2.1.1-3
libgnomeprintui22-2.2.1.1-1
Comment 6 Thomas Zehetbauer 2003-06-26 20:21:49 EDT
Upgrading to libgnomeprint22-2.2.1.2-2 from rawhide solved this problem for me
(RedHat9/Ximian evolution-1.4.0-0.ximian.6.6)
Comment 7 Tim Waugh 2003-06-27 04:33:52 EDT
What I see with that version is mostly the right font, with the exception of the
font used for page numbers at the bottom of the page.  I am using
evolution-1.4.0-2 now, and libgnomeprint22-2.2.1.2-2.
Comment 8 Owen Taylor 2003-08-29 09:44:54 EDT
Problem is that evolution is asking for "Helvetica", which isn't
there, then gnome-print falls back to "Helvetica" which isn't there,
so gnome-print falls back to whatever is alphabetically first.

Filed gnome-print bug as:

http://bugzilla.gnome.org/show_bug.cgi?id=120954

Evolution bug as:

http://bugzilla.ximian.com/show_bug.cgi?id=48013

With a patch in libgnomeprint, there is no real reason to fix it
in our Evolution packages before it is fixed upstream.

* Thu Aug 28 2003 Owen Taylor <otaylor@redhat.com> 2.3.1-2
- Make the fallback font "Sans Regular", not "Helvetica". Helvetica
  was ending up picking the alphabetically first font on the system.
  (#79271. Tim Waugh)
Comment 9 Tim Waugh 2003-12-23 09:27:22 EST
This is happening again.
Comment 10 Tim Waugh 2003-12-23 09:32:00 EST
*** Bug 107862 has been marked as a duplicate of this bug. ***
Comment 11 Tim Waugh 2003-12-23 09:32:59 EST
It broke between 2.3.1-2 and 2.4.0-1.
Comment 12 Tim Waugh 2003-12-23 09:41:16 EST
Hmm, I'm wrong; 2.3.1-2 also fails.  Red Hat Linux 9 worked though,
I'm pretty sure.
Comment 13 Tim Waugh 2004-01-14 18:00:42 EST
libgnomeprint22-2.4.2-1.1 fixes the problem -- will it be available as
a Fedora Core 1 update?
Comment 14 Dan Tucny 2004-04-12 14:29:19 EDT
I can confirm, libgnomeprint22-2.4.2-1.1 does indeed fix this
problem... Is it going to be released?
Comment 15 Owen Taylor 2004-08-03 11:10:23 EDT
Not going to do a FC1 update at this point.

Note You need to log in before you can comment on or make changes to this bug.