Bug 794971 - Missing gpodder deps: python-eyed3, python-pymtp
Missing gpodder deps: python-eyed3, python-pymtp
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: gpodder (Show other bugs)
el6
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
: Reopened
Depends On: 209894 643199 795591 795592
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-18 07:21 EST by Nux
Modified: 2018-04-11 04:19 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-pymtp-0.0.4-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-19 14:05:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nux 2012-02-18 07:21:08 EST
Description of problem:
PAckage gpodder in EPEL for EL6 has missing deps: python-eyed3, python-pymtp

Version-Release number of selected component (if applicable):
2.19-1.el6

How reproducible:
always

Steps to Reproduce:
1. add EPEL repo to vanilla EL6
2. yum install gpodder

  
Actual results:


Expected results:


Additional info:
Backporting python-eyed3 and python-pymtp from F14 was easy and solved the problem.
Reported at http://forums.nux.ro/index.php?t=msg&goto=153
Comment 1 Matěj Cepl 2012-02-20 19:41:41 EST
(In reply to comment #0)
> Description of problem:
> PAckage gpodder in EPEL for EL6 has missing deps: python-eyed3, python-pymtp

Created requested bugs for other components. Let's see what happens.
Comment 2 Matěj Cepl 2012-02-26 17:26:17 EST
(In reply to comment #1)
> (In reply to comment #0)
> > Description of problem:
> > PAckage gpodder in EPEL for EL6 has missing deps: python-eyed3, python-pymtp
> 
> Created requested bugs for other components. Let's see what happens.

After thinking about it longer, I actually don't want to maintain EL-6 branch of gpodder anymore (I don't use it at all anymore, switched to Android podcatchers exclusively).

Are you a Fedora packager or do you know one willing to take over maintainer of this (and related) EPEL packages?
Comment 3 Nux 2012-02-27 02:15:26 EST
Unfortunately I don't.. 

Then maybe it would be better to remove it from EPEL altogether than leave it with broken deps like it is now..
Comment 4 Matěj Cepl 2012-02-27 04:49:39 EST
(In reply to comment #3)
> Unfortunately I don't.. 
> 
> Then maybe it would be better to remove it from EPEL altogether than leave it
> with broken deps like it is now..

Yes, that's what I will do if I won't find anybody interested soon.
Comment 5 Kristofer M White 2012-05-15 02:59:44 EDT
I'm interested in it. I've never maintained a package for a distro before, though (just DEBs at my office). I had planned on pursuing maintainership anyway for a xxxterm package I put together. Is that sufficient?
Comment 6 Kristofer M White 2012-05-15 03:05:04 EDT
Forgive the prior comment, but what I'm stating is that given that I'm already looking into pursing maintainership of a package that I couldn't already find, I know I need to get a mentor (per http://fedoraproject.org/wiki/Join_the_package_collection_maintainers). Even though you're looking to relinquish this package, would you be willing to be the mentor for these or should I continue to look for one?
Comment 7 Matěj Cepl 2012-05-15 06:15:56 EDT
(In reply to comment #6)
> Forgive the prior comment, but what I'm stating is that given that I'm already
> looking into pursing maintainership of a package that I couldn't already find,
> I know I need to get a mentor (per
> http://fedoraproject.org/wiki/Join_the_package_collection_maintainers). Even
> though you're looking to relinquish this package, would you be willing to be
> the mentor for these or should I continue to look for one?

Sure, make yourself a comaintainer at https://admin.fedoraproject.org/pkgdb/acls/name/gpodder and you can start with fixing this bug ;) (if you need a help from a superhero with provenmanagers superhuman powers, let me know).
Comment 8 Kristofer M White 2012-05-17 04:20:05 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > Forgive the prior comment, but what I'm stating is that given that I'm already
> > looking into pursing maintainership of a package that I couldn't already find,
> > I know I need to get a mentor (per
> > http://fedoraproject.org/wiki/Join_the_package_collection_maintainers). Even
> > though you're looking to relinquish this package, would you be willing to be
> > the mentor for these or should I continue to look for one?
> 
> Sure, make yourself a comaintainer at
> https://admin.fedoraproject.org/pkgdb/acls/name/gpodder and you can start with
> fixing this bug ;) (if you need a help from a superhero with provenmanagers
> superhuman powers, let me know).

I may need that help. I tried to log in, but was unable to. When trying to reset my password, I got the message:

"Your account currently has status admin_disabled. For more information, please contact accounts@fedoraproject.org"

I've contacted accounts@ and will try for co-maintainership after things with my account get squared away.

Thanks!
Comment 9 Matěj Cepl 2012-05-17 05:21:21 EDT
you can try also #fedora-admin channel on Freenode.
Comment 10 Matěj Cepl 2013-09-27 06:55:25 EDT
Giving up on gpodder in EL-6
Comment 11 Tero Nieminen 2013-12-16 05:23:13 EST
I think this bug has a maintenance issue:

The current gpodder package ought to be removed from EPEL(/el6) ASAP, at least until a new maintainer can be found for the package. Currently there is no any point in keeping the dependency broken package that won't even install in the repo (at least it wont install on current Centos 6 (most likely not on RHEL6 either).

Though I would rather see someone take the maintainship of the package: judging from the comments in this bug it might not be all that much work to at least replace the current gpodder package with a working one from some (old) Fedora distribution (F14?), albeit it would then be an outdated version of gpodder (or maybe the above commneters were wrong). Of course, the best option would be to replace the current gpodder with an reasonably up to date version (if that is at all possible to achieve).

Anyway, the current situation does not reflect at all well the EPEL strive for high quality and some action would definitely be needed...
Comment 12 Matěj Cepl 2013-12-16 09:35:14 EST
(In reply to Tero Nieminen from comment #11)
> I think this bug has a maintenance issue:

Don't tell what other people should do, tell us what you will do for this bug (thank you, JFK).
Comment 13 Christopher Meng 2013-12-21 23:29:51 EST
I've requested commit to this package since I need it for listening to podcast for English studying.

Matěj, I think I can solve 50% of this bug, since eyd3 is my package now.

I will request a el6 branch of eyd3 today.
Comment 14 Fedora Update System 2013-12-28 01:22:36 EST
python-eyed3-0.7.4-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-eyed3-0.7.4-1.el6
Comment 15 Christopher Meng 2014-01-02 21:28:34 EST
Unfortunately, only pymtp 0.0.4 version can be pushed to EPEL6 as from 0.0.5 it requires libmtp 1.1+, so I can only package 0.0.4 to EPEL6.
Comment 16 Fedora Update System 2014-01-02 22:27:46 EST
python-pymtp-0.0.4-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-pymtp-0.0.4-1.el6
Comment 17 Fedora Update System 2014-01-03 00:33:15 EST
python-pymtp-0.0.4-1.el6 has been pushed to the Fedora EPEL 6 testing repository.
Comment 18 Fedora Update System 2014-01-12 14:19:29 EST
python-eyed3-0.7.4-1.el6 has been pushed to the Fedora EPEL 6 stable repository.
Comment 19 Fedora Update System 2014-01-19 14:05:39 EST
python-pymtp-0.0.4-1.el6 has been pushed to the Fedora EPEL 6 stable repository.
Comment 20 Christopher Meng 2014-01-19 22:40:39 EST
Hi Nux repo admin,

The above packages will be also available in EPEL7 soon, I will build them later.

Request some feedback.

BTW gpodder need to be rebased to 3.x in rawhide and epel7 IMO, will do this later if you agree.
Comment 21 Matěj Cepl 2014-01-20 05:34:15 EST
(In reply to Christopher Meng from comment #20)
> BTW gpodder need to be rebased to 3.x in rawhide and epel7 IMO, will do this
> later if you agree.

I have some start on rebasing in http://luther.ceplovi.cz/git/gpodder-pkg.git/ (not finished). Take a look.
Comment 22 Christopher Meng 2014-01-20 23:19:26 EST
Fine, thanks for your hard work.

I've sent email the owner of gpodder, their answers are vague because 3.x has new structure of files, users will basically lose all their settings and podcasts unless they figure out that there is a gpodder-migrate2tres script which they need to run manually in a shell.

But one thing interesting is that gpodder sometimes will ignore the upgrade path results from migration script as well(Debian poor sod...)

https://groups.google.com/forum/#!topic/linux.debian.bugs.dist/flAjU8K_3nA

Note You need to log in before you can comment on or make changes to this bug.