Bug 798501 - References to Pool family should be removed.
References to Pool family should be removed.
Status: CLOSED DUPLICATE of bug 803628
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: beta6
: ---
Assigned To: Jason Guiditta
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 23:22 EST by Aziza Karol
Modified: 2012-05-01 11:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 10:32:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pool family (217.73 KB, image/png)
2012-02-28 23:23 EST, Aziza Karol
no flags Details
ref pool family (196.00 KB, image/png)
2012-03-23 05:43 EDT, Aziza Karol
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0583 normal SHIPPED_LIVE new packages: aeolus-conductor 2012-05-15 18:31:59 EDT

  None (edit)
Description Aziza Karol 2012-02-28 23:22:14 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
Navigate to default cloud->Role assignment->Grant access.
Pool family text displayed.see attached screenshot.
  


Expected results:
 Pool family to be replaced with Cloud

Additional info:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-10.el6.noarch
aeolus-conductor-daemons-0.8.0-38.el6.noarch
aeolus-all-0.8.0-38.el6.noarch
rubygem-aeolus-cli-0.3.0-11.el6.noarch
aeolus-conductor-doc-0.8.0-38.el6.noarch
aeolus-configure-2.5.0-15.el6.noarch
aeolus-conductor-0.8.0-38.el6.noarch
Comment 1 Aziza Karol 2012-02-28 23:23:01 EST
Created attachment 566447 [details]
pool family
Comment 2 Scott Seago 2012-03-02 11:36:03 EST
The reusable permissions panel references the model object type for display -- which would include Deployable, PoolFamily, etc. The fix is the same as for 798501 -- we need i18n strings for the classnames.
Comment 3 Jason Guiditta 2012-03-02 16:32:05 EST
commit 90393e54cf96df58a2b4c2960abef14bcaa9c743
Author: Jason Guiditta <jguiditt@redhat.com>
Date:   Fri Mar 2 16:21:54 2012 -0500

    BZs #798501 and #798505: Object names should be pulled from mapping file
    
    https://bugzilla.redhat.com/show_bug.cgi?id=798505
    https://bugzilla.redhat.com/show_bug.cgi?id=798501
    
    This boils down to the following: The strings in question were NOT
    being internationalized, they were pulled from the class names.  This
    patch adds a mapping i18n file, which fixes both bugs (and any similar)
    and future ones saying we don't internationalize the class names.
    
    It is possible there are other cases beside permissions where this
    maybe be the case, but if so, it is a simple matter of repeating the
    pattern here and add a few translation strings to this file.
Comment 4 Jason Guiditta 2012-03-05 18:09:20 EST
This has been pushed to master
Comment 6 Aziza Karol 2012-03-23 05:41:34 EDT
Pool family text is still displayed.see attached screenshot.


#rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-conductor-doc-0.8.3-1.el6.noarch
aeolus-all-0.8.3-1.el6.noarch
aeolus-conductor-daemons-0.8.3-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-0.8.3-1.el6.noarch
Comment 7 Aziza Karol 2012-03-23 05:43:17 EDT
Created attachment 572213 [details]
ref pool family
Comment 8 Jason Guiditta 2012-03-23 10:32:23 EDT
After I fixed this last time, my fix was then overriden by a different approach. This works for me when testing against HEAD of product, so should make it back into the next build/puddle

*** This bug has been marked as a duplicate of bug 803628 ***

Note You need to log in before you can comment on or make changes to this bug.