Bug 799033 - libvirt-cim should require a CIM server and not specifically tog-pegasus
libvirt-cim should require a CIM server and not specifically tog-pegasus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt-cim (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 799037 799040
  Show dependency treegraph
 
Reported: 2012-03-01 11:01 EST by Perry Myers
Modified: 2012-03-05 05:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 799037 (view as bug list)
Environment:
Last Closed: 2012-03-05 05:16:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2012-03-01 11:01:50 EST
Description of problem:
Right now libvirt-cim specifically Requires: tog-pegasus

But it should probably require something more generic like "cim-server"

In order for this to happen, we'd also need sblim-sfcb and tog-pegasus to add Provides: cim-server to their spec files.
Comment 1 Perry Myers 2012-03-01 11:05:07 EST
Note: tog-pegasus and sblim-sfcb already list Provides: cim-server in their spec files, so looks like just a change to libvirt-cim is all that is needed
Comment 2 Daniel Veillard 2012-03-05 05:16:21 EST
"just" yes :-)
Except the libvirt-cim rpm won't rebuild if sblim-sfcb is installed
so there is certainly some tuning, but I made the change, pushed 0.6.1
update and fixed the package to restart either server would be running
using systemctl instead of init.d

At least that issue should be fixed.

Daniel
Comment 3 Daniel Veillard 2012-03-05 05:33:20 EST
For the record I kept BuildRequires: tog-pegasus-devel to make sure
that tog-pegasus was installed in the tree and hoping the build
environment would not try to pick sblim-fscb as if it is installed
its schemas registration scripts goof at install time and build fail
(at least on F16)

Daniel

Note You need to log in before you can comment on or make changes to this bug.