Bug 799037 - libvirt-cim should require a CIM server and not specifically tog-pegasus
libvirt-cim should require a CIM server and not specifically tog-pegasus
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt-cim (Show other bugs)
6.3
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On: 799033 799040
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 11:12 EST by Perry Myers
Modified: 2012-06-20 08:01 EDT (History)
7 users (show)

See Also:
Fixed In Version: libvirt-cim-0.6.1-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 799033
: 799040 (view as bug list)
Environment:
Last Closed: 2012-06-20 08:01:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2012-03-01 11:12:48 EST
+++ This bug was initially created as a clone of Bug #799033 +++

Description of problem:
Right now libvirt-cim specifically Requires: tog-pegasus

But it should probably require something more generic like "cim-server"

In order for this to happen, we'd also need sblim-sfcb and tog-pegasus to add Provides: cim-server to their spec files.

--- Additional comment from pmyers@redhat.com on 2012-03-01 11:05:07 EST ---

Note: tog-pegasus and sblim-sfcb already list Provides: cim-server in their spec files, so looks like just a change to libvirt-cim is all that is needed
Comment 1 Perry Myers 2012-03-01 11:13:47 EST
In RHEL6, sblim-sfcb Provides: cim-server but tog-pegasus does not.  So this bug will need to depend on a RHEL 6 bug for tog-pegasus so that it can add Provides: cim-server to its spec file to be consistent with Fedora
Comment 2 Daniel Veillard 2012-03-08 04:19:01 EST
tog-pegasus-2.11.0-3.el6 exports the right cim-server provide
The fix is now done in build libvirt-cim-0.6.1-2.el6 , the rpm
should also register the schemas with sblim-sfcb if it is found
when libvirt-cim is installed.

Daniel
Comment 5 dyuan 2012-03-09 03:01:46 EST
Verified PASS with libvirt-cim-0.6.1-2.el6.

# rpm -e tog-pegasus-2.11.0-2.el6.x86_64 sblim-sfcb-1.3.11-2.el6.x86_64
error: Failed dependencies:
	cim-server is needed by (installed) libvirt-cim-0.6.1-2.el6.x86_64

#### Remove all cim-server

# rpm -e tog-pegasus-2.11.0-2.el6.x86_64 sblim-sfcb-1.3.11-2.el6.x86_64 libvirt-cim-0.6.1-2.el6.x86_64

# rpm -ivh libvirt-cim-0.6.1-1.el6.x86_64.rpm
error: Failed dependencies:
	tog-pegasus is needed by libvirt-cim-0.6.1-1.el6.x86_64

# rpm -ivh libvirt-cim-0.6.1-2.el6.x86_64.rpm
error: Failed dependencies:
	cim-server is needed by libvirt-cim-0.6.1-2.el6.x86_64

#### Install sblim-sfcb only

# rpm -ivh sblim-sfcb-1.3.11-2.el6.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:sblim-sfcb             ########################################### [100%]

# rpm -ivh libvirt-cim-0.6.1-1.el6.x86_64.rpm 
error: Failed dependencies:
	tog-pegasus is needed by libvirt-cim-0.6.1-1.el6.x86_64

# rpm -ivh libvirt-cim-0.6.1-2.el6.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:libvirt-cim            ########################################### [100%]


#### Install tog-pegasus only

# rpm -e sblim-sfcb-1.3.11-2.el6.x86_64

# rpm -ivh tog-pegasus-libs-2.11.0-3.el6.x86_64.rpm tog-pegasus-2.11.0-3.el6.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:tog-pegasus-libs       ########################################### [ 50%]
   2:tog-pegasus            ########################################### [100%]

# rpm -ivh libvirt-cim-0.6.1-2.el6.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:libvirt-cim            ########################################### [100%]
Comment 7 errata-xmlrpc 2012-06-20 08:01:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0757.html

Note You need to log in before you can comment on or make changes to this bug.