Bug 803420 - When creating new custom Provider, pane opens wrong provider
When creating new custom Provider, pane opens wrong provider
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Og Maciel
: Triaged
: 805647 805661 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 12:58 EDT by Jason E. Rist
Modified: 2014-09-18 11:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 14:31:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason E. Rist 2012-03-14 12:58:41 EDT
Description of problem:


Version-Release number of selected component (if applicable):

81f3eac56e17521a27cbd63380e8f5929cf04a16

How reproducible:
always

Steps to Reproduce:
1. Custom Provider Page 
2. Create at least 2 +New Provider, make note of name of latest one
3. See which pane opens
  
Actual results:
Top/Older provider opens

Expected results:
most recently created opens


Additional info: Fixing this bug will help reproduce bug 803409.
Comment 1 Og Maciel 2012-03-14 13:12:12 EDT
fwiw this same behavior happens when adding a new user. The top/oldest user gets selected by default.
Comment 3 Brad Buckingham 2012-03-16 09:54:03 EDT
commit - 24a0c137536afcbb39654d1664b2c04996a27655

Note: this issue would exist on any 2-pane page (e.g. provider, system, user, org..etc).

This issue was an accidental regression related to a fix that went in for endless scroll for 2-pane pages.  For endless scroll, we want the content to be added to the bottom of the list; however, for creating new items (e.g providers) we want them to be added to the top of the list (so that user sees them); however, these 2 areas were using the same logic from the panel.  In order to address this, created a 'prepend' action on the panel (in addition to the existing 'append' action), so that we can support both cases.
Comment 5 Og Maciel 2012-03-19 11:50:25 EDT
Verified:
* candlepin-0.5.26-1.el6.noarch
* candlepin-tomcat6-0.5.26-1.el6.noarch
* katello-0.1.305-1.el6.noarch
* katello-all-0.1.305-1.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.0.4-1.el6.noarch
* katello-cli-0.1.105-1.el6.noarch
* katello-cli-common-0.1.105-1.el6.noarch
* katello-common-0.1.305-1.el6.noarch
* katello-configure-0.1.106-1.el6.noarch
* katello-glue-candlepin-0.1.305-1.el6.noarch
* katello-glue-foreman-0.1.305-1.el6.noarch
* katello-glue-pulp-0.1.305-1.el6.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.1.9-1.el6.noarch
* pulp-1.0.0-5.el6.noarch
* pulp-common-1.0.0-5.el6.noarch
* pulp-selinux-server-1.0.0-5.el6.noarch
Comment 6 Brad Buckingham 2012-03-21 14:48:25 EDT
*** Bug 805647 has been marked as a duplicate of this bug. ***
Comment 7 Brad Buckingham 2012-03-21 14:54:26 EDT
*** Bug 805661 has been marked as a duplicate of this bug. ***
Comment 9 Mike McCune 2013-08-16 14:08:39 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.