Bug 80387 - Bluecurve icons for nautilus have issues
Bluecurve icons for nautilus have issues
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: nautilus (Show other bugs)
phoebe
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
: 80853 81312 (view as bug list)
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-25 12:11 EST by Need Real Name
Modified: 2015-01-07 19:02 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-14 09:29:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
theme fixer bash script (2.51 KB, text/plain)
2003-01-13 09:11 EST, Matthew Hall
no flags Details

  None (edit)
Description Need Real Name 2002-12-25 12:11:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Changing the icon theme from nautilus leads to messed up icons on the desktop
and file manager ("start here" -> "preferences" -> "themes" -> "icon theme"
tab).  Most icons (files, directories, etc) show up as a grayish, "curled-paper"
icon.  

Trying to undo the damage from "preferences" does not work.  Exiting gnome,
removing the file "~/.gconf/desktop/gnome/interface/%gconf.xml", and then
restarting X/gnome restores the original icon theme (which look to me like the
stock gnome icons, not the bluecurve icons).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See above
2.
3.
    

Actual Results:  Wrong icons are displayed

Expected Results:  User should be able to switch icon themes

Additional info:

I'm marking this as "high" severity becuase it leaves the desktop with greatly
reduced usability.  Since it is not obvious how to fix this problem, many users,
especially new users, will be confused and frustrated.
Comment 1 louisgtwo 2002-12-25 17:58:52 EST
The Bluecurve theme for icons does not work with nautilus-2.1.x. All it displays
is blank white icons. Changing it back to Gnome, control-center should set it to
gnome not Gnome which is fixed upstream.
Comment 2 John J. Germs 2002-12-31 22:30:18 EST
I threw in my $0.02 in bug 80853 where this has also been brought up.
Comment 3 Need Real Name 2003-01-01 16:32:27 EST
A work around is in the GConf editor:
/gnome/interface/
set icon_theme to "gnome" with a little g
Comment 4 John J. Germs 2003-01-01 18:42:02 EST
Just to clarify for others:
type:

gconf-editor

in the run box and go to desktop, gnome, interface and
edit key 'icon_theme' from Gnome to gnome
Comment 5 Havoc Pennington 2003-01-02 16:07:14 EST
*** Bug 80853 has been marked as a duplicate of this bug. ***
Comment 6 Alexander Larsson 2003-01-06 10:52:08 EST
There are various issues here, but we're working on it.
Comment 7 Alexander Larsson 2003-01-08 05:46:49 EST
*** Bug 81312 has been marked as a duplicate of this bug. ***
Comment 8 Matthew Hall 2003-01-13 09:11:20 EST
Created attachment 89335 [details]
theme fixer bash script

I figured out the bluecurve icons had the wrong filename; and thus weren't
being picked up by nautilus. It's not a proper fix; but I wrote this lil script
to link the bluecurve icons to the right filenames.
Comment 9 Alexander Larsson 2003-01-14 09:29:22 EST
This should work now with the latest redhat-artwork.
Comment 10 John J. Germs 2003-01-19 23:18:01 EST
I have rebuilt the rawhide redhat-artwork-0.60-1.src.rpm

It fixed the Bulcurve icon issue, but the gnome icons
still have issues due to the capital G in Gnome.

Looks like it still needs some tweaking...  :)
Comment 11 John J. Germs 2003-01-19 23:45:10 EST
Again, just to be a little clearer:
Installing the latest redhat-artwork (redhat-artwork-0.60-1)
fixes the Bluecurve icon problem but not the Gnome icon
problem.

Additional info:
(My $0.02 from the other bug marked as duplicate)
------------------snip------------------
If I'm not mistaken when I first went to the icons 'tab' 
I believe there were three choices. When I selected one of them
there were only two choices remaining... 
After my first selection all the nautilus icons went blank... 
------------------snip------------------

Watching closer this time I saw that the three choices were:

Bluecurve
gnome
Gnome

gnome was highlighted of course.
When selecting Bluecurve the gnome entry disappeared
and all that remained was:

Bluecurve
Gnome

I would suggest this bug be reopened and the Summary
altered to reflect the changes still needed.
Comment 12 Alexander Larsson 2003-01-20 11:13:33 EST
You need latest control-center.
Comment 13 John J. Germs 2003-01-20 20:02:50 EST
Thankyou, that did the trick.

Note You need to log in before you can comment on or make changes to this bug.