Bug 80395 - oops on shutdown unless acpi=off for notebook Dell Inspiron 4000
oops on shutdown unless acpi=off for notebook Dell Inspiron 4000
Status: CLOSED DUPLICATE of bug 82123
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-25 15:04 EST by John Reiser
Modified: 2013-07-02 22:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from acpidmp (49.42 KB, text/plain)
2002-12-25 17:21 EST, John Reiser
no flags Details
output from dmidecode (8.00 KB, text/plain)
2002-12-25 17:21 EST, John Reiser
no flags Details

  None (edit)
Description John Reiser 2002-12-25 15:04:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
Unless I boot with  acpi=off , then shutting down from GNOME desktop does not
turn off the power, and manually pressing the power button gets an Oops.  This
is a Dell Inspiron 4000 notebook laptop (19 months old).


Version-Release number of selected component (if applicable):
8.0.92 (phoebe)

How reproducible:
Always

Steps to Reproduce:
1. Fresh install Phoebe: workstation, graphic login.  Fix "no screens" problem
with firstboot because Horiz/Vert frequencies for display panel not detected.
2. Login as normal user (not root).  Shutdown from GNOME desktop.
3. Manually press Power button when "Power down." message appears but system
does not turn off power like under RHL8.0.
    

Actual Results:  [Manually transcribed using keyboard+editor on another system.]

flushing ide devices: hda hdc
Power down.
  ## But power is not turned off automatically; so: press Power button.
Unable to handle kernel NULL pointer dereference at virtual address 00000518
 printing eip:
c011f855
*pde = 00000000
Oops: 0000
maestro3 ac97_codec soundcore ide-cd cdrom r128 agpgart parport_pc lp parport
autofs 3c59x ipt_REJEC
T iptable_filter ip_tables nls_iso8859-1 nls_cp437 vfat fa
CPU:    0
EIP:    0060:[<c011f855>]    Not tainted
EFLAGS: 00010286

EIP is at sys_wait4 [kernel] 0x2f5 (2.4.20-2.2)
eax: 00000000   ebx: 00000000   ecx: 00000000   edx: 00000004
esi: c52ae000   edi: c7fb0000   ebp: bffff46c   esp: c7fb1f80
ds: 0068   es: 0068   ss: 0068
Process init (pid: 1, tackpage=c7fb1000)
Stack: ffffffff 00000001 c52ae000 00000001 00000000 c7fb0000 00000000 00000000
       00000000 c7fb0000 c7fb0160 c7fb0160 c7f00000 00000000 ffffffff bffff44c
       c01096ff ffffffff bffff46c 00000001 00000000 ffffffff bffff44c 00000072
Call Trace:   [<c01096ff>] system_call [kernel] 0x33 (0xc7fb1fc0))


Code: 8b b9 18 05 00 00 85 ff 0f 84 84 00 00 00 b8 00 e0 ff ff 8b
 <0>Kernel panic: Attempted to kill init!

[Now the CapsLock and ScrollLock LEDs are flashing slowly and irregularly, like
Morse code; but it's too hard for me to read.
Also, the Power button does not work!  The only way to turn off the machine is
to unplug the power adapter, and remove the battery.]

Expected Results:  Power turned off automatically by shutting down from GNOME
desktop.

Additional info:

Booting with "acpi=off" fixes the problem:  Then shutting down from GNOME
desktop turns off the power as the last operation.

Neither /usr/sbin/dmidecode nor /usr/sbin/acpidmp are installed, so I could not
run them as requested in RELEASE-NOTES.  "locate" could not find any "dmidecode"
nor any "acpidmp" anywhere [updatedb was run].
Comment 1 John Reiser 2002-12-25 17:21:21 EST
Created attachment 88908 [details]
output from acpidmp
Comment 2 John Reiser 2002-12-25 17:21:58 EST
Created attachment 88909 [details]
output from dmidecode
Comment 3 Ron H. 2002-12-29 22:32:09 EST
I would like to add that this issue is reproducable on my Dell Inspiron 2500
with the latest BIOS from Dell as well.
Comment 4 Dave Habben 2003-01-14 23:39:02 EST
This looks like a duplicate of bug 80330
The oops output is just slightly different between the two. Causes are just the
same though.
Comment 5 Jeff Garzik 2003-01-17 16:15:47 EST

*** This bug has been marked as a duplicate of 82123 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:50:34 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.