Bug 80330 - Kernel Panic on Shutdown: Attempted to kill init!
Kernel Panic on Shutdown: Attempted to kill init!
Status: CLOSED DUPLICATE of bug 82123
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
Depends On:
Blocks: 79579
  Show dependency treegraph
Reported: 2002-12-24 10:18 EST by Dave Habben
Modified: 2013-07-02 22:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:50:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
acpidmp output (51.37 KB, text/plain)
2002-12-24 10:33 EST, Dave Habben
no flags Details
dmidecode output (8.53 KB, text/plain)
2002-12-24 10:35 EST, Dave Habben
no flags Details

  None (edit)
Description Dave Habben 2002-12-24 10:18:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

Description of problem:
This is on a Dell Inspriron 8000

The system does not auto power off at shutdown. When hitting the power button on
the laptop a Kernel Panic appears:

Halting system...
md: stopping all md devices.
flushing ide devices: hda hdb
System halted

Then upon pressing the power button:

Unable to handle kernel NULL pointer dereferenced at virtual address 00000518
 printing eip:
*pde = 00000000
Oops: 0000
lp parport autofs 3c59x ipt_REJECT iptable_filter ip_tables ohci1394 ieee1394 nl
s_iso8859-1 nls_cp437 vfat fat loop lvm-mod keybdev mousedev hid input usb-uhc
CPU:	0
EIP:	0060:[<c011f855>]	Not tainted
EFLAGS:	00010282

EIP is at sys_wait4 [kernel] 0x2f5 (2.4.20-2.2)
eax: 00000000	ebx: 00000000	ecx: 00000000	edx: 00000004
esi: ce05e000	edi: cffe8000	ebp: bffff48c	esp: cffe9f80
ds: 0068   es: 0068   ss: 0068

Process init (pid: 1, stackpage=cffe9000)
Stack: ffffffff	00000001 ce05e000 00000001 00000000 cffe8000 00000000 00000000
       00000000 cffe8000 cffe8160 cffe8160 cffe8000 00000000 ffffffff bffff46c
       c01096ff ffffffff bffff48c 00000001 00000000 ffffffff bffff46c 00000072
Call Trace:	[<c01096ff>] system_call [kernel] 0x33 (0xcffe9fc0))

Code: 8b b9 18 05 00 00 85 ff 0f 84 84 00 00 00 b8 00 e0 ff ff 8b
 <0>Kernel panic: Attempted to kill init!

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Login as root
2. Type in: halt
3. Kernel indicates: System halted
4. Press the power button

Actual Results:  Kernel Panic with above output

Expected Results:  The laptop should power off.
This worked fine under Redhat 8.0

Additional info:

When the kernel is booted with acpi=off the system will power off as expected.
Comment 1 Arjan van de Ven 2002-12-24 10:20:49 EST
does this get fixed if you add acpi=off to the kernel commandline (eg the
vmlinuz line in /boot/grub/grub.conf) ?
Comment 2 Dave Habben 2002-12-24 10:26:01 EST
Yes it does, see my comment at the end of the bug report

Additional info:
When the kernel is booted with acpi=off the system will power off (without
crashing) as expected.
Comment 3 Dave Habben 2002-12-24 10:33:23 EST
Created attachment 88888 [details]
acpidmp output
Comment 4 Dave Habben 2002-12-24 10:35:53 EST
Created attachment 88889 [details]
dmidecode output
Comment 5 Warren Togami 2002-12-24 15:53:41 EST
I have seen this kernel panic on my Sony Vaio FXA36 Athlon laptop as well.
Comment 6 Bill Nottingham 2002-12-24 16:37:48 EST
That panic is *in your bios*, if I'm reading the EIP right.
Comment 7 venkat belede 2002-12-25 12:47:41 EST
It happens on Inspiron 4150 too
Comment 8 Elton Woo 2002-12-29 16:46:46 EST
I get a similar kernel panic on *bootup*, (apparently) since (after) having
edited my grub.conf
 to _enable_ poweroff. [Bug 80360]

Motherboard ASUS ATX A7V-E/550 
BIOS: Award, Rev. 1004
Comment 9 Dave Habben 2003-01-14 23:41:46 EST
This bug looks like it's closely related with bug 80395
Oops output is slightly different, causes are the same.

Any newer kernels in rawhide that would likely fix this issue?
Comment 10 Jeff Garzik 2003-01-18 18:56:09 EST

*** This bug has been marked as a duplicate of 82123 ***
Comment 11 Red Hat Bugzilla 2006-02-21 13:50:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.