Bug 804479 - RFE: manipulate system Condition via command line
RFE: manipulate system Condition via command line
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
0.8
Unspecified Unspecified
unspecified Severity medium (vote)
: 19.0
: ---
Assigned To: Dan Callaghan
CommandLineEnhancement
: FutureFeature, Patch
: 840556 1119930 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-18 22:17 EDT by Marco Grigull
Modified: 2014-11-25 02:17 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-25 02:17:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Grigull 2012-03-18 22:17:25 EDT
Description of problem:
Often a larger number of systems get marked broken, due to the way we track this it is easy enough to build a hostlist.

It would be awesome if one could perform administrative tasks against a system in beaker via the command line.

In particular, it would be very handy if one was able to set a system back to 'Automated' via bkr.  It is anticipated that this action will also be noted in the systems history tab.


Version-Release number of selected component (if applicable):
beaker-client-0.8.1-4


Additional info:
This would be an improvement upon using sql statements file generated by intermediate scripts  or  manipulating via csv export/modify/import.
Comment 1 Marco Grigull 2012-03-18 22:27:59 EDT
Optionally an alias for marking the system as unbroken could be implemented, and it would revert the status to that before it was last marked broken.
Comment 2 Dan Callaghan 2012-09-27 20:20:26 EDT
*** Bug 840556 has been marked as a duplicate of this bug. ***
Comment 3 Nick Coghlan 2012-10-17 00:37:33 EDT
Bulk reassignment of issues as Bill has moved to another team.
Comment 5 Nick Coghlan 2013-12-13 00:16:55 EST
As per bug 1037592, this is currently referred to as the system Condition in the web UI (although the system search options still refer to it as "Status").

However, we're not completely happy with the current condition modelling, so I'd prefer to revisit that before adding a command line interface for it.
Comment 6 Nick Coghlan 2014-07-20 22:55:25 EDT
*** Bug 1119930 has been marked as a duplicate of this bug. ***
Comment 7 Dan Callaghan 2014-11-04 22:57:39 EST
We do still need to deal with the issues around Condition/Status (bug 1039842) but we won't hold up this RFE for that.
Comment 8 Dan Callaghan 2014-11-04 23:28:43 EST
http://gerrit.beaker-project.org/3463
Comment 14 Dan Callaghan 2014-11-25 02:17:39 EST
Beaker 19.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.