Bug 804817 - UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 65: ordinal not in range(128)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:6cd3c1d0d600ed47ebea0add4c0...
:
: 805428 805673 805771 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 16:23 EDT by Dr. Tilmann Bubeck
Modified: 2012-03-24 13:55 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-17.14-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 13:46:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-zAA0uO (117.26 KB, text/plain)
2012-03-19 16:23 EDT, Dr. Tilmann Bubeck
no flags Details

  None (edit)
Description Dr. Tilmann Bubeck 2012-03-19 16:23:36 EDT
libreport version: 2.0.8
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-zAA0uO
hashmarkername: anaconda
kernel:         3.3.0-0.rc7.git0.3.fc17.x86_64
other involved packages: 
product:        Fedora
reason:         UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 65: ordinal not in range(128)
release:        Cannot get release name.
time:           Mo 19 Mär 2012 20:22:44 UTC
version:        17-Beta-TC2

anaconda-tb-zAA0uO: Text file, 120078 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.13 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/gettext.py", line 368, in lgettext
:    return tmsg.encode(locale.getpreferredencoding())
:  File "/usr/lib64/python2.7/gettext.py", line 543, in ldgettext
:    return t.lgettext(message)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 47, in <lambda>
:    _ = lambda x: gettext.ldgettext("anaconda", x)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 326, in betaNagScreen
:    _("Warning!  This is pre-release software!\n\n"
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
:    self.anaconda.dispatch.go_forward()
:UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 65: ordinal not in range(128)

environ:
:LANG=de_DE.UTF-8
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=fedora/17/x86_64/vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:PWD=/
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.y3zxgF
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=fedora/17/x86_64/initrd.img
:MALLOC_PERTURB_=204
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 Dr. Tilmann Bubeck 2012-03-19 16:23:41 EDT
Created attachment 571228 [details]
File: anaconda-tb-zAA0uO
Comment 2 Dr. Tilmann Bubeck 2012-03-20 09:39:07 EDT
This happens when I choose "German" as the installation LANGUAGE.

Choosing the keyboard layout is not responsible for causing the bug. I can choose german or english for keyboard without any consequence. But choosing german LANGUAGE crashes anaconda.
Comment 3 Chris Lumens 2012-03-22 10:35:45 EDT
*** Bug 805771 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2012-03-22 10:35:51 EDT
*** Bug 805673 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2012-03-22 10:36:30 EDT
*** Bug 805428 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2012-03-23 13:23:43 EDT
anaconda-17.14-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-4546/anaconda-17.14-1.fc17
Comment 7 Fedora Update System 2012-03-23 13:46:02 EDT
anaconda-17.14-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Dr. Tilmann Bubeck 2012-03-24 13:55:02 EDT
work with Fedora-17-BETA-RC1.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.