Bug 807722 - [RFE] Subscription Manager UXD Improvements based on customer Feedback
[RFE] Subscription Manager UXD Improvements based on customer Feedback
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: FutureFeature
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-03-28 10:50 EDT by Bryan Kearney
Modified: 2013-01-10 04:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:49:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2012-03-28 10:50:14 EDT
Per some customer feedback, it would be nice for the current SLA to be more prominant.
Comment 1 Bryan Kearney 2012-03-28 11:22:11 EDT
Re-purposing this bug. This bug will track hte usability changes for 5.9 based on the following custoemr feedback:

* it would be nice for the current SLA to be more
prominant.
* The yellow highlighting is not clear.
* Should you be able to uninstall a product from the subscribe workflow if you get to the end and do not have a subscription for 1 or more of your installed products?
* GUI icons are a little unclear b/c they require a user to start clicking to find what they need rather than knowing immediately where to go
* When autosubscribe fails, Would be nice to tell you what it could not cover in the error condition. Or, tell them what could be covered.
* Can SAM Launch Higher
* How should the filters be shown on the all available tab.
* Should the filters be "ON" or "Off" by default?
* Org Name versus id is confusing. Perhaps show both in the gui window.
* Hard to see data in Subscription vs Software tab, have to go back and forth a lot
* May want to include the SLA directly in the tables (all available subs, contract picker)
* Added https://bugzilla.redhat.com/show_bug.cgi?id=807722 for 5.9
* May want to include the SLA directly in the tables (all available subs, contract picker)
Comment 2 Bryan Kearney 2012-03-28 13:08:54 EDT
One more: Would like to right click on products to do the subscribe button.
Comment 3 Bryan Kearney 2012-03-28 14:16:27 EDT
One more: This has been submitted to the UXD for consideration in future designs.
Comment 4 Matt Reid 2012-03-28 14:43:09 EDT
(In reply to comment #1)
> Re-purposing this bug. This bug will track hte usability changes for 5.9 based
> on the following customer feedback:
> 
> * it would be nice for the current SLA to be more
> prominent.
This is in the latest designs already, along with Org
> * The yellow highlighting is not clear.
Need to investigate this, haven't touched on it yet
> * Should you be able to uninstall a product from the subscribe workflow if you
> get to the end and do not have a subscription for 1 or more of your installed
> products?
Need to think on this
> * GUI icons are a little unclear b/c they require a user to start clicking to
> find what they need rather than knowing immediately where to go
They should get a tooltip on hover currently, but I'll be proposing a switch to a menu for 5.9, we'll see what everyone thinks
> * When autosubscribe fails, Would be nice to tell you what it could not cover
> in the error condition. Or, tell them what could be covered.
Definitely would like to see this, included it in last design update
> * Can SAM Launch Higher
Not sure what this means
> * How should the filters be shown on the all available tab.
Needs addressing, current method could be better
> * Should the filters be "ON" or "Off" by default?
I'm fine with matching arch being on by default, matching installed software should probably be off, and overlap I'm not sure about yet, I might lean towards off as well.
Should we include a match my SLA preference filter as well? I'm hoping tables will become sortable, so it wouldn't be as important to filter if we could sort the results
> * Org Name versus id is confusing. Perhaps show both in the gui window.
Was this in reference to the CLI? I got confused initially trying to put a name in when it only takes id. I'd rather not show both in the GUI, can we pick the more important one and have that prominent in the GUI, and maybe show the other in facts or something? Is ID always just a modified name, with spaces turned into dashes or can they be wildly different?
> * Hard to see data in Subscription vs Software tab, have to go back and forth > a lot
Can think about that
> * May want to include the SLA directly in the tables (all available subs,
> contract picker)
Latest designs tried to include SLA wherever important
Comment 5 Bryan Kearney 2012-07-03 13:47:55 EDT
Given that we are going off of the latest designs, I am moving this to MODIFIED. Verification should be done not against this list but against the current designs from mreid.
Comment 6 Matt Reid 2012-07-10 16:18:54 EDT
(In reply to comment #4)
> (In reply to comment #1)
> > Re-purposing this bug. This bug will track hte usability changes for 5.9 based
> > on the following customer feedback:
> > 
> > * it would be nice for the current SLA to be more
> > prominent.

This was in designs but hasn't been implemented. Not sure if it will be in 5.9 or not.

> This is in the latest designs already, along with Org
> > * The yellow highlighting is not clear.
> Need to investigate this, haven't touched on it yet

https://bugzilla.redhat.com/show_bug.cgi?id=829825
The highlight for expiring subscriptions on My Subscriptions, being implemented now.

> > * Should you be able to uninstall a product from the subscribe workflow if you
> > get to the end and do not have a subscription for 1 or more of your installed
> > products?
> Need to think on this

This has not been implemented, don't think it will be for 5.9.

> > * GUI icons are a little unclear b/c they require a user to start clicking to
> > find what they need rather than knowing immediately where to go
> They should get a tooltip on hover currently, but I'll be proposing a switch
> to a menu for 5.9, we'll see what everyone thinks

This has been implemented, https://bugzilla.redhat.com/show_bug.cgi?id=814731

> > * When autosubscribe fails, Would be nice to tell you what it could not cover
> > in the error condition. Or, tell them what could be covered.
> Definitely would like to see this, included it in last design update

This hasn't happened yet

> > * Can SAM Launch Higher
> Not sure what this means

Ignore this ^

> > * How should the filters be shown on the all available tab.
> Needs addressing, current method could be better

https://bugzilla.redhat.com/show_bug.cgi?id=813336
Implemented and mostly in master, I think there's a bug fix or two that may not be in master yet

> > * Should the filters be "ON" or "Off" by default?
> I'm fine with matching arch being on by default, matching installed software
> should probably be off, and overlap I'm not sure about yet, I might lean
> towards off as well.
> Should we include a match my SLA preference filter as well? I'm hoping
> tables will become sortable, so it wouldn't be as important to filter if we
> could sort the results

https://bugzilla.redhat.com/show_bug.cgi?id=817901
Match my installed products is now turned off by default.

> > * Org Name versus id is confusing. Perhaps show both in the gui window.
> Was this in reference to the CLI? I got confused initially trying to put a
> name in when it only takes id. I'd rather not show both in the GUI, can we
> pick the more important one and have that prominent in the GUI, and maybe
> show the other in facts or something? Is ID always just a modified name,
> with spaces turned into dashes or can they be wildly different?

I need to try and follow up on this again. 

> > * Hard to see data in Subscription vs Software tab, have to go back and forth > a lot
> Can think about that

Didn't end up with any specifics on this one, we've added a few fields to both tabs, but I don't know what the issue was originally.

> > * May want to include the SLA directly in the tables (all available subs,
> > contract picker)
> Latest designs tried to include SLA wherever important

Currently Service Level shows in My Subs and All Available Subs.

------------

I'll try to keep this up to date, if anything important changes.
Comment 7 Matt Reid 2012-07-18 16:41:30 EDT
Quick update:

> > > * When autosubscribe fails, Would be nice to tell you what it could not cover
> > > in the error condition. Or, tell them what could be covered.
> > Definitely would like to see this, included it in last design update
> 
> This hasn't happened yet

This looks to be slated for 6.4 now.

> 
> > > * Org Name versus id is confusing. Perhaps show both in the gui window.
> > Was this in reference to the CLI? I got confused initially trying to put a
> > name in when it only takes id. I'd rather not show both in the GUI, can we
> > pick the more important one and have that prominent in the GUI, and maybe
> > show the other in facts or something? Is ID always just a modified name,
> > with spaces turned into dashes or can they be wildly different?
> 
> I need to try and follow up on this again. 

I think when we add org to the gui, we'll only need to show Org Name, not ID, which will probably be 6.4.
Comment 9 John Sefler 2012-10-23 10:55:35 EDT
(In reply to comment #7)
> Quick update:
> 
> > > > * When autosubscribe fails, Would be nice to tell you what it could not cover
> > > > in the error condition. Or, tell them what could be covered.
> > > Definitely would like to see this, included it in last design update
> > 
> > This hasn't happened yet
> 
> This looks to be slated for 6.4 now.
> 
Will look for this in rhel64. (see Rally stories US1381 US1604)

> > 
> > > > * Org Name versus id is confusing. Perhaps show both in the gui window.
> > > Was this in reference to the CLI? I got confused initially trying to put a
> > > name in when it only takes id. I'd rather not show both in the GUI, can we
> > > pick the more important one and have that prominent in the GUI, and maybe
> > > show the other in facts or something? Is ID always just a modified name,
> > > with spaces turned into dashes or can they be wildly different?
> > 
> > I need to try and follow up on this again. 
> 
> I think when we add org to the gui, we'll only need to show Org Name, not
> ID, which will probably be 6.4.
Opened under [RFE] bug 869306 for rhel64
Comment 10 John Sefler 2012-10-23 10:56:10 EDT
Most all of the feedback items in this bug have been addressed to some degree in subscription-manager-gui-1.0.23-1.el5 or have been carried forward to rhel64 for implementation under individual [RFE] bugs.

Moving this bug to VERIFIED.
Comment 11 John Sefler 2012-10-23 13:21:52 EDT
(In reply to comment #9)
> (In reply to comment #7)
> > Quick update:
> > 
> > > > > * When autosubscribe fails, Would be nice to tell you what it could not cover
> > > > > in the error condition. Or, tell them what could be covered.
> > > > Definitely would like to see this, included it in last design update
> > > 
> > > This hasn't happened yet
> > 
> > This looks to be slated for 6.4 now.
> > 
> Will look for this in rhel64. (see Rally stories US1381 US1604)
and see bug 864195 for rhel64
Comment 13 errata-xmlrpc 2013-01-07 22:49:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.