Bug 807908 - Evolution hangs when I try receive much messages
Evolution hangs when I try receive much messages
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-ews (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 824727 840899 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 02:18 EDT by Mikhail
Modified: 2012-07-18 06:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 11:59:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (8.48 KB, text/plain)
2012-03-29 02:18 EDT, Mikhail
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 673095 None None None Never

  None (edit)
Description Mikhail 2012-03-29 02:18:08 EDT
Created attachment 573542 [details]
backtrace

Description of problem:
Evolution with evolution-ews connector hangs when I try receive much messages
Comment 1 Milan Crha 2012-03-29 08:53:50 EDT
Thanks for a bug report. I see that three threads are stuck in the same function e_ews_connection_update_items() on the same line e-ews-connection.c:3098 for the same connection and folder. It's waiting for a finish of an asynchronous operation. I'll check whether I'll be able to find anything.
Comment 2 Milan Crha 2012-03-29 11:59:07 EDT
I tried to reproduce this, and even I cannot reproduce the "3 threads with the same function", then I can reproduce the operation "Storing folder large..." being stuck when it is performed on a not-completely downloaded EWS folder. I'm moving this upstream, thus please see [1] for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=673095
Comment 3 Milan Crha 2012-05-28 03:16:02 EDT
*** Bug 824727 has been marked as a duplicate of this bug. ***
Comment 4 Milan Crha 2012-07-18 06:57:28 EDT
*** Bug 840899 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.