Bug 807957 - [abrt] vinagre-3.2.1-2.fc16: libusb_set_debug: Process /usr/bin/vinagre was killed by signal 11 (SIGSEGV)
[abrt] vinagre-3.2.1-2.fc16: libusb_set_debug: Process /usr/bin/vinagre was k...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spice-gtk (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
abrt_hash:ab8bdc9cd0a69e1890070b6b1a2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 04:44 EDT by u5afe
Modified: 2012-04-11 12:55 EDT (History)
6 users (show)

See Also:
Fixed In Version: libusb1-1.0.9-0.6.rc1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 11:18:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: build_ids (5.25 KB, text/plain)
2012-03-29 04:44 EDT, u5afe
no flags Details
File: dso_list (12.07 KB, text/plain)
2012-03-29 04:44 EDT, u5afe
no flags Details
File: maps (55.97 KB, text/plain)
2012-03-29 04:44 EDT, u5afe
no flags Details
File: backtrace (29.94 KB, text/plain)
2012-03-29 04:44 EDT, u5afe
no flags Details

  None (edit)
Description u5afe 2012-03-29 04:44:39 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        vinagre
crash_function: libusb_set_debug
executable:     /usr/bin/vinagre
kernel:         3.3.0-4.fc16.x86_64
pid:            8352
pwd:            /home/anthony
reason:         Process /usr/bin/vinagre was killed by signal 11 (SIGSEGV)
time:           Wed 28 Mar 2012 03:03:21 AM EST
uid:            1000
username:       anthony
xsession_errors: 

backtrace:      Text file, 30659 bytes
build_ids:      Text file, 5371 bytes
dso_list:       Text file, 12364 bytes
maps:           Text file, 57311 bytes

comment:
:Tried to access XP guest using SPICE (not as root).
:Guest is setup for USB using spicy, by manually editing the XML file as so. (note spicy needs to be run as root).
:<domain type='kvm' xmlns:qemu='http://libvirt.org/schemas/domain/qemu/1.0'>
:...
:  </devices>
:  <qemu:commandline>
:     <qemu:arg value='-readconfig'/>
:     <qemu:arg value='/etc/qemu/ich9-ehci-uhci.cfg'/>
:     <qemu:arg value='-chardev'/>
:     <qemu:arg value='spicevmc,name=usbredir,id=usbredirchardev1'/>
:     <qemu:arg value='-device'/>
:     <qemu:arg value='usb-redir,chardev=usbredirchardev1,id=usbredirdev1,bus=ehci.0,debug=3'/>
:     <qemu:arg value='-chardev'/>
:     <qemu:arg value='spicevmc,name=usbredir,id=usbredirchardev2'/>
:     <qemu:arg value='-device'/>
:     <qemu:arg value='usb-redir,chardev=usbredirchardev2,id=usbredirdev2,bus=ehci.0,debug=3'/>
:     <qemu:arg value='-chardev'/>
:     <qemu:arg value='spicevmc,name=usbredir,id=usbredirchardev3'/>
:     <qemu:arg value='-device'/>
:     <qemu:arg value='usb-redir,chardev=usbredirchardev3,id=usbredirdev3,bus=ehci.0,debug=3'/>
:  </qemu:commandline>
:</domain>

environ:
:XDG_VTNR=2
:XDG_SESSION_ID=5
:HOSTNAME=shoosh
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=4c1e9d974a61621e9bc00f5800000013-1332861590.360125-892168762
:GNOME_KEYRING_CONTROL=/tmp/keyring-AIITlz
:IMSETTINGS_MODULE=none
:USER=anthony
:USERNAME=anthony
:MAIL=/var/spool/mail/anthony
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/anthony/.local/bin:/home/anthony/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/anthony
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=7314
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/anthony
:XDG_SEAT=seat0
:SHLVL=1
:LOGNAME=anthony
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-pr53zidzD3,guid=fb6456c2a3619defa0e4849700001032
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=2
:XDG_RUNTIME_DIR=/run/user/anthony
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-anthony-CgCcWo/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/7319,unix/unix:/tmp/.ICE-unix/7319
:GPG_AGENT_INFO=/tmp/keyring-AIITlz/gpg:0:1
:SSH_AUTH_SOCK=/tmp/keyring-AIITlz/ssh
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:DESKTOP_STARTUP_ID=gnome-shell-7519-shoosh-vinagre-11_TIME5268458
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/vinagre.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=8352

smolt_data:
:
:
:General
:=================================
:UUID: cb30d627-47fc-4eac-9d40-ea18b56d5be1
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6784.72
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 8
:CPU Speed: 3701
:System Memory: 7716
:System Swap: 17757
:Vendor: Gigabyte Technology Co., Ltd.
:System: H67MA-D2H 
:Form factor: Desktop
:Kernel: 3.3.0-4.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:(32902:258:5208:53248) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7170:5208:45061) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7184:5208:20481) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7242:5208:20481) pci, None, PCI/ISA, H67 Express Chipset Family LPC Controller
:(32902:7196:5208:20481) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:7200:5208:40962) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7202:5208:20481) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:9294:5208:20480) pci, None, PCI/PCI, GA-EP45-DS5 Motherboard
:(4147:404:5208:20487) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:7213:5208:20486) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:5208:20486) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:256:0:0) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:5208:7226) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:257:5208:20480) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_shoosh-lv_root / ext4 4096 4096 13092026 11997618 11866596 3276800 3160232 3160232
:/dev/sda4 WITHHELD ext4 4096 4096 21100490 2775829 1719100 5283840 5272730 5272730
:/dev/mapper/vg_shoosh-lv_home /home ext4 4096 4096 13540090 6800652 6122355 3391488 3390694 3390694
:/dev/sdc1 WITHHELD fuseblk 4096 4096 244190000 180181184 180181184 721019648 720943729 720943729
:/dev/sr0 WITHHELD iso9660 2048 2048 309102 0 0 0 0 0
:

var_log_messages:
:Mar 28 03:03:21 shoosh kernel: [ 6738.328852] vinagre[8352]: segfault at 4 ip 0000003cd4a0315b sp 00007fff5ff6a178 error 4 in libusb-1.0.so.0.1.0[3cd4a00000+e000]
:Mar 28 03:03:24 shoosh abrt[10936]: Saved core dump of pid 8352 (/usr/bin/vinagre) to /var/spool/abrt/ccpp-2012-03-28-03:03:21-8352 (253722624 bytes)
Comment 1 u5afe 2012-03-29 04:44:44 EDT
Created attachment 573569 [details]
File: build_ids
Comment 2 u5afe 2012-03-29 04:44:46 EDT
Created attachment 573570 [details]
File: dso_list
Comment 3 u5afe 2012-03-29 04:44:49 EDT
Created attachment 573571 [details]
File: maps
Comment 4 u5afe 2012-03-29 04:44:51 EDT
Created attachment 573572 [details]
File: backtrace
Comment 5 Hans de Goede 2012-03-29 05:53:16 EDT
Hi,

I believe this is a bug in spice-gtk-0.11, which is fixed by this commit:
http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=434adeb05b0d8aef0d983b346bd820287db22eae
Which is in spice-gtk-0.11-3 and newer

So if you get the latest spice-gtk from updates-testing then you should no longer see this crash. I'll update the update in bodhi to point to this bug.

Regards,

Hans
Comment 6 Fedora Update System 2012-03-29 05:54:25 EDT
libusb1-1.0.9-0.6.rc1.fc16, usbredir-0.4.2-1.fc16, spice-gtk-0.11-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-4025/usbredir-0.4.2-1.fc16,spice-gtk-0.11-4.fc16,libusb1-1.0.9-0.6.rc1.fc16
Comment 7 abrt-bot 2012-03-30 11:18:42 EDT
Backtrace analysis found this bug to be similar to bug #798010, closing as duplicate.

Bugs which were found to be similar to this bug: 
  usbredir: bug #798010
  virt-manager: bug #801098

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 798010 ***
Comment 8 Fedora Update System 2012-04-11 12:55:43 EDT
libusb1-1.0.9-0.6.rc1.fc16, usbredir-0.4.3-1.fc16, spice-gtk-0.11-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.