This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 808131 - abrt-gui fails: Can't get problem list from abrt-dbus
abrt-gui fails: Can't get problem list from abrt-dbus
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
: 734294 808384 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 12:31 EDT by Joachim Backes
Modified: 2012-04-25 21:53 EDT (History)
10 users (show)

See Also:
Fixed In Version: abrt-2.0.10-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 18:58:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2012-03-29 12:31:19 EDT
Description of problem:
Trying to run abrt-gui fails:

abrt-gui

Gtk-Message: Failed to load module "pk-gtk-module"

(abrt:2396): GLib-CRITICAL **: g_variant_get_va: assertion `value != NULL' failed

(abrt:2396): GLib-CRITICAL **: g_variant_iter_loop: assertion `first_time || format_string == GVSI(iter)->loop_format' failed

(abrt:2396): GLib-CRITICAL **: g_variant_iter_free: assertion `is_valid_heap_iter (iter)' failed
Can't get problem list from abrt-dbus



Version-Release number of selected component (if applicable):
abrt-gui-2.0.9-1.fc17.x86_64

How reproducible:

always
Steps to Reproduce:
1./usr/bin/abrt-gui
2.
3.
  
Actual results:


Expected results:


Additional info:

 ls -l /var/spool/abrt

drwxr-x---. 2 abrt backes 4096 Mar 29 18:13 ccpp-2012-03-26-16:55:08-11883
drwxr-x---. 2 abrt backes 4096 Mar 29 18:13 ccpp-2012-03-27-14:56:55-1767
drwxr-x---. 2 abrt backes 4096 Mar 29 18:13 ccpp-2012-03-28-07:44:08-2429
drwxr-x---. 2 abrt backes 4096 Mar 29 18:13 ccpp-2012-03-29-17:45:53-1616
-rw-------. 1 root root     20 Mar 29 17:45 last-ccpp
drwxr-x---. 2 abrt backes 4096 Mar 29 18:13 pyhook-2012-03-26-16:53:05-10465
drwxr-x---. 2 abrt backes 4096 Mar 29 18:13 pyhook-2012-03-28-11:44:27-7256
drwxr-x---. 2 abrt root   4096 Mar 29 18:13 pyhook-2012-03-29-17:34:13-13076
Comment 1 Jiri Moskovcak 2012-03-29 14:01:55 EDT
I can't reproduce this one, can you please post output of:

rpm -qa | grep -i kit
Comment 2 Joachim Backes 2012-03-29 15:48:33 EDT
jack-audio-connection-kit-1.9.8-6.fc17.x86_64
p11-kit-0.11-1.fc17.x86_64
rtkit-0.10-2.fc17.x86_64
python-kitchen-1.1.1-1.fc17.noarch
ConsoleKit-x11-0.4.5-2.fc17.x86_64
polkit-0.104-6.fc17.x86_64
PackageKit-0.7.3-1.fc17.x86_64
PackageKit-gtk3-module-0.7.3-1.fc17.x86_64
polkit-qt-0.103.0-2.fc17.x86_64
ConsoleKit-0.4.5-2.fc17.x86_64
webkitgtk3-1.7.92-1.fc17.x86_64
PackageKit-gstreamer-plugin-0.7.3-1.fc17.x86_64
pywebkitgtk-1.1.8-3.fc17.x86_64
p11-kit-0.11-1.fc17.i686
PackageKit-glib-0.7.3-1.fc17.x86_64
polkit-gnome-0.105-2.fc17.x86_64
gnome-packagekit-3.3.92-1.fc17.x86_64
PackageKit-yum-plugin-0.7.3-1.fc17.x86_64
qtwebkit-2.2.1-4.fc17.x86_64
ConsoleKit-libs-0.4.5-2.fc17.x86_64
webkitgtk-1.6.3-2.fc17.x86_64
PackageKit-yum-0.7.3-1.fc17.x86_64
PackageKit-device-rebind-0.7.3-1.fc17.x86_64
perl-Template-Toolkit-2.22-11.fc17.x86_64
Comment 3 Noriko Mizumoto 2012-03-29 19:14:08 EDT
*** Bug 734294 has been marked as a duplicate of this bug. ***
Comment 4 Noriko Mizumoto 2012-03-29 19:48:31 EDT
With the versin abrt-gui-2.0.7-4.fc17.x86_64, abrt-gui run
correctly for L10N Test, but the test result was fail. There was localization
issue reported bug#800784.

After Updated to abrt-2.0.9-1.fc17 and libreport-2.0.10-1.fc17 as the fix for
bug#734298 of another localization issue, running abrt-gui fails with the
following error message (regression to bug#734294). 

Gtk-Message: Failed to load module "pk-pkg-module"
Glib-CRITICAL **: g_variant_get_va: assertion 'value !=NULL' failed
Glib-CRITICAL **: g_variant_iter_loop: assertion 'first_time || format_string
== GVSI (iter)->loop_format' failed
Glib-CRITICAL **: g-variant-iter_free: assertion 'is_valid_heap_iter (iter)'
failed
Can't get problem list from abrt-dbus
Comment 5 Jiri Moskovcak 2012-03-30 12:10:44 EDT
*** Bug 808384 has been marked as a duplicate of this bug. ***
Comment 6 Misha Shnurapet 2012-04-01 07:20:47 EDT
$ rpm -qa | grep kit
jack-audio-connection-kit-1.9.8-6.fc17.x86_64
polkit-gnome-0.105-2.fc17.x86_64
p11-kit-0.12-1.fc17.x86_64
webkitgtk-1.8.0-1.fc17.x86_64
pywebkitgtk-1.1.8-3.fc17.x86_64
webkitgtk3-1.8.0-1.fc17.x86_64
rtkit-0.10-2.fc17.x86_64
python-kitchen-1.1.1-1.fc17.noarch
gnome-packagekit-3.4.0-1.fc17.x86_64
polkit-0.104-6.fc17.x86_64
Comment 7 Nicolas Mailhot 2012-04-01 13:22:57 EDT
rpm -qa | grep -i kit
PackageKit-gstreamer-plugin-0.7.3-1.fc18.x86_64
svnkit-1.3.4-2.fc15.noarch
PackageKit-glib-0.7.3-1.fc18.x86_64
jbigkit-libs-2.0-4.fc17.x86_64
webkitgtk3-1.8.0-1.fc18.x86_64
webkitgtk-1.8.0-1.fc18.x86_64
eclipse-svnkit-1.3.4-2.fc15.noarch
p11-kit-0.12-1.fc17.x86_64
PackageKit-0.7.3-1.fc18.x86_64
jack-audio-connection-kit-1.9.8-6.fc18.x86_64
PackageKit-device-rebind-0.7.3-1.fc18.x86_64
polkit-0.104-6.fc18.x86_64
python-kitchen-1.1.1-1.fc18.noarch
ConsoleKit-libs-0.4.5-2.fc17.x86_64
avalon-logkit-2.1-7.fc17.noarch
ConsoleKit-0.4.5-2.fc17.x86_64
PackageKit-yum-0.7.3-1.fc18.x86_64
rtkit-0.10-2.fc17.x86_64
ConsoleKit-x11-0.4.5-2.fc17.x86_64
PackageKit-yum-plugin-0.7.3-1.fc18.x86_64
polkit-gnome-0.105-2.fc17.x86_64
pywebkitgtk-1.1.8-3.fc17.x86_64
Comment 8 Jiri Moskovcak 2012-04-02 03:39:53 EDT
Fixed in git.
Comment 9 Fedora Update System 2012-04-02 09:32:06 EDT
abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17
Comment 10 Joachim Backes 2012-04-02 10:36:14 EDT
The update fixed my issue :-)

Thanks a lot!
Comment 11 Fedora Update System 2012-04-02 13:44:11 EDT
Package abrt-2.0.10-1.fc17, libreport-2.0.10-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.10-1.fc17 libreport-2.0.10-2.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5200/abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-04-18 18:58:09 EDT
abrt-2.0.10-1.fc17, libreport-2.0.10-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Noriko Mizumoto 2012-04-25 21:53:43 EDT
abrt-2.0.10-1.fc17.x86_64 and libreport-2.0.10-2.fc17.x86_64

Confirmed that 'abrt-gui' command worked and displayed the window now.
There is still localization bug#800784 existed though.

Note You need to log in before you can comment on or make changes to this bug.