Bug 808337 - segfault when running ld.so --verify on some DSO's in current working directory
segfault when running ld.so --verify on some DSO's in current working directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jeff Law
qe-baseos-tools
:
Depends On:
Blocks: 808342
  Show dependency treegraph
 
Reported: 2012-03-30 03:53 EDT by Miroslav Franc
Modified: 2016-11-24 07:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No Documentation Needed
Story Points: ---
Clone Of:
: 808342 (view as bug list)
Environment:
Last Closed: 2012-06-20 08:10:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Franc 2012-03-30 03:53:24 EDT
Description of problem:

When poking at bug 807740 I hit another segfault in dynamic linker. It manifest itself, when running ld.so --verify on some DSO's in current working directory. Upstream 6a5ee1029b3966c5ae9adaaa881e255b2880f511 seems to be fixing the issue for me.


Version-Release number of selected component (if applicable):
glibc-2.12-1.75.el6


How reproducible:
Always.


Steps to Reproduce:
cd /lib; for i in *; do /lib/ld-linux.so.2 --verify "$i";done


Actual results:
A lot of segfaults.


Expected results:
No segfault.
Comment 1 Jeff Law 2012-03-30 15:23:16 EDT
I wouldn't mind adding the referenced patch to 6.3; it's small and reasonably safe.  It's arguably related to 741105/767146 and a testcase which tests ld --verify doesn't fault on a wide set of libraries and debuginfo files would cover testing for both BZs.
Comment 3 Jeff Law 2012-04-12 12:21:08 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation Needed
Comment 5 errata-xmlrpc 2012-06-20 08:10:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0763.html

Note You need to log in before you can comment on or make changes to this bug.