Bug 808342 - segfault when running ld.so --verify on some DSO's in current working directory
segfault when running ld.so --verify on some DSO's in current working directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: glibc (Show other bugs)
5.8
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jeff Law
qe-baseos-tools
:
Depends On: 808337
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 03:58 EDT by Miroslav Franc
Modified: 2016-11-24 07:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Same as RHEL 6.3 BZ 808337
Story Points: ---
Clone Of: 808337
Environment:
Last Closed: 2013-01-07 22:46:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix some of these problems (1.48 KB, patch)
2012-05-10 23:38 EDT, Jeff Law
no flags Details | Diff

  None (edit)
Description Miroslav Franc 2012-03-30 03:58:45 EDT
+++ This bug was initially created as a clone of Bug #808337 +++

Description of problem:

When poking at bug 807740 I hit another segfault in dynamic linker. It manifest itself, when running ld.so --verify on some DSO's in current working directory. Upstream 6a5ee1029b3966c5ae9adaaa881e255b2880f511 seems to be fixing the issue for me.


Version-Release number of selected component (if applicable):
glibc-2.12-1.75.el6


How reproducible:
Always.


Steps to Reproduce:
cd /lib; for i in *; do /lib/ld-linux.so.2 --verify "$i";done


Actual results:
A lot of segfaults.


Expected results:
No segfault.
Comment 1 RHEL Product and Program Management 2012-04-02 09:09:21 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Jeff Law 2012-05-10 23:38:38 EDT
Created attachment 583709 [details]
patch to fix some of these problems

Doesn't fix all the problems with ld --verify, but does fix one class of them.
Comment 5 Patsy Franklin 2012-06-11 22:54:23 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Same as RHEL 6.3 BZ 808337
Comment 7 errata-xmlrpc 2013-01-07 22:46:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0022.html

Note You need to log in before you can comment on or make changes to this bug.