Bug 808509 - qemu-ga prints debug message while starting
qemu-ga prints debug message while starting
Status: CLOSED DUPLICATE of bug 827612
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Jeff Cody
Virtualization Bugs
:
Depends On:
Blocks: 820481 831387
  Show dependency treegraph
 
Reported: 2012-03-30 10:50 EDT by Luiz Capitulino
Modified: 2012-10-10 14:45 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 14:45:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luiz Capitulino 2012-03-30 10:50:31 EDT
Description of problem:

While starting qemu-ga will print the following debug message:

  "Starting qemu-ga: ** (process:1330): DEBUG: starting daemon"

This happens here:

    if (daemonize) {
        g_debug("starting daemon");
        become_daemon(pidfile);
    }

Version-Release number of selected component (if applicable):
qemu-guest-agent-0.12.1.2-2.265.el6.x86_64.rpm

How reproducible:


Steps to Reproduce:
1. install the qemu-guest-agent package
2. # service qemu-ga start
  
Actual results:
Debug message is printed.

Expected results:
No debug message.
Comment 1 Jeff Cody 2012-05-09 11:35:15 EDT
In addition to debug prints from starting the daemon, if you specify commands in the blacklist, a debug print is issued for each blacklisted command.  There may be others too, from different paths, so we will want to check all debug prints.
Comment 2 RHEL Product and Program Management 2012-07-10 04:33:52 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 22:04:46 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Jeff Cody 2012-10-10 14:45:27 EDT
This has been resolved already with commits 0925f73 and 67ef572 (BZ 827612)

*** This bug has been marked as a duplicate of bug 827612 ***

Note You need to log in before you can comment on or make changes to this bug.