Bug 827612 - Update qemu-ga to its latest upstream version
Update qemu-ga to its latest upstream version
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Luiz Capitulino
Virtualization Bugs
:
: 808509 (view as bug list)
Depends On:
Blocks: 820481 831387
  Show dependency treegraph
 
Reported: 2012-06-01 16:43 EDT by Luiz Capitulino
Modified: 2013-02-21 02:36 EST (History)
12 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.297.el6
Doc Type: Release Note
Doc Text:
Rebase package(s) to version: 1.1 Highlights, important fixes, or notable enhancements: @Errata Content Author: please include the following fixes in the rebase statement along with the features listed below in the release note (see comment 12 for details): - Persist tracking of fsfreeze state via filesystem, thus avoiding qemu-ga to forget fsfreeze state if it dies or is restarted - Allow guest-fsfreeze-thaw to run unconditionally, thus qemu-ga is still able to thaw the FS even if it dies or is restarted - Avoid blocking on atime update when reading /etc/mtab while the FS is frozen --- #Release Note: QEMU Guest Agent Updated The QEMU guest agent (qemu-guest-agent) has been updated to upstream version 1.1, which includes the following notable enhancements and bug fixes: The guest-suspend-disk and guest-suspend-ram commands can now be used to suspend to RAM or to disk on a Windows system. This update fixes a memory leak in the Windows communication code. The guest-network-get-interfaces command can now be used to acquire network interface information in Linux. This update provides file system freeze support improvements and fixes. This update includes various documentation fixes and small improvements.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:36:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luiz Capitulino 2012-06-01 16:43:19 EDT
The guest agent we have in RHEL6.3 was forked off from QEMU 1.0. The latest version of QEMU (v1.1) contains a more up to date guest agent. Let's update RHEL's qemu-ga to its latest upstream version.
Comment 6 Jeff Cody 2012-10-10 14:45:27 EDT
*** Bug 808509 has been marked as a duplicate of this bug. ***
Comment 7 langfang 2012-10-16 01:06:10 EDT
test this bug as follow version:
# uname -r
2.6.32-331.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.323.el6.x86_64

guest:
# uname -r
2.6.32-279.el6.x86_64

qemu-guest-agent-0.12.1.2-2.327.el6.x86_64

steps:
1.boot guest with virtio serial 
....-chardev socket,path=/tmp/qga.sock,server,nowait,id=qga0 -device  virtio-serial -device virtserialport,chardev=qga0,name=org.qemu.guest_agent.0

2. Inside guest: #service qemu-ga start

3. On host: 
#nc -U /tmp/qga.sock

{"execute": "guest-info"}
{"return": {"version": "1.0", "supported_commands": [{"enabled": true, "name": "guest-network-get-interfaces"}, {"enabled": true, "name": "guest-suspend-hybrid"}, {"enabled": true, "name": "guest-suspend-ram"}, {"enabled": true, "name": "guest-suspend-disk"}, {"enabled": true, "name": "guest-fsfreeze-thaw"}, {"enabled": true, "name": "guest-fsfreeze-freeze"}, {"enabled": true, "name": "guest-fsfreeze-status"}, {"enabled": true, "name": "guest-file-flush"}, {"enabled": true, "name": "guest-file-seek"}, {"enabled": true, "name": "guest-file-write"}, {"enabled": true, "name": "guest-file-read"}, {"enabled": true, "name": "guest-file-close"}, {"enabled": true, "name": "guest-file-open"}, {"enabled": true, "name": "guest-shutdown"}, {"enabled": true, "name": "guest-info"}, {"enabled": true, "name": "guest-ping"}, {"enabled": true, "name": "guest-sync"}, {"enabled": true, "name": "guest-sync-delimited"}]}}
{"execute":"guest-fsfreeze-status"}
{"return": "thawed"}
{"execute":"guest-fsfreeze-freeze"}
{"return": 2}
{"execute":"guest-fsfreeze-thaw"}
{"return": 2}
{"execute":"guest-fsfreeze-status"}
{"return": "thawed"}
{"execute":"guest-network-get-interfaces"}
{"return": [{"name": "lo", "ip-addresses": [{"ip-address-type": "ipv4", "ip-address": "127.0.0.1", "prefix": 8}, {"ip-address-type": "ipv6", "ip-address": "::1", "prefix": 128}], "hardware-address": "00:00:00:00:00:00"}, {"name": "eth0", "ip-addresses": [{"ip-address-type": "ipv4", "ip-address": "10.66.105.76", "prefix": 21}, {"ip-address-type": "ipv6", "ip-address": "fe80::62a:4aff:fe42:1b00", "prefix": 64}], "hardware-address": "04:2a:4a:42:1b:00"}]}
{"execute":"guest-sync-delimited","arguments":{"id":1234}}
�{"return": 1234}
{"execute":"guest-file-open", "arguments":{"path":"/tmp/testqga","mode":"w+"}}
{"return": 7}
{"execute":"guest-file-write", "arguments":{"handle":7,"buf-b64":"aGVsbG8gd29ybGQhCg=="}}
{"return": {"count": 13, "eof": false}}
{"execute":"guest-file-close", "arguments":{"handle":7}}
{"return": {}}
{"execute":"guest-file-open", "arguments":{"path":"/tmp/testqga","mode":"r"}}
{"return": 7}
{"execute":"guest-file-read", "arguments":{"handle":7,"count":1024}}
{"return": {"count": 13, "buf-b64": "aGVsbG8gd29ybGQhCg==", "eof": true}}
{"execute":"guest-file-close","arguments":{"handle":7}}
{"return": {}}
{"execute":"guest-file-flush", "arguments":{"handle":7,"count":1024}}
{"error": {"class": "FdNotFound", "desc": "File descriptor named 'handle' not found", "data": {"name": "handle"}}}
{"execute":"guest-file-open", "arguments":{"path":"/tmp/testqga","mode":"r"}}
{"return": 7}
{"execute":"guest-file-open", "arguments":{"path":"/tmp/testqga","mode":"r"}}
{"return": 8}
{"execute":"guest-file-flush", "arguments":{"handle":7,"count":1024}}            
{"return": {}}
{"execute":"guest-file-seek","arguments":{"handle":7,"offset":0,"whence":2}}
{"return": {"eof": false, "position": 13}}

adddinfo:test qemu-ga operations as follow:

"guest-sync-delimited"
"guest-network-get-interfaces"
"guest-fsfreeze-*"
"guest-file-* "
Comment 13 Martin Prpič 2012-11-21 08:39:24 EST
On second thought, the above bug fixes can probably be mentioned in the documentation shipped with RHBA-2012:13475. A note about this has been added to the Doc Text field along with the content present in the Release Notes.
Comment 15 errata-xmlrpc 2013-02-21 02:36:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html

Note You need to log in before you can comment on or make changes to this bug.