Bug 808562 - abrt-addon-python: The process might hang forever if no one collects the dump it sends
abrt-addon-python: The process might hang forever if no one collects the dump...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 808584 837333
  Show dependency treegraph
 
Reported: 2012-03-30 13:59 EDT by Saggi Mizrahi
Modified: 2015-03-02 00:23 EST (History)
12 users (show)

See Also:
Fixed In Version: abrt-2.0.10-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 837333 (view as bug list)
Environment:
Last Closed: 2012-05-12 12:20:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saggi Mizrahi 2012-03-30 13:59:49 EDT
Description of problem:
The code in write_dump on abrt_exception_handler.py opens a sockets and writes to it without setting a timeout. If for some reason no one picks up the data the program might hang forever while crashing.

Please set a timeout as the process's resources are still being held while it is stuck and cause problems when trying to recover from crashes.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jiri Moskovcak 2012-04-11 09:53:12 EDT
care to beta-test? 

http://koji.fedoraproject.org/koji/taskinfo?taskID=3979664

And also would be great if someone can send us strace output of that stalled app.
Comment 2 Fedora Update System 2012-04-18 07:40:34 EDT
abrt-2.0.7-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/abrt-2.0.7-3.fc16
Comment 3 Fedora Update System 2012-04-19 01:21:46 EDT
Package abrt-2.0.7-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.7-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6193/abrt-2.0.7-3.fc16
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-05-10 09:15:33 EDT
abrt-2.0.10-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.10-3.fc17
Comment 5 Fedora Update System 2012-05-12 12:20:12 EDT
abrt-2.0.10-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-06-01 23:54:30 EDT
abrt-2.0.7-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 greg.2.harris 2012-11-06 14:03:03 EST
I believe the root cause of the other side not responding is in https://bugzilla.redhat.com/show_bug.cgi?id=873815.

Note You need to log in before you can comment on or make changes to this bug.