Bug 80987 - [acpi] Poweroff doesn't work on Intel SE7500WV2 MB
[acpi] Poweroff doesn't work on Intel SE7500WV2 MB
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
Reported: 2003-01-02 19:08 EST by hjl
Modified: 2013-07-02 22:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:40:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The ACPI patch 20021212. (412.94 KB, patch)
2003-01-07 17:16 EST, hjl
no flags Details | Diff
A patch to fix SMP (568 bytes, patch)
2003-01-07 17:17 EST, hjl
no flags Details | Diff
An updated patch for SMP (1.54 KB, patch)
2003-01-14 19:58 EST, hjl
no flags Details | Diff

  None (edit)
Description hjl 2003-01-02 19:08:20 EST
Poweroff doesn't turn off the power on Intel
SE7500WV2 MB. Poweroff works fine under RedHat
7.3 running the 2.4.18-19.7.x kernel with ACPI
patch on the same hardare.
Comment 1 hjl 2003-01-07 17:16:05 EST
Created attachment 89194 [details]
The ACPI patch 20021212.

Here is an ACPI patch 20021212 ported to beta3 kernel.
Comment 2 hjl 2003-01-07 17:17:33 EST
Created attachment 89195 [details]
A patch to fix SMP

This patch fixes ACPI for SMP.
Comment 3 hjl 2003-01-07 17:18:54 EST
I uploaded 2 ACPI patches to replace

Patch680: linux-2.4.20-intel-acpi-safe-update.patch
Patch681: linux-2.4.20-acpi-relaxed-aml.patch
Patch682: linux-2.4.20-acpi-fixes.patch

Now at least I can power off my machine.
Comment 4 hjl 2003-01-14 19:58:54 EST
Created attachment 89366 [details]
An updated patch for SMP

The new patch fixes the problem of the UP kernel
on SMP MB when ACPI and local IO APIC are enabled.
Comment 5 Jeff Garzik 2003-01-17 15:49:21 EST

*** This bug has been marked as a duplicate of 82120 ***
Comment 6 Jeff Garzik 2003-01-17 16:02:04 EST

*** This bug has been marked as a duplicate of 82123 ***
Comment 7 hjl 2003-01-21 19:03:00 EST
Poweroff still doesn't work with beta4. SE7500WV2 needs a
working ACPI for poweroff. Turning off ACPI is not a solution
for this bug.
Comment 8 Andy Grover 2003-02-28 00:01:46 EST
hjl: I am confused how the patches attached to this bug would fix poweroff,
since they are related to IRQ configuration at init.

I'd love to fix ACPI poweroff once and for all, so if you have the answer, I'm
all ears.
Comment 9 hjl 2003-02-28 11:36:03 EST
My patch fixes ACPI on SMP so that ACPI can be turned on.
It is against an old ACPI patch. I don't know if it is
still needed. I no longer have access to SE7500WV2 to
verify it. 
Comment 10 Andy Grover 2003-07-30 20:38:44 EDT

I have a SE7501WV2. I tried 2.6.0-test2 and 2.4.22-pre8. Both shutdown 

Is that close enough to close this bug as WORKSFORME?
Comment 11 hjl 2003-07-31 01:14:48 EDT
The problem is RedHat kernel doesn't support ACPI. It can be
closed when a released RedHat kernel has ACPI support.
Comment 12 Aleksey Nogin 2003-07-31 01:28:08 EDT
Actually it does - the Severn beta release includes ACPI.
Comment 13 hjl 2003-07-31 01:31:53 EDT
Didn't one of Shrike alphas/beta kernels include ACPI? I don't believe
ACPI is in the final kernel in Shrike.
Comment 14 Jeff Garzik 2003-07-31 10:27:54 EDT
Shrike is a long time ago, yes :)

But we have turned on ACPI again, and have got Intel folks actively looking at
ACPI problems.
Comment 15 Dave Jones 2003-09-15 10:35:20 EDT
Just to bring this bug up to date a little, Severn kernel is now based on
2.4.22-ac1, which has the big acpi updates that were backported. A number of
issues remain, including this one, which means that it will be disabled unless
you boot with acpi=on.

Every test box I've tried so far refuses to power off with acpi, so this bug is
still very much alive.
Comment 16 Len Brown 2004-03-24 20:19:05 EST
> Every test box I've tried so far refuses to power off with acpi,
> so this bug is still very much alive.

Dave, 6 months later now, is this still true?
Comment 17 Bugzilla owner 2004-09-30 11:40:21 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.