Bug 810052 - [abrt] gnome-shell-3.4.0-1.fc17: reload_systemd_sessions: Process /usr/bin/gnome-shell was killed by signal 11 (SIGSEGV)
[abrt] gnome-shell-3.4.0-1.fc17: reload_systemd_sessions: Process /usr/bin/gn...
Status: CLOSED DUPLICATE of bug 810447
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
abrt_hash:657ca7d4863c4b047d7a034f0bd...
:
: 809365 811071 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 21:55 EDT by Mikhail
Modified: 2012-04-10 11:07 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 15:38:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (41.06 KB, text/plain)
2012-04-04 21:55 EDT, Mikhail
no flags Details
File: maps (59.94 KB, text/plain)
2012-04-04 21:55 EDT, Mikhail
no flags Details
File: dso_list (20.37 KB, text/plain)
2012-04-04 21:55 EDT, Mikhail
no flags Details
File: build_ids (7.29 KB, text/plain)
2012-04-04 21:55 EDT, Mikhail
no flags Details
File: var_log_messages (18.28 KB, text/plain)
2012-04-04 21:55 EDT, Mikhail
no flags Details
audit.log (3.80 MB, text/x-log)
2012-04-05 22:42 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2012-04-04 21:55:11 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: reload_systemd_sessions
executable:     /usr/bin/gnome-shell
kernel:         3.3.0-8.fc17.i686.PAE
pid:            1209
pwd:            /home/mikhail
remote_result:  809365
time:           Чт. 05 апр. 2012 07:38:59
uid:            1000
username:       mikhail

backtrace:      Text file, 42048 bytes
build_ids:      Text file, 7462 bytes
dso_list:       Text file, 20856 bytes
maps:           Text file, 61375 bytes
var_log_messages: Text file, 18714 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/mikhail/2

core_backtrace:
:67471cc179ffb4a335f925dfce28147c0764f9e1 0x130dd - libaccountsservice.so.0 -
:0f38369260ca783a82ce4d694451ede68aaa0da1 0x614ca - libgio-2.0.so.0 -
:542ce7fe25fb8fc3e2cc85ab8aa4096f1ccfbc88 0x46f01 g_main_context_dispatch libglib-2.0.so.0 -
:542ce7fe25fb8fc3e2cc85ab8aa4096f1ccfbc88 0x47380 - libglib-2.0.so.0 -
:542ce7fe25fb8fc3e2cc85ab8aa4096f1ccfbc88 0x477e3 g_main_loop_run libglib-2.0.so.0 -
:5966a41f16a4eb0782c1c41caec6758190812974 0x4b2f8 meta_run libmutter.so.0 -
:c85bcc8da84a188f5361a9ca75f69d6c7912e701 0x17c8 main [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=ao521
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=712f11080aa5ec90698eefb000000045-1333589134.203615-2008631085
:GNOME_KEYRING_CONTROL=/home/mikhail/.cache/keyring-0hcMHC
:IMSETTINGS_MODULE=none
:USER=mikhail
:USERNAME=mikhail
:MAIL=/var/spool/mail/mikhail
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/mikhail/.local/bin:/home/mikhail/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/mikhail
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=966
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/mikhail
:SHLVL=1
:LOGNAME=mikhail
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-uh2ezzuAQU,guid=4c28e201b2035f08d5eb360f0000003d
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/mikhail
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-mikhail-I3WmKG/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/970,unix/unix:/tmp/.ICE-unix/970
:GPG_AGENT_INFO=/home/mikhail/.cache/keyring-0hcMHC/gpg:0:1
:SSH_AUTH_SOCK=/home/mikhail/.cache/keyring-0hcMHC/ssh
:LC_TIME=ru_RU.utf8
:LC_NUMERIC=ru_RU.utf8
:LC_MONETARY=ru_RU.utf8
:LC_MEASUREMENT=ru_RU.utf8
:DESKTOP_AUTOSTART_ID=10c8591825ff67b1271333589136234600000009700000

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 30094                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       30094                30094                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/mikhail/.xsession-errors
:pos:	24779
:flags:	02002
:2:/home/mikhail/.xsession-errors
:pos:	24779
:flags:	02002
:3:pipe:[21735]
:pos:	0
:flags:	04000
:4:pipe:[21735]
:pos:	0
:flags:	01
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:socket:[21736]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:General
:=================================
:UUID: 6478aaa9-30e4-4a97-a123-b179d02652cd
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: i686
:BogoMIPS: 3391.55
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Athlon(tm) II Neo K125 Processor
:CPU Stepping: 3
:CPU Family: 16
:CPU Model Num: 6
:Number of CPUs: 1
:CPU Speed: 1700
:System Memory: 3778
:System Swap: 4095
:Vendor: Acer
:System: AO521 Not Applicable
:Form factor: Notebook
:Kernel: 3.3.0-8.fc17.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4098:17297:4133:1085) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
:(4098:17302:4133:1085) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4130:38401:4133:1085) pci, None, HOST/PCI, RS880 Host Bridge
:(4130:38402:4130:1085) pci, None, PCI/PCI, RS780/RS880 PCI to PCI bridge (int gfx)
:(4130:4612:0:0) pci, None, HOST/PCI, Family 10h Processor Link Control
:(6505:8288:4133:1085) pci, atl1c, ETHERNET, AR8152 v1.1 Fast Ethernet
:(4130:4608:0:0) pci, None, HOST/PCI, Family 10h Processor HyperTransport Configuration
:(4130:4611:0:0) pci, k10temp, HOST/PCI, Family 10h Processor Miscellaneous Control
:(4130:4610:0:0) pci, None, HOST/PCI, Family 10h Processor DRAM Controller
:(4130:4609:0:0) pci, None, HOST/PCI, Family 10h Processor Address Map
:(5772:43:4187:57397) pci, ath9k, NETWORK, AR9285 Wireless Network Adapter (PCI-Express)
:(4098:17285:0:0) pci, None, SERIAL, SBx00 SMBus Controller
:(4098:17309:4133:1085) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:4133:1085) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4098:38674:4133:1085) pci, radeon, VIDEO, M880G [Mobility Radeon HD 4200]
:(4098:38671:4098:38674) pci, snd_hda_intel, MULTIMEDIA, RS880 Audio Device [Radeon HD 4200]
:(4098:17303:4133:1085) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:17302:4133:1085) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:4133:1085) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4130:38404:4133:1085) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 0)
:(4130:38405:4133:1085) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 1)
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 6094889 3781900 3720878 1531904 1296174 1296174
:/dev/sda5 /home ext4 4096 4096 48953540 5384181 2933474 12255232 12096355 12096355
:

xsession_errors:
:(gnome-shell:1150): eds-WARNING **: edsf-persona-store.vala:2078: Error in address book view query: GDBus.Error:org.gnome.evolution.dataserver.AddressBook.AuthenticationRequired: Authentication Required
:(gnome-shell:1150): eds-WARNING **: edsf-persona-store.vala:2088: Error is considered unrecoverable. Removing persona store.
:(gnome-shell:1150): eds-WARNING **: edsf-persona-store.vala:2078: Error in address book view query: GDBus.Error:org.gnome.evolution.dataserver.AddressBook.AuthenticationRequired: Authentication Required
:(gnome-shell:1150): eds-WARNING **: edsf-persona-store.vala:2088: Error is considered unrecoverable. Removing persona store.
:(gnome-shell:1150): folks-WARNING **: Failed to reach quiescence normally (0 backends and 1 persona stores still haven't reached quiescence). Forcing IndividualAggregator quiescence due to reaching the timeout.
Comment 1 Mikhail 2012-04-04 21:55:16 EDT
Created attachment 575249 [details]
File: backtrace
Comment 2 Mikhail 2012-04-04 21:55:19 EDT
Created attachment 575250 [details]
File: maps
Comment 3 Mikhail 2012-04-04 21:55:22 EDT
Created attachment 575251 [details]
File: dso_list
Comment 4 Mikhail 2012-04-04 21:55:24 EDT
Created attachment 575252 [details]
File: build_ids
Comment 5 Mikhail 2012-04-04 21:55:27 EDT
Created attachment 575253 [details]
File: var_log_messages
Comment 6 Owen Taylor 2012-04-05 13:49:21 EDT
This is a problem with (likely) SELinux causing listing sessions not to work, which reveals a bug in libaccountsservice where it isn't properly handling the failure to list sessions - its missing a null check.
Comment 7 Daniel Walsh 2012-04-05 13:49:56 EDT
Could you check to see if this  being caused by SELinux?  Any AVC's in /var/log/audit/audit.log?
Comment 8 Ray Strode [halfline] 2012-04-05 14:30:22 EDT
so the denial actually is encoded in the dbus security policy.

ConsoleKit specifically disallows using object properties and gdbus specifically does a GetAll call on the properties.  It's harmless, though, 

It looks like we activate ConsoleKit if it's installed because of this in /etc/pam.d/system-auth:

-session optional pam_ck_connector.so

which is fine, it's just adding noise to the logs.

So the only bit I don't understand is why there's no systemd session available.  

Mikhail, i'm curious about /var/log/audit/audit.log as well.  Also, the output of 

rpm -q selinux-policy-targeted
Comment 9 Ray Strode [halfline] 2012-04-05 14:38:21 EDT
upstream commit for the missing NULL check:

http://cgit.freedesktop.org/accountsservice/commit/?id=522ef48a5566db0f8d8d6c80062b6ff63de0eaae

again, though, things aren't going to function 100% if the current session has somehow disappeared (or was never registered in the first place)
Comment 10 Owen Taylor 2012-04-05 15:44:48 EDT
*** Bug 809365 has been marked as a duplicate of this bug. ***
Comment 11 Mikhail 2012-04-05 22:42:01 EDT
Created attachment 575587 [details]
audit.log
Comment 12 Mikhail 2012-04-05 22:44:59 EDT
mikhail@ao521:~$ rpm -q selinux-policy-targeted
selinux-policy-targeted-3.10.0-110.fc17.noarch
Comment 13 Mikhail 2012-04-06 00:23:16 EDT
when i do logoff

backtrace_rating: 4
Package: gnome-shell-3.4.0-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 14 Dong Chen 2012-04-07 10:21:03 EDT
after installing or uninstalling software, this happenwhen logout. 

backtrace_rating: 4
Package: gnome-shell-3.4.0-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 15 Daniel Walsh 2012-04-09 15:38:31 EDT

*** This bug has been marked as a duplicate of bug 810447 ***
Comment 16 cblaauw 2012-04-10 05:04:46 EDT
I get a sigsegv every time I logout (at least that's what abrtd keeps telling me).
Comment 17 Owen Taylor 2012-04-10 11:07:13 EDT
*** Bug 811071 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.