Bug 810447 - SELinux is preventing gdb from using the 'ptrace' accesses on a process.
Summary: SELinux is preventing gdb from using the 'ptrace' accesses on a process.
Keywords:
Status: CLOSED DUPLICATE of bug 810451
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 17
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:edf03dc5a7d3e7c1514a0dc7274...
: 810052 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-06 07:52 UTC by Kamil Páral
Modified: 2012-04-09 19:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-06 18:13:03 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 810451 0 unspecified CLOSED Logging out crashes i686 LiveCD system 2021-02-22 00:41:40 UTC

Internal Links: 810451

Description Kamil Páral 2012-04-06 07:52:32 UTC
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-1.fc17.i686
time:           Fri 06 Apr 2012 03:51:29 AM EDT

description:
:SELinux is preventing gdb from using the 'ptrace' accesses on a process.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that gdb should be allowed ptrace access on processes labeled xdm_t by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gdb /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
:Target Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
:Target Objects                 [ process ]
:Source                        gdb
:Source Path                   gdb
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-110.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-1.fc17.i686 #1
:                              SMP Mon Mar 19 03:19:22 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Fri 06 Apr 2012 03:50:25 AM EDT
:Last Seen                     Fri 06 Apr 2012 03:50:25 AM EDT
:Local ID                      993eaf0e-0a49-4939-909f-9ca31c8ad7e6
:
:Raw Audit Messages
:type=AVC msg=audit(1333698625.906:288): avc:  denied  { ptrace } for  pid=1535 comm="gdb" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tclass=process
:
:
:Hash: gdb,xdm_t,xdm_t,process,ptrace
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:

Comment 1 Kamil Páral 2012-04-06 07:54:15 UTC
I have seen this alert on F17 Beta RC3 i686 LiveCD. After I log out, gdm/X crashes. Probably abrt or some other process tried to inspect the crash. After the crash X respawned, logged me in, and I saw notification for this selinux denial.

Comment 2 Adam Williamson 2012-04-06 18:13:03 UTC
Kamil filed a 'manual' bug for the problem caused by this, so closing as a dupe of that one, which is a blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 810451 ***

Comment 3 Daniel Walsh 2012-04-09 19:38:31 UTC
*** Bug 810052 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.