Bug 81022 - mozilla RPMs don't remove empty directories when removed
mozilla RPMs don't remove empty directories when removed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
: Reopened
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-01-03 10:55 EST by Braden McDaniel
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 07:53:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add include dirs to package manifest (1.26 KB, text/plain)
2003-07-17 18:31 EDT, Jens Petersen
no flags Details

  None (edit)
Description Braden McDaniel 2003-01-03 10:55:11 EST
Description of problem:
When removed using "rpm -e", the mozilla RPMs don't remove directories that they
install (e.g., /usr/lib/mozilla-1.2.1, /usr/include/mozilla-1.2.1).

Version-Release number of selected component (if applicable):
1.2.1-3
Comment 1 Warren Togami 2003-02-03 02:33:08 EST
Is this truly a bug?  Many other packages don't remove empty directories either.
Comment 2 Jens Petersen 2003-07-17 17:27:08 EDT
Yes, mozilla has lots of unowned directories:

% rpm -qf /usr/include/mozilla-1.4/mozilla-config.h
mozilla-devel-1.4-12
% rpm -qf /usr/include/mozilla-1.4
file /usr/include/mozilla-1.4 is not owned by any package
% rpm -qf /usr/include/mozilla-1.4/gtkembedmoz/gtkmozembed.h
mozilla-devel-1.4-12
% rpm -qf /usr/include/mozilla-1.4/gtkembedmoz
file /usr/include/mozilla-1.4/gtkembedmoz is not owned by any package

It would be nice to have all the directories in the manifest to prevent this:

% ls /usr/include/mozilla-1.[Tab]
 mozilla-1.3/   mozilla-1.4/   mozilla-1.4b/
Comment 3 Jens Petersen 2003-07-17 18:31:51 EDT
Created attachment 92991 [details]
patch to add include dirs to package manifest
Comment 4 Michael Lee Yohe 2003-08-12 11:02:07 EDT
This is, in general, a good idea.  I am wondering, however, if these directories
were left behind because some plugins tend to install themselves into
/usr/lib/mozilla-1.x instead of the symbolic link /usr/lib/mozilla.

I think some sort of logic would be good in the removal/upgrade process to
migrate all plugins from legacy directories to the current version directory. 
That way, people don't find themselves unable to view that particular applet or
flash object.
Comment 5 Braden McDaniel 2003-08-12 11:36:43 EDT
That would be bad. Plug-ins that are version-independent should be installing 
themselves in ${libdir}/mozilla/plugins, not the versioned directory.

Regardless, certainly a directory shouldn't be deleted by an RPM uninstall if 
it still has files in it.
Comment 6 Jens Petersen 2003-09-03 23:21:02 EDT
> Regardless, certainly a directory shouldn't be deleted by an RPM uninstall if 
> it still has files in it.

(And indeed rpm doesn't delete non-empty directories.)
Comment 8 Steve Snyder 2004-08-05 13:04:43 EDT
Just a reminder that, 1.5 years after being reported, this is still a
problem.  

After upgrading to mozilla-1.7.2 I noticed that directories
/usr/lib/mozilla-1.7 and /usr/include/mozilla-1.7 were still present
on my system.  As was the directory structures from the even older
mozilla-1.6 installation.  The RPM upgrade correctly removed the old
files in these directories, but left the directory structures in place.

These obsolete directory structures are useless and should be removed.
Comment 9 Jens Petersen 2004-08-08 23:19:05 EDT
This seems to be fixed in mozilla-1.7.2-0.2.0 finally. :)
Comment 10 Christopher Aillon 2005-03-31 05:52:14 EST

*** This bug has been marked as a duplicate of 74160 ***
Comment 11 Braden McDaniel 2006-07-10 17:58:03 EDT
This problem persists. Upgrading from mozilla 1.7.12 to 1.7.13 leaves a bunch of
directories around.
Comment 12 Matěj Cepl 2007-02-05 07:53:18 EST
Mozilla has been removed from Fedora, and this has been already fixed in firefox.

Note You need to log in before you can comment on or make changes to this bug.