Bug 810451 - Logging out crashes i686 LiveCD system
Logging out crashes i686 LiveCD system
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 810137 810447 (view as bug list)
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-04-06 04:12 EDT by Kamil Páral
Modified: 2012-06-15 20:16 EDT (History)
19 users (show)

See Also:
Fixed In Version: gdm-3.4.1-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 22:36:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
audit.log (32.46 KB, text/plain)
2012-04-06 04:13 EDT, Kamil Páral
no flags Details
dmesg (31.85 KB, text/plain)
2012-04-06 04:13 EDT, Kamil Páral
no flags Details
messages (70.57 KB, text/plain)
2012-04-06 04:14 EDT, Kamil Páral
no flags Details
rpm-qa.out (34.18 KB, text/plain)
2012-04-06 04:14 EDT, Kamil Páral
no flags Details
Xorg.0.log (34.29 KB, text/plain)
2012-04-06 04:14 EDT, Kamil Páral
no flags Details
Xorg.0.log.old (28.67 KB, text/plain)
2012-04-06 04:14 EDT, Kamil Páral
no flags Details
Xorg.1.log (26.08 KB, text/plain)
2012-04-06 04:14 EDT, Kamil Páral
no flags Details
gdm :0.log (23.51 KB, text/plain)
2012-04-06 04:14 EDT, Kamil Páral
no flags Details
gdm :0.log.1 (1.05 KB, text/plain)
2012-04-06 04:14 EDT, Kamil Páral
no flags Details
gdm :0-slave.log (971 bytes, text/plain)
2012-04-06 04:14 EDT, Kamil Páral
no flags Details
gdm :0-slave.log.1 (528 bytes, text/plain)
2012-04-06 04:14 EDT, Kamil Páral
no flags Details
gdm :1.log (17.71 KB, text/plain)
2012-04-06 04:14 EDT, Kamil Páral
no flags Details
gdm :1-slave.log (205 bytes, text/plain)
2012-04-06 04:14 EDT, Kamil Páral
no flags Details
syslog when error on logout causes machine restart (21.13 KB, text/plain)
2012-04-06 19:23 EDT, Tim Flink
no flags Details

  None (edit)
Description Kamil Páral 2012-04-06 04:12:29 EDT
Description of problem:
I booted F17 Beta RC3 i686 LiveCD system in virt-manager and wanted to re-login. My use case was to force fallback mode, which needs logging out and in again. After logging out, there was a brief flash of new X/gdm spawning (black screen with rotating cursor) and then X probably crashed (graphics errors displayed for a short time) and the whole VM shut down. I reproduced it many times. The VM either shuts down completely, or X/gdm crashes several times and then I appear logged in again on display :1. There is a selinux error displayed, bug 810447. I never logged out correctly.

I tried the same on x86_64 LiveCD and logging out worked flawlessly there. It means it's a problem of i686 only.

I can't collect any logs when the VM shuts down completely. So I at least collected some logs when X/gdm crashed repeatedly, but then logged me again.

I tried both qxl+spice and cirrus+vnc, happens in both. I didn't test on bare metal machine, I'll try to do that.

Version-Release number of selected component (if applicable):
Fedora 17 Beta RC3 LiveCd *i686*
gdm-3.4.0.1-1.fc17.i686
xorg-x11-server-common-1.12.0-2.fc17.i686

How reproducible:
always

Steps to Reproduce:
1. boot i686 livecd
2. select Log out
3. see either VM shut off or X crashes and then automatic log-in again
Comment 1 Kamil Páral 2012-04-06 04:13:52 EDT
Created attachment 575654 [details]
audit.log
Comment 2 Kamil Páral 2012-04-06 04:13:58 EDT
Created attachment 575655 [details]
dmesg
Comment 3 Kamil Páral 2012-04-06 04:14:03 EDT
Created attachment 575656 [details]
messages
Comment 4 Kamil Páral 2012-04-06 04:14:08 EDT
Created attachment 575657 [details]
rpm-qa.out
Comment 5 Kamil Páral 2012-04-06 04:14:13 EDT
Created attachment 575658 [details]
Xorg.0.log
Comment 6 Kamil Páral 2012-04-06 04:14:17 EDT
Created attachment 575659 [details]
Xorg.0.log.old
Comment 7 Kamil Páral 2012-04-06 04:14:21 EDT
Created attachment 575660 [details]
Xorg.1.log
Comment 8 Kamil Páral 2012-04-06 04:14:28 EDT
Created attachment 575661 [details]
gdm :0.log
Comment 9 Kamil Páral 2012-04-06 04:14:32 EDT
Created attachment 575662 [details]
gdm :0.log.1
Comment 10 Kamil Páral 2012-04-06 04:14:37 EDT
Created attachment 575663 [details]
gdm :0-slave.log
Comment 11 Kamil Páral 2012-04-06 04:14:41 EDT
Created attachment 575664 [details]
gdm :0-slave.log.1
Comment 12 Kamil Páral 2012-04-06 04:14:46 EDT
Created attachment 575665 [details]
gdm :1.log
Comment 13 Kamil Páral 2012-04-06 04:14:50 EDT
Created attachment 575666 [details]
gdm :1-slave.log
Comment 14 Kamil Páral 2012-04-06 04:16:57 EDT
What I see in the logs:

dmesg:
[   51.077447] gnome-shell[1367]: segfault at 0 ip 01df70dd sp bffcdb00 error 4 in libaccountsservice.so.0.0.0[1de4000+39000]

Xorg.0.log.old:
[    52.805] Server terminated successfully (0). Closing log file.

gdm :0.log.1:
Server terminated successfully (0). Closing log file.

gdm :0-slave.log.1:
gdm-autologin][1052]: pam_unix(gdm-autologin:session): session closed for user liveuser
gdm-simple-slave[841]: WARNING: Child process 1052 was already dead.
gdm-simple-slave[841]: WARNING: Unable to kill session worker process
Comment 15 Kamil Páral 2012-04-06 04:19:58 EDT
Proposing as Beta blocker due to criterion:

"All release-blocking desktops' offered mechanisms (if any) for shutting down, logging out and rebooting must work"
https://fedoraproject.org/wiki/Fedora_17_Beta_Release_Criteria

This is confirmed to be broken just on the LiveCD system, I haven't tested on installed system (I'll try that soon). But I believe there are valid use cases even on livecd system to log out (e.g. changing desktop to fallback mode if there are some rendering problems). LiveCDs are often used for fixing broken systems, therefore hard shutdown without unmounting disks correctly could be potentially harmful.
Comment 16 Kamil Páral 2012-04-06 04:41:04 EDT
This *does not* happen in an installed system in the exactly same VM from that particular LiveCD, only in the live environment itself.
Comment 17 Kamil Páral 2012-04-06 04:53:07 EDT
I can reproduce this on bare-metal machine with i686 LiveCD dd'd to USB stick. However, it never powered-off hard for me, it always just respawned another desktop session with liveuser automatically logged in.

It has one further drawback however - you can't power off the system, if you don't know the hidden Alt key in GNOME's user menu. Logging out doesn't work -> no poweroff/restart options visible.
Comment 18 Petr Schindler 2012-04-06 06:09:14 EDT
I can confirm this. I've got the same result with liveCD in KVM.

+1 blocker
Comment 19 Tim Flink 2012-04-06 13:56:58 EDT
I reproduced this as well. If I add  'selinux=0' to the boot args, I can logout of the live session without issue.
Comment 20 Adam Williamson 2012-04-06 14:08:40 EDT
re-assigning to selinux-policy.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Adam Williamson 2012-04-06 14:12:42 EDT
The AVC for this has been reported as https://bugzilla.redhat.com/show_bug.cgi?id=810447 . Marking that as a dupe of this.
Comment 22 Adam Williamson 2012-04-06 14:13:03 EDT
*** Bug 810447 has been marked as a duplicate of this bug. ***
Comment 23 Miroslav Grepl 2012-04-06 17:42:09 EDT
Is this really SELinux issue? I am not able to reproduce it. I am able to log out/in in either enforcing or permissive mode.

I see the same AVC msg. This tells me that gdb is executed by xdm_t because of a crash.
Comment 24 Tim Flink 2012-04-06 18:02:09 EDT
(In reply to comment #23)
> Is this really SELinux issue? I am not able to reproduce it. I am able to log
> out/in in either enforcing or permissive mode.

Which livecd are you using? This only seems to affect i686, not x86_64.

When I try with the F17 beta RC3 Desktop i686 livecd, I see the problem almost every time I log out unless I used 'selinux=0' at boot time.
Comment 25 Miroslav Grepl 2012-04-06 18:23:17 EDT
I use the same from

http://dl.fedoraproject.org/pub/alt/stage/17-Beta.RC3/Live/i686/

could you boot with enforcing=0 and then 

$ semodule -DB

re-login

$ ausearch -m avc  -ts recent |audit2allow
Comment 26 Tim Flink 2012-04-06 19:23:24 EDT
Created attachment 575843 [details]
syslog when error on logout causes machine restart

(In reply to comment #25)
> could you boot with enforcing=0 and then 
> 
> $ semodule -DB
> 
> re-login
> 
> $ ausearch -m avc  -ts recent |audit2allow

I tried this the livecd with enforcing=0 and ran semodule -DB. Every time I logged out, the VM that the livecd is in restarted and I can't run the second command.

I tried again, tailing the system log on a serial console when I logged out and was able to capture a gdm crash.
Comment 27 Miroslav Grepl 2012-04-06 19:43:54 EDT
Ok, I see it now.
Comment 28 Miroslav Grepl 2012-04-09 04:40:38 EDT
My observation is the following:

This happens either enforcing or permissive mode. This does not happen with selinux=disabled.

Dan,
any idea?
Comment 29 Daniel Walsh 2012-04-09 11:28:26 EDT
Could this be accountsservice or gdm doing a libselinux call and crashing?
Comment 30 Tim Flink 2012-04-09 11:35:35 EDT
A little late but:

This bug was discussed at the 2012-04-06 Fedora 17 beta blocker review meeting.
We agreed to accept this as a blocker for Fedora 17 beta due to conditional
violation (i686 Live CD) of the following Fedora 17 beta release criterion [1]
:

All release-blocking desktops' offered mechanisms (if any) for shutting down,
logging out and rebooting must work

[1] https://fedoraproject.org/wiki/Fedora_17_Beta_Release_Criteria
Comment 31 Miroslav Grepl 2012-04-09 13:07:49 EDT
(In reply to comment #29)
> Could this be accountsservice or gdm doing a libselinux call and crashing?

Yes, this is also my suspect.
Comment 32 Daniel Walsh 2012-04-09 14:26:02 EDT
We have found the problem in gdm, totally unrelated to SELinux.  The problem arises from the move from consolekit to systemd-login for discovering the seats associated with a logged in user.  Ray is fixing it now.
Comment 33 Fedora Update System 2012-04-09 14:33:11 EDT
gdm-3.4.0.1-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gdm-3.4.0.1-4.fc17
Comment 34 Adam Williamson 2012-04-09 15:07:31 EDT
I built a test live image with the new gdm, and it still appears to be broken. Ray is investigating further.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 35 Kamil Páral 2012-04-09 15:31:24 EDT
(In reply to comment #32)
> We have found the problem in gdm, totally unrelated to SELinux. 

Maybe that's a different problem? Because this one is supposed to be influenced by selinux=disabled.
Comment 36 Daniel Walsh 2012-04-09 15:42:24 EDT
The gdm problem is random since he was walking off into memory, perhaps changing the SELinux settings changed the way memory was layed out and you don't hit the problem.  But I believe this issue has nothing to do with SELinux.
Comment 37 Fedora Update System 2012-04-09 15:56:13 EDT
gdm-3.4.0.1-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gdm-3.4.0.1-5.fc17
Comment 38 Fedora Update System 2012-04-10 16:16:26 EDT
Package gdm-3.4.0.1-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gdm-3.4.0.1-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5573/gdm-3.4.0.1-5.fc17
then log in and leave karma (feedback).
Comment 39 bodhi.zazen 2012-04-10 23:59:16 EDT
fixed the issue here (can log out and back in on the live cd).

I added karma on bodhi, just posting here as this bug is listed as a Beta blocking bug.





-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 40 Sergio 2012-04-11 14:37:25 EDT
Just commenting that I upgraded an installed F17 i686 (with selinux disabled) to gdm-3.4.0.1-4.fc17 and it crashed at login. I had to downgrade back to gdm-3.4.0.1-1.fc17
I'm waiting now for gdm-3.4.0.1-5.fc17 to be available here.
Comment 41 Fedora Update System 2012-04-11 22:36:33 EDT
gdm-3.4.0.1-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 42 Owen Taylor 2012-04-12 11:55:16 EDT
*** Bug 810137 has been marked as a duplicate of this bug. ***
Comment 43 Fedora Update System 2012-04-14 15:25:42 EDT
gdm-3.4.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gdm-3.4.1-1.fc17
Comment 44 Fedora Update System 2012-04-18 18:48:33 EDT
gdm-3.4.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 45 Devon Janitz 2012-06-15 20:16:31 EDT
This actually happened when I logged in to Fedora 17 64 bit on a regular systems.  Please let me know if I can get additional information for you.
Thanks, Devon

Note You need to log in before you can comment on or make changes to this bug.