Bug 915843 - subscription-manager-migration needs to depend on subscription-manager-migration-data or else it fails.
subscription-manager-migration needs to depend on subscription-manager-migrat...
Status: CLOSED DUPLICATE of bug 811779
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel65 rhsm-2013
  Show dependency treegraph
 
Reported: 2013-02-26 10:51 EST by Peter Robinson
Modified: 2013-03-21 16:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-21 16:09:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2013-02-26 10:51:25 EST
You can do a "yum install subscription-manager-migration" which will give you the rhn-migrate-classic-to-rhsm script to allow you to migrate RHN Classic to SAM/Subscriptions but it fails with the following error:

[root@some-host ~]# rhn-migrate-classic-to-rhsm 
Red Hat account: RHN-Account
Password: 

Retrieving existing RHN Classic subscription information ...

+-----------------------------------------------------+ 
System is currently subscribed to these RHN Classic Channels:
+-----------------------------------------------------+
rhel-x86_64-server-6
Unable to read mapping file: /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
[root@some-host ~]#

The subscription-manager-migration rpm package needs to depend on subscription-manager-migration-data so that the channel-cert-mapping.txt text file is there and the migration then succeeds.
Comment 2 RHEL Product and Program Management 2013-03-02 01:48:18 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Alex Wood 2013-03-21 16:09:50 EDT
The dependency is weird, but was set up on purpose so that subscription-manager could be included in Fedora at some point in the future. The migration-data rpm is RH internal, and thus cannot be a dependency for subscription-manager-migration (which is built from the same source rpm as subscription-manager). We provide instructions for how a user can create their own migration data certs and mapping, in case they ever wanted to use it.

*** This bug has been marked as a duplicate of bug 811779 ***

Note You need to log in before you can comment on or make changes to this bug.