Bug 820750 - TC4 live install to HD fails on first try - Partition(s) 1 on /dev/sda have been written, but we have been unable to inform the kernel of the change
TC4 live install to HD fails on first try - Partition(s) 1 on /dev/sda have ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 819193 819250 (view as bug list)
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-05-10 17:13 EDT by satellit
Modified: 2012-07-18 13:20 EDT (History)
13 users (show)

See Also:
Fixed In Version: anaconda-17.27-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 07:51:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
failure on first attempt using liveinst on TC4 (455.47 KB, text/plain)
2012-05-10 17:13 EDT, satellit
no flags Details
built l-i-t-d on TC4 Desktop x86_64 got this install error (683.72 KB, text/plain)
2012-05-10 19:07 EDT, satellit
no flags Details

  None (edit)
Description satellit 2012-05-10 17:13:06 EDT
Created attachment 583675 [details]
failure on first attempt using liveinst on TC4

Description of problem:
TC4 live install to HD IOException: Partition(s) 1 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further changes.

-Installs on reboot of dd USB.
and l-i-t-d USB live desktop x86_64

Version-Release number of selected component (if applicable):


How reproducible:
every time i686 and x86_64 live install from USB (either l-i-t-d or dd)

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Install on first invocation of liveinst

Expected results:


Additional info:
Comment 1 satellit 2012-05-10 19:07:32 EDT
Created attachment 583690 [details]
built l-i-t-d on TC4 Desktop x86_64 got this install error

ACER ASPIRE ONE N450 booted to external HD install of TC4 Desktop x86_64
Error from anaconda on first try. Installs correctly on second boot of l-i-t-d USB invocation of liveinst. IS this some kind of problem passing the format information on to anaconda or the kernel?

(Previous error was from a TC3 Desktop install)
Comment 2 satellit 2012-05-11 10:13:28 EDT
also encountered same liveinst bug using liveusb-creator in (f17TC4 i686 Desktop install) USB created with --reset-mbr. Tried to use first-screen install to HD option. Used an external USB HD with TC2 Desktop installed on it as a target. Use whole disk non lvm option. Had to reboot USB and then install preceded to completion successfully.
Comment 3 Brian Lane 2012-05-11 11:28:32 EDT
The desktop (GNOME in this case) is mounting the external drive under /run/media/liveuser/UUID even though I canceled the popup when I logged in.

So when anaconda tried to install to it things get confused because it is already mounted.

The live spin desktop shouldn't be automatically mounting things, especially when you cancel the dialog asking you if you want to do that.
Comment 4 John Dulaney 2012-05-11 15:40:59 EDT
Just hit this in KVM/Qemu vm with F17 host
Comment 5 Ray Strode [halfline] 2012-05-11 15:56:50 EDT
A few thoughts:

1) One recent change is user mounts go to /run/media now instead of /media
2) The bubble doesn't ask you if you want to mount, it tells you it mounted
3) This presumably worked before.  My guess is anaconda has code to deal with this, but it broke because the mount point location changed (point 1)

If my assumption in 3 is correct, then it should be straight forward to adapt the code to work with the new location I guess.  Moving back to anaconda under that assumption.
Comment 6 Adam Williamson 2012-05-11 21:05:26 EDT
Discussed at 2012-05-11 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-05-11/f17-final-blocker-review-meeting-5.2012-05-11-17.04.html . Accepted as a blocker per Alpha criterion "The installer must be able to complete an installation using any locally connected storage interface (e.g. PATA, SATA, SCSI etc...) with the default file system ".

AIUI, this bug affects the case where you try to install from a live image to an external hard disk. Right?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 satellit 2012-05-12 06:22:50 EDT
TC5 Desktop l-i-t-d x86_64 same error as above
8 GB USB

this is message when I tried to use TC5 disk-utility to unmount USB /dev/sdb1 after liveinst error message on reboot of USB:

Error unmounting /dev/sdb1: Command-line `umount  "/dev/sdb1"' exited with non-zero exit status 32: umount: /run/initramfs/live: target is busy.
        (In some cases useful info about processes that use
         the device is found by lsof(8) or fuser(1))
 (udisks-error-quark, 0)

Install to external USB HD worked on second try.
Comment 8 satellitgo 2012-05-12 09:34:36 EDT
Ext USB install from l-i-t-d TC5 DVD x86_64 Ext USB install:
gnome/LDXE/Sugar-Desktop from DVD install repo

Boot to LDXE: 
run dd=f17 TC5 Live Desktop x86_64 to 4 GB USB:

Boot from dd=f17 TC5 Live Desktop x86_64  USB:
(eject 3 attempts at mount of previous install of f17 Beta volumes)
Install to Hardisk (liveinst)
External USB HD as target use whole disk non LVM
 Write changes to disk
"ext4 filesystem check failure on /dev/sda3:
File system errors left uncorrected....."

2nd Boot from dd=f17 TC5 Live Desktop x86_64  USB:
Install to Hardisk (liveinst)
External USB HD as target use whole disk non LVM
 Write changes to disk
 "ext4 filesystem check failure on /dev/sda3:
File system errors left uncorrected....."

Will try dd again from gnome desktop....
Comment 9 satellitgo 2012-05-12 10:17:16 EDT
when I re-wrote the  dd USB in Gnome it gave usual error on first try then installed on 2nd try.(Using the same .iso and USB)

Why does a dd written in LXDE not work?
Comment 10 satellitgo 2012-05-13 08:23:24 EDT
more testing with f17 TC5 Live desktop x86_64 l-i-t-d-USB:

Error: "Partition(s) 1 on /dev/sda have been written, but we have been unable to inform the kernel of the change". 

This error occurs if I use an external USB Hard-disk target which has a F17 use whole disk non lvm installation on it.

The fix is to not select the opening screen "install to Hard-Disk". but to "try first without install". them use "disks" (Disk-utility) to re-format the target external USB HD fat with a /dev/sdb1 partition fat label=LIVE boot flag. (the /dev/sdb1 partition remains unmounted.) exit disk-utility and select "Install to Hard-disk" on left panel of gnome. This installs correctly with no errors.
Comment 11 satellitgo 2012-05-13 11:42:53 EDT
Another test:
used disks (disk-utility) on USB to unmount 5 partitions first then installed to existing TC5 Desktop HD

Looks like unmounting existing partitions on target external USB disk is critical for install to succeed.
Comment 12 satellitgo 2012-05-13 11:46:04 EDT
(In reply to comment #11)
> Another test:
> used disks (disk-utility) on USB to unmount 5 partitions first then installed
> to existing TC5 Desktop HD
> 
> Looks like unmounting existing partitions on target external USB disk is
> critical for install to succeed.

This was a liveusb-creator install to USB (with --reset-mbr in command) of 
Fedora-17.TC5-x86_64-Live-Desktop.iso with 1024 persistence

Ref:
https://fedoraproject.org/wiki/Test_Results:Fedora_17_Final_TC5_Install#USB_Stick
Comment 13 Brian Lane 2012-05-14 11:42:09 EDT
No, Anaconda doesn't have code to deal with this. It expects things to me unmounted when it runs. This includes raid, luks, external drives, etc. This is why we tell dracut to ignore all of these with the kernel cmdline.

I wouldn't expect the desktop to stop doing this, but for live spins they need to disable this behavior somehow.
Comment 14 Adam Williamson 2012-05-14 12:03:57 EDT
I think c#13 is entirely wrong and c#5 is entirely right. scripts/anaconda-cleanup has this note:

    live install:
         - unmount everything under /media
         - populate a devicetree and tear everything down

and this code:

     if (mountpoint.startswith("/media") or device.startswith("/dev")) and \
        live_install and not "live" in mounted:
         os.system("umount %s" % mountpoint)

so it needs the obvious patch for the /run/media mount point change.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Brian Lane 2012-05-14 12:51:11 EDT
Adam is correct. Sorry for the confusion.
Comment 16 Fedora Update System 2012-05-14 14:40:36 EDT
anaconda-17.27-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.27-1.fc17
Comment 17 Fedora Update System 2012-05-14 22:30:59 EDT
Package anaconda-17.27-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.27-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7834/anaconda-17.27-1.fc17
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2012-05-16 07:51:42 EDT
anaconda-17.27-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 satellitgo 2012-05-16 08:15:57 EDT
https://fedoraproject.org/wiki/Test_Results:Fedora_17_Final_TC6_Install#USB_Stick

dd and --efi l-i-t-d USB Live Desktop x86_64

EFI Mac boot is unable to reformat use whole disk non LVM have to go to "try
with out installing - diskutility and format target USB Hd to fat with fat
label=LIVE boot flag then Install to HD

This is NOT necessary for bios boot install to HD
Comment 20 Adam Williamson 2012-05-16 13:15:33 EDT
when translated from satellitish, I believe, that means that he found doing a second EFI install to his Mac over the top of an initial install, using 'use all space', resulted in a non-booting system. To get a successful install over the top of an existing Fedora EFI install, he had to reformat the disk with OS X Disk Utility first.

This could well be due to https://bugzilla.redhat.com/show_bug.cgi?id=821187 , I guess?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Jesse Keating 2012-07-18 13:19:10 EDT
*** Bug 819250 has been marked as a duplicate of this bug. ***
Comment 22 Jesse Keating 2012-07-18 13:20:37 EDT
*** Bug 819193 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.