Bug 820959 - Crash when selecting effects, followed by starting recording or switching resolution
Crash when selecting effects, followed by starting recording or switching res...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-bad-free (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
: 748178 820967 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 08:40 EDT by Petr Schindler
Modified: 2012-06-27 23:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 23:25:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cheese's log (6.12 KB, text/x-log)
2012-05-11 08:40 EDT, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2012-05-11 08:40:00 EDT
Created attachment 583830 [details]
cheese's log

Description of problem:
I can see only black window when I click on button 'Effect'. Picture returns after I click on this button again. In attachment you can find log from terminal.

Version-Release number of selected component (if applicable):
cheese-3.4.1-1.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
1. run cheese
2. click on the button 'Effects'
  
Actual results:
Instead of preview of effects I got only black window.

Expected results:
preview of effects is shown

Additional info:
Comment 1 Hans de Goede 2012-06-06 06:04:02 EDT
*** Bug 820967 has been marked as a duplicate of this bug. ***
Comment 2 Hans de Goede 2012-06-06 06:10:33 EDT
Hi,

I'm afraid I cannot reproduce this. Looking at the log it looks like a clutter problem. Can you please try upgrading clutter, cheese and gstreamer to the latest version? :

yum update --enablerepo=updates-testing 'cheese*' 'gstreamer*' 'clutter*'

Thanks,

Hans
Comment 3 Petr Schindler 2012-06-06 07:12:50 EDT
Now there is only few of unworking effects. But still, when I choose some (either working or non-woking) effect and then I try to record a video, it falls on segfault after I click on stop.

versions:
cheese-3.4.2-1.fc17.x86_64
gstreamer-0.10.36-1.fc17.x86_64
clutter-1.10.6-1.fc17.x86_64
Comment 4 Hans de Goede 2012-06-06 07:17:09 EDT
(In reply to comment #3)
> Now there is only few of unworking effects. But still, when I choose some
> (either working or non-woking) effect and then I try to record a video, it
> falls on segfault after I click on stop.
> 
> versions:
> cheese-3.4.2-1.fc17.x86_64
> gstreamer-0.10.36-1.fc17.x86_64
> clutter-1.10.6-1.fc17.x86_64

Ah, I see / can reproduce (crash when recording with effects). I'll put this on my list of things to look into.
Comment 5 Hans de Goede 2012-06-08 08:33:02 EDT
*** Bug 748178 has been marked as a duplicate of this bug. ***
Comment 6 Hans de Goede 2012-06-08 08:46:44 EDT
As you all have noticed, I've been working a lot on fixing cheese / gstreamer bugs the last few days, unfortunately the various bugs about cheese all contain comments about various different issues,
so in order to sort things out, I'm going to update the summary of various bugs, to make clear
which bug is about what.

Pease only add comments to bugs if the bug matches the problem you are having! If none of the below bugs match your issue, please file a new bug!

Here is a list of all bugs I'm actively working on, or which are on my todo list:

bug 797188   10-90 seconds delay before showing video
bug 810429   Cheese crashes on machines with radio/tv devices
bug 815134   Cheese not working with webcam on Thinkpad x120e / x121e
bug 815581   Could not map/get buffers from device '/dev/video0' errors when trying to record
bug 820959   Crash when selecting effects, followed by starting recording or switching resolution
bug 829957   Recorded pictures and videos do not appear in area at bottom of Cheese window
bug 830166   Long starup delay when 0 sized filed exist under Videos/Webcam
Comment 7 Hans de Goede 2012-06-19 17:54:52 EDT
This turns out to be a bug in gstreamer-plugins-bad-free in the geometrictransform plugin. Changing component.

An update fixing this is on its way.
Comment 8 Fedora Update System 2012-06-19 17:56:20 EDT
gstreamer-plugins-bad-free-0.10.23-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gstreamer-plugins-bad-free-0.10.23-7.fc17
Comment 9 Fedora Update System 2012-06-20 15:30:51 EDT
Package gstreamer-plugins-bad-free-0.10.23-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gstreamer-plugins-bad-free-0.10.23-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9733/gstreamer-plugins-bad-free-0.10.23-7.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-06-27 23:25:03 EDT
gstreamer-plugins-bad-free-0.10.23-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.