Bug 817457 - RFE: ability to select all text flows in all documents on project-wide search page
RFE: ability to select all text flows in all documents on project-wide search...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.6-beta-1
Assigned To: David Mason
Joyce Chang
:
: 817578 (view as bug list)
Depends On:
Blocks: 817435
  Show dependency treegraph
 
Reported: 2012-04-30 01:56 EDT by David Mason
Modified: 2013-03-03 22:19 EST (History)
3 users (show)

See Also:
Fixed In Version: verified in Zanata version 1.6.0-beta-2-SNAPSHOT (20120531-0020).
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 20:58:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Mason 2012-04-30 01:56:41 EDT
Description of problem:
(Copied from https://bugzilla.redhat.com/show_bug.cgi?id=817435#c3)
Bigger projects like Installation Guide can contain
~1,000 individual files, each containing only a handful of messages. So it's
very likely to have several search results in as many different files.

(Copied from https://bugzilla.redhat.com/show_bug.cgi?id=817435#c2)
This could still require a lot of clicking if there are
many documents, so I will look at also adding a feature to select all text
flows in all documents.


Version-Release number of selected component (if applicable):
1.6-alpha-1
Comment 1 David Mason 2012-05-07 23:15:58 EDT
*** Bug 817578 has been marked as a duplicate of this bug. ***
Comment 2 David Mason 2012-05-17 03:32:44 EDT
Added 'select all' link next to 'Replace All Selected' button. Note that there is still some work to do on the UI so the link does not stand out well, but it is fully functional.

See: https://github.com/zanata/zanata/commit/556d8f61cdc4b16eb20dda3b4ba8bc8404d917e6
Comment 3 Joyce Chang 2012-05-30 20:11:00 EDT
verified in Zanata version 1.6.0-beta-2-SNAPSHOT (20120531-0020). 

a small suggestion see Bug 826783

Note You need to log in before you can comment on or make changes to this bug.