Bug 817435 - Usability changes to Search & Replace UI
Usability changes to Search & Replace UI
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6-SNAPSHOT
Unspecified Linux
medium Severity medium
: ---
: 1.6.1
Assigned To: David Mason
Ding-Yi Chen
:
Depends On: 817453 817455 817457
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-29 22:12 EDT by Hedda Peters
Modified: 2012-07-03 01:27 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-03 01:27:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-04-29 22:12:59 EDT
Filed from caserun (https://tcms.engineering.redhat.com/run/37375/)

Version-Release number of selected component (if applicable):
Zanata version 1.6.0-alpha-1 (20120419-0011)

Test case PASSED, but a few options I feel are missing, or UI needs improving:

a) There should be an option to either search in msgid, or in msgstr, or in both. (Obviously, replacing only possible in msgstr). 
Example use case (msgid): I want to double-check existing translations for a certain English word, in order to ensure consistency. Hence I need to search through only the msgid strings.
Example use case (msgstr): Existing translations for de_DE contain an English word for a certain term, the previous translator decided to keep the EN word instead of translating into DE. I want to change that. Searching for the word and checking the option "msgstr" gives me only those entries where the troublesome word still appears in the translation, instead of all appearances in EN.
Example use case (msgid+msgstr): I am translating FINAL version but noticed some BETA references from the previous version in English text and existing translation. To clean my translation from them and to report occurences in the English text to the author, I would want to search through msgid+msgst.

b) There is no option to select all search results at once. So in order to actually replace all occurences, I have to manually put the checkmark for every search result.

c) The whole msgstr entry is displayed, as it should be. However the msgid only displays the first line, there is no line break to display the rest.

d) Checkboxes to select search result for replacement should be located closer to the "Replace" button. Currently they are at opposite sides of the screen, meaning rushing the mouse around from left to right to get an entry replaced. More intuitive to have those located together.

e) Same with button "Replace all selected" and individual "Replace" buttons. Seems more intuitive to have them located together, e.g. "Replace all selected" above the column of individual "Replace" buttons.
Comment 1 Hedda Peters 2012-04-29 22:13:27 EDT
Feel free to split this into several bugs as you see fit.
Comment 2 David Mason 2012-04-30 01:14:55 EDT
a) filed as https://bugzilla.redhat.com/show_bug.cgi?id=817453

b) a checkbox to select all text flows in a document has been added and will be in the next release. This could still require a lot of clicking if there are many documents, so I will look at also adding a feature to select all text flows in all documents.

c) this is a simple display issue that will most likely be fixed before the beta.

d) the 'replace' button on each row does not require the row to be selected. The checkboxes are only used for the 'Replace All Selected' button (may currently display as 'Replace All' in some browsers - another simple display issue that will be fixed). Does this change the relevance of this point? Either way this will need to be addressed to make the functionality more intuitive or more usable.

e) filed as https://bugzilla.redhat.com/show_bug.cgi?id=817455
Comment 3 Hedda Peters 2012-04-30 01:26:16 EDT
(In reply to comment #2)

> b) a checkbox to select all text flows in a document has been added and will be
> in the next release. This could still require a lot of clicking if there are
> many documents, so I will look at also adding a feature to select all text
> flows in all documents.
 
That would be good, thanks. Bigger projects like Installation Guide can contain ~1,000 individual files, each containing only a handful of messages. So it's very likely to have several search results in as many different files.


> d) the 'replace' button on each row does not require the row to be selected.
> The checkboxes are only used for the 'Replace All Selected' button (may
> currently display as 'Replace All' in some browsers - another simple display
> issue that will be fixed). Does this change the relevance of this point? Either
> way this will need to be addressed to make the functionality more intuitive or
> more usable.

Of course, my bad. Please disregard, all good then!
Comment 4 David Mason 2012-04-30 01:57:37 EDT
(In reply to comment #3)

> > I will look at also adding a feature to select all text
> > flows in all documents.
> 
> That would be good, thanks. Bigger projects like Installation Guide can contain
> ~1,000 individual files, each containing only a handful of messages. So it's
> very likely to have several search results in as many different files.

b) filed as https://bugzilla.redhat.com/show_bug.cgi?id=817457

> > d) the 'replace' button on each row does not require the row to be selected.
(snip)
> Of course, my bad. Please disregard, all good then!

We're aiming for an interface that is as intuitive as possible, so I think this point is still worth some consideration in case there is a way to make the behaviour more clear.
Comment 5 Joyce Chang 2012-05-07 22:16:10 EDT
*** Bug 817578 has been marked as a duplicate of this bug. ***
Comment 6 David Mason 2012-05-31 22:49:29 EDT
Each of these issues has been addressed. See related bugs
Comment 7 Ding-Yi Chen 2012-06-06 23:21:36 EDT
Hi,

Current implementation (as Zanata version 1.6.1-SNAPSHOT (20120606-0019))
does not quite fit what you described in e).
(Bug 817455).

Do you like the current implementation?
Comment 8 Hedda Peters 2012-06-07 00:29:22 EDT
Thanks guys.

If I wanted to be picky, I'd have to say that the location of the main fields/buttons is not very intuitive:
- "Search" field in top left corner
- "Replace with" field in bottom left corner
- "Replace" button in bottom right corner

More intuitive and/or common is the placement of all these items together.

Also, is there a way to get out of the Search&Replace screen other than using the "back" browser functinonality? I was a bit stuck.

And what is the function of "Required preview"? I can't seem to spot a difference in the behaviour when checking/unchecking that box.
Comment 9 David Mason 2012-06-07 01:08:48 EDT
The plan is to move the contents of the bottom panel (replace textbox and button) to the top right - just ran out of time before the 1.6 release. Fields should be as you describe for 1.7 release, possibly for 1.6.1 if it happens.
Note that key shortcuts are available, which should allow users to avoid excessive mouse movement to focus fields and click buttons. Use Alt+Y to see a list of shortcuts (this is not yet a complete list for the entire editor).

There are a few ways to get out of the search replace screen:
 - browser back function
 - click the project name to return to the doclist
 - click 'view in editor' or 'search in document'  to the right of the document name on any document in search results.

When 'Require preview' is active, the replace button is disabled until previews have been generated for all selected text flows. On a fast connection the previews show up fast enough that this is not noticeable, but for slow connections it may be noticeable. The checkbox is provided so that users on very slow connections can skip waiting for previews if they are interfering with a normal workflow.
Comment 10 David Mason 2012-06-07 02:53:57 EDT
Replacement text box and button moved to top in 1.6.1

See: https://github.com/zanata/zanata/commit/0411f3ba2c840aff5b23f3f47fa1a9e36c730f6d
Comment 11 David Mason 2012-06-07 03:03:41 EDT
Added tooltip to 'Require preview'.

See: https://github.com/zanata/zanata/commit/1dd02bd3c4e2922b8e4d3ec33a24a742fa037e77
Comment 12 Ding-Yi Chen 2012-06-07 21:00:56 EDT
Verified with Zanata version 1.6.1-SNAPSHOT (20120608-0019)

Note You need to log in before you can comment on or make changes to this bug.