This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 817578 - Request for "Select All" button in "Project wide search and replace" feature
Request for "Select All" button in "Project wide search and replace" feature
Status: CLOSED DUPLICATE of bug 817457
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Runa Bhattacharjee
Joyce Chang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 10:37 EDT by Nilamdyuti
Modified: 2013-03-03 22:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 22:16:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nilamdyuti 2012-04-30 10:37:53 EDT
Description of problem:

While testing the new features of web UI in Zanata 1.6 alpha, I felt that it would have been nice if there was an "Select All" button in "Project wide search and replace feature" for selecting all the entries containing the 'searched word' at one go along with the provided feature of selecting them one by one using checkboxes. This will be really helpful when there are several entries containing a word which needs to be replaced with a better contextual replacement. "Select All" will select all the entries and "Replace All" will replace them at one go instead of selecting them one by one by checking the checkboxes and then clicking "Replace All".

Version-Release number of selected component (if applicable):

Zanata 1.6 alpha
Comment 1 Joyce Chang 2012-05-07 22:15:38 EDT
Actually,Zanata 1.6 already has the requested function implemented, allowing all search results to be checked at one time. It's on the very top right of first search result entry,the checkbox right next to "index". When that box is checked, all search results will be selected and ready for replacement that you wish to replace. Still, this display is not intuitive enough and will be fixed before beta. Please refer to bug 817435
Comment 2 Joyce Chang 2012-05-07 22:16:09 EDT

*** This bug has been marked as a duplicate of bug 817435 ***
Comment 3 David Mason 2012-05-07 23:15:58 EDT
(In reply to comment #1)
> Actually,Zanata 1.6 already has the requested function implemented, allowing
> all search results to be checked at one time.

This is not strictly correct, as the checkbox only allows selection of all text flows for a single document, not for multiple documents in the search results.

> Please refer to bug 817435
The specific bug for this feature is 817457, as noted in 817435

*** This bug has been marked as a duplicate of bug 817457 ***
Comment 4 Joyce Chang 2012-05-07 23:51:00 EDT
thanks for fixing!!

Note You need to log in before you can comment on or make changes to this bug.