Bug 817477 - Lightning Menu not displayed
Lightning Menu not displayed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thunderbird-lightning (Show other bugs)
16
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
: 817852 818540 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 04:01 EDT by Felix Schwarz
Modified: 2012-05-18 06:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: thunderbird-12.0.1-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 03:29:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Schwarz 2012-04-30 04:01:53 EDT
Description of problem:
After I updated Thunderbirg+Lightning I can't access my calendar anymore as the menu items are not displayed anymore.

Lightning is still displayed in the settings menu and I see the calendar icon on the lower right.

Version-Release number of selected component (if applicable):
thunderbird-lightning-1.4-1.fc16.x86_64
thunderbird-12.0-1.fc16.x86_64
thunderbird-enigmail-1.4.1-1.fc16.1.x86_64

Additional info:
When starting from the console I see some output from the lightning plugin (e.g. "Warning: Calendar … has a dangling E-Mail identity configured.").

In Thunderbird's error log I see many error messages such as:
Timestamp: 30.04.2012 09:56:33
Error: undefined entity
Source File: chrome://calendar/content/calendar-common-sets.xul
Line: 422, Column: 7
Source Code:
      <menu id="task-context-menu-postpone"
…
Timestamp: 30.04.2012 09:56:33
Error: document.getElementById(kWorkdaysCommand) is null
Source File: chrome://calendar/content/calendar-base-view.xml
Line: 289
…
Timestamp: 30.04.2012 09:56:33
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [calIDateTime.getInTimezone]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://calendar/content/calendar-base-view.xml :: today :: line 537"  data: no]
…
Timestamp: 30.04.2012 09:56:34
Error: command is null
Source File: chrome://calendar/content/calendar-views.js
Line: 316

Creating a fresh Thunderbird profile did not help.
Comment 1 Felix Schwarz 2012-04-30 04:25:33 EDT
The problem is because broken locales (I'm using 'de'). If I start Thunderbird with "LANG=C thunderbird" everything works as expected. Downgrading severity as this is only a problem for some locales.

I found this upstream bug which contains more info on a related issue ( https://bugzilla.mozilla.org/show_bug.cgi?id=736717 ) though the lightning developers consider the bug fixed and the Fedora package seems to use the latest tar ball.
Comment 2 Felix Schwarz 2012-04-30 05:02:54 EDT
I was able to get Lightning working again with the German locale by running 'mklangsource.sh'+rebuild. So I assume that by the time you generated l10n-1.4.tar.xz the hg repos did not contain the fixed translations.
Comment 3 Didier G 2012-04-30 07:28:12 EDT
Sale problem for me using locales fr

I just updated to:

thunderbird-12.0-1.fc16.x86_64
thunderbird-lightning-1.4-1.fc16.x86_64

and when I start Thunderbird in terminal I get:

$ thunderbird
null:profile-after-change
added
added
[object ChromeWindow]:mail-startup-done
-- Exception object --
+ fileName (string) 'chrome://lightning/content/messenger-overlay-sidebar.js'
+ lineNumber (number) 439
*
-- Stack Trace --
ltnSwitch2Calendar()@chrome://lightning/content/messenger-overlay-sidebar.js:439
([object Object],[object Object])@chrome://lightning/content/messenger-overlay-sidebar.js:87
openTab("calendar",[object Object])@chrome://messenger/content/tabmail.xml:548
oncommand([object XULCommandEvent])@chrome://messenger/content/messenger.xul:1
$

Thunderbird run fine with lightning if I specify LANG=C
Comment 4 Didier G 2012-04-30 15:02:42 EDT
For locales fr, problem is fixed by 

thunderbird-lightning-1.4-2.fc16.x86_64.rpm

available on koji: http://koji.fedoraproject.org/koji/buildinfo?buildID=316291
Comment 5 Felix Schwarz 2012-04-30 15:43:45 EDT
yes, works like a charm for me as well.
Comment 6 Fedora Update System 2012-04-30 16:15:09 EDT
thunderbird-12.0.1-1.fc15,thunderbird-lightning-1.4-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/thunderbird-12.0.1-1.fc15,thunderbird-lightning-1.4-2.fc15
Comment 7 Fedora Update System 2012-04-30 16:15:19 EDT
thunderbird-12.0.1-1.fc16,thunderbird-lightning-1.4-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/thunderbird-12.0.1-1.fc16,thunderbird-lightning-1.4-2.fc16
Comment 8 Fedora Update System 2012-04-30 16:15:29 EDT
thunderbird-12.0.1-1.fc17,thunderbird-lightning-1.4-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/thunderbird-12.0.1-1.fc17,thunderbird-lightning-1.4-2.fc17
Comment 9 Orion Poplawski 2012-05-01 11:14:01 EDT
*** Bug 817852 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2012-05-01 17:32:55 EDT
Package thunderbird-12.0.1-1.fc17, thunderbird-lightning-1.4-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing thunderbird-12.0.1-1.fc17 thunderbird-lightning-1.4-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7043/thunderbird-12.0.1-1.fc17,thunderbird-lightning-1.4-2.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-05-03 03:29:52 EDT
thunderbird-12.0.1-1.fc16, thunderbird-lightning-1.4-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Orion Poplawski 2012-05-03 10:49:08 EDT
*** Bug 818540 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2012-05-04 19:06:55 EDT
thunderbird-12.0.1-1.fc17, thunderbird-lightning-1.4-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2012-05-18 06:35:16 EDT
thunderbird-12.0.1-1.fc15, thunderbird-lightning-1.4-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.