Bug 819672 - Unable to build ovirt-node iso on fedora 17 "No packages or groups specified"
Unable to build ovirt-node iso on fedora 17 "No packages or groups specified"
Status: CLOSED DUPLICATE of bug 827269
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Joey Boggs
: Reopened
Depends On: 827269
Blocks: 824420
  Show dependency treegraph
 
Reported: 2012-05-07 19:18 EDT by Netbulae
Modified: 2016-04-26 13:22 EDT (History)
7 users (show)

See Also:
Fixed In Version: 2.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 09:31:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Netbulae 2012-05-07 19:18:21 EDT
Description of problem:

I followed all the steps from the wiki (http://www.ovirt.org/wiki/Node_Building) to compile the node iso from git. But it fails at the very last step :-( 

I tried many different options but all the time I get the error:

"imgcreate.errors.CreatorError: No packages or groups specified"

ovirt-node-iso]# make iso publish
rm -f *.ks
Node Creator script is:  ~/ovirt-node/recipe/node-creator
cp ~/ovirt-node/recipe/*.ks .
rm -f version.ks
( \
    echo "PRODUCT='"oVirt Node Hypervisor"'" ;\
    echo "PRODUCT_SHORT='"oVirt Node Hypervisor"'" ;\
    echo "PACKAGE=ovirt-node-iso" ;\
    echo "VERSION=2.3.0" ;\
    echo "RELEASE=999.02.fc16" ;\
) > version.ks
ksflatten -c ovirt-node-image.ks -o ovirt-node-iso.ks
~/ovirt-node/recipe/node-creator ovirt-node-iso.ks
Traceback (most recent call last):
  File "/bin/livecd-creator", line 210, in <module>
    sys.exit(main())
  File "/bin/livecd-creator", line 174, in main
    title=title, product=product)
  File "/usr/lib/python2.7/site-packages/imgcreate/live.py", line 52, in __init__
    tmpdir=tmpdir)
  File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 788, in __init__
    ImageCreator.__init__(self, ks, name, releasever=releasever, tmpdir=tmpdir)
  File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 84, in __init__
    self.__sanity_check()
  File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 412, in __sanity_check
    raise CreatorError("No packages or groups specified")
imgcreate.errors.CreatorError: No packages or groups specified
ERROR: ISO build failed.
make: *** [iso] Error 1

Version-Release number of selected component (if applicable):

Git

Kind regards,

Jorick Astrego
Netbulae
Comment 1 Netbulae 2012-05-08 05:34:40 EDT
Tried it on a fresh install off Fedora 16 and the process is fine. So I think it has to do with my Fedora 17 install.
Comment 2 Joey Boggs 2012-05-31 20:30:36 EDT
Looks like ksflatten isn't working correctly in F17. ksflatten on ovirt-node-iso.ks results in %include's not be flattend to inside a single kickstart file.
Comment 3 Joey Boggs 2012-05-31 21:20:43 EDT
workaround for now is to install older pykickstart version, bz submitted for pykickstart

http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=37975
Comment 4 Mike Burns 2012-06-14 09:31:58 EDT
No fix needed in ovirt-node, just in pykickstart

*** This bug has been marked as a duplicate of bug 827269 ***

Note You need to log in before you can comment on or make changes to this bug.