Bug 820985 - Searching for duplicate anaconda bugs while reporting exception against partner-bugzilla during install fails
Searching for duplicate anaconda bugs while reporting exception against partn...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
17
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker 823411 826957
  Show dependency treegraph
 
Reported: 2012-05-11 09:46 EDT by Tim Flink
Modified: 2012-05-31 05:59 EDT (History)
11 users (show)

See Also:
Fixed In Version: libreport-2.0.10-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 823411 (view as bug list)
Environment:
Last Closed: 2012-05-15 23:15:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from reporter-bugzilla -vvvd (718 bytes, text/plain)
2012-05-11 10:06 EDT, Tim Flink
no flags Details

  None (edit)
Description Tim Flink 2012-05-11 09:46:19 EDT
After deliberately causing a failure in anaconda, reporting the first issue in partner-bugzilla works fine but causing the same failure a second time fails. The following log information is shown:

--- Running report_Bugzilla ---
Logging into Bugzilla at https://partner-bugzilla.redhat.com/
Checking for duplicates
fatal: (null)
(exited with 1)

At the time of this report, the partner-bugzilla duplicate is https://partner-bugzilla.redhat.com/show_bug.cgi?id=819676

If I report the same traceback multiple times to bugzilla.redhat.com, the log output on screen looks like:

--- Running report_Bugzilla ---
Logging into Bugzilla at https://bugzilla.redhat.com
Checking for duplicates
Bug is already reported: 820975
Logging out
Status: NEW https://bugzilla.redhat.com/show_bug.cgi?id=820975

My testing thus far has been with F17 final TC4. The exact procedure that I've been using to cause a failure in anaconda is as follows:
 1. boot DVD iso with the extra param:
   updates=http://tflink.fedorapeople.org/updates/f17_traceback.img
 2. proceed with installation until the timezone selection screen where a 
   traceback will happen
 3. Save the traceback to either bugzilla.redhat.com or 
    partner-bugzilla.redhat.com
Comment 1 Tim Flink 2012-05-11 10:06:26 EDT
Created attachment 583856 [details]
output from reporter-bugzilla -vvvd

I ran reporter-bugzilla -vvvd -c /etc/libreport/plugins/bugzilla.conf -d <crash_dir> after hitting the exception.

Attached the results of that command.
Comment 2 Tim Flink 2012-05-12 10:55:28 EDT
Proposing as a release blocker for F17 final due to violation of the following alpha release criterion [1]:

The installer must be able to report failures to Bugzilla and local disk, with appropriate information included.

This can't be fixed post release and the inability for the installer to report failures with any duplicates is a significant handicap.

[1] http://fedoraproject.org/wiki/Fedora_17_Alpha_Release_Criteria
Comment 3 Tim Flink 2012-05-12 11:01:33 EDT
Note that bugzilla.redhat.com is schedule to be upgraded before the release of F17 - hence the blocker proposal.
Comment 4 Nikola Pajkovsky 2012-05-14 07:04:17 EDT
commit 386bcecdff5eeea2f0855e9b91b73f862fa11860
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Mon May 14 13:03:25 2012 +0200

    rhbz#820985 - bz 4.2 doesn't have 'bug_id' member; it's 'id'
    
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>
Comment 5 Adam Williamson 2012-05-14 11:37:32 EDT
We would also want the next patch:

http://git.fedorahosted.org/git/?p=libreport.git;a=commit;h=add5f6eed5cae2f0618707ed9c642f692426d8d7

"bugzilla: query bz version and for 4.2 use 'id' element for getting bug number, for others use 'bug_id'"



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Fedora Update System 2012-05-14 13:40:54 EDT
libreport-2.0.10-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreport-2.0.10-3.fc17
Comment 7 Tim Flink 2012-05-14 14:46:14 EDT
Discussed during the 2012-05-14 mini blocker review meeting. Accepted as a blocker bug for Fedora 17 final due to violation of the following Fedora 17 alpha release criterion [1]:

The installer must be able to report failures to Bugzilla and local disk, with appropriate information included

[1] http://fedoraproject.org/wiki/Fedora_17_Alpha_Release_Criteria
Comment 8 Fedora Update System 2012-05-14 22:31:48 EDT
Package libreport-2.0.10-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreport-2.0.10-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7851/libreport-2.0.10-3.fc17
then log in and leave karma (feedback).
Comment 9 Tim Flink 2012-05-14 23:32:20 EDT
Tested with a custom boot.iso built with the libreport update from comment#8 Duplicate issue was successfully detected and libreport is functioning as expected.

Setting to VERIFIED, new builds should be pulled into the next TC/RC
Comment 10 Fedora Update System 2012-05-15 23:15:30 EDT
libreport-2.0.10-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-05-21 06:17:21 EDT
libreport-2.0.10-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreport-2.0.10-3.fc16

Note You need to log in before you can comment on or make changes to this bug.