Bug 821186 - tapset errors in qemu-kvm.stp with "in" and "from" keywords
tapset errors in qemu-kvm.stp with "in" and "from" keywords
Status: CLOSED DUPLICATE of bug 831763
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 18:02 EDT by Dominic Cleal
Modified: 2013-01-09 07:01 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 07:23:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dominic Cleal 2012-05-12 18:02:37 EDT
Description of problem:
Trying to run an unrelated systemtap script shows two parse errors with these lines:

in = $arg3;
next = $arg1;

Identical errors are shown for qemu-kvm.stp, qemu-system-i386.stp and qemu-system-x86_64.stp, showing a total of six.

Version-Release number of selected component (if applicable):
qemu-system-x86-1.0-17.fc17.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. run stap -e ''
2. check for any parse errors relating to qemu
  
Actual results:
$ stap -e ''
Input file '<input>' is empty or missing.
parse error: expected statement
	saw: keyword at /usr/share/systemtap/tapset/qemu-kvm.stp:1139:3
     source:   in = $arg3;
               ^
parse error: expected literal string or number
	saw: operator '=' at /usr/share/systemtap/tapset/qemu-kvm.stp:2078:8
     source:   next = $arg1;
                    ^
2 parse errors.


Expected results:
$ stap -e ''
Input file '<input>' is empty or missing.

Additional info:
Already reported against RHEL 6 as bug #720979, bug #798676 and #820320.  These only report the "next" error, not the "in" error though.

See bug #820320, comment #2 for a list of all reserved keywords.
Comment 1 Cole Robinson 2012-07-10 07:23:33 EDT

*** This bug has been marked as a duplicate of bug 831763 ***

Note You need to log in before you can comment on or make changes to this bug.