Bug 823309 - Performance problems when filing a new bug with many components
Performance problems when filing a new bug with many components
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Performance (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity urgent (vote)
: ---
: ---
Assigned To: Simon Green
:
: 823496 823760 823958 823997 824006 (view as bug list)
Depends On:
Blocks: BZ42
  Show dependency treegraph
 
Reported: 2012-05-20 15:46 EDT by Dan Mashal
Modified: 2014-10-12 18:48 EDT (History)
7 users (show)

See Also:
Fixed In Version: 4.2.1-1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-22 07:52:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Mashal 2012-05-20 15:46:26 EDT
Description of problem:

Bugzilla has performance issues when creating a new bug.

Version-Release number of selected component (if applicable):

4.2

How reproducible:

Easy

Steps to Reproduce:
1. Login
2. Click New
3. Choose Fedora

  
Actual results:

Web browser spins for 2 minutes

After about 2 minutes you are presented with the create bug screen.

Expected results:

Should take you to new bug screen instantly.

Additional info:

None.
Comment 1 Mikolaj Izdebski 2012-05-21 10:06:07 EDT
I have the same problem.
The direct link to the page causing the problem is:
https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora

Usually I need to wait for about 2-3 minutes for the page to load,
but sometimes it fails to load with the following error:

502 Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /enter_bug.cgi.

Reason: Error reading from remote server

Apache Server at bugzilla.redhat.com Port 443
Comment 2 Simon Green 2012-05-22 01:48:39 EDT
*** Bug 823760 has been marked as a duplicate of this bug. ***
Comment 4 Simon Green 2012-05-22 07:54:21 EDT
This will be fixed in an release that will be put live in the next few hours.

If a product has more than 200 components, we will use AJAX to get the component information, rather than load all the information on the page itself.

  -- simon
Comment 5 Simon Green 2012-05-22 11:10:35 EDT
*** Bug 824006 has been marked as a duplicate of this bug. ***
Comment 6 Simon Green 2012-05-22 11:10:53 EDT
*** Bug 823997 has been marked as a duplicate of this bug. ***
Comment 7 Simon Green 2012-05-22 17:25:40 EDT
This change is now live.
Comment 8 Simon Green 2012-05-22 18:01:34 EDT
*** Bug 823958 has been marked as a duplicate of this bug. ***
Comment 9 Simon Green 2012-05-22 20:26:42 EDT
*** Bug 823496 has been marked as a duplicate of this bug. ***
Comment 10 Dan Mashal 2012-05-23 00:20:47 EDT
Thanks Simon.

Note You need to log in before you can comment on or make changes to this bug.