Bug 823413 - Show comments and groups side by side, not comments below groups
Show comments and groups side by side, not comments below groups
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Matt Tyson
tools-bugs
:
: 623139 823865 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 04:19 EDT by Miroslav Franc
Modified: 2016-01-31 21:27 EST (History)
12 users (show)

See Also:
Fixed In Version: 4.2.4-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 19:43:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (141.86 KB, image/jpeg)
2012-05-21 04:19 EDT, Miroslav Franc
no flags Details

  None (edit)
Description Miroslav Franc 2012-05-21 04:19:04 EDT
Description of problem:

In the new version of bugzilla the comments are shown below "groups that can view the bug". Please see the screenshot. This doesn't make much sense since the groups are in the right column, while comments are in the left one. In case there are too many groups (too often) there's this huge empty space before the first comment appear. One has to scroll down a lot just to read the first comment in order to find out what the bug is really about.
Comment 1 Miroslav Franc 2012-05-21 04:19:53 EDT
Created attachment 585758 [details]
screenshot
Comment 2 Tomas Hoger 2012-05-23 03:02:04 EDT
*** Bug 823865 has been marked as a duplicate of this bug. ***
Comment 3 Tomas Radej 2012-05-23 04:10:44 EDT
Confirming the bug on screens of any width.
Comment 4 Martin Cermak 2012-06-12 04:48:30 EDT
Confirming too.
Comment 5 Branislav Blaškovič 2012-09-19 07:26:48 EDT
Any progress?
Comment 6 Simon Green 2012-09-27 09:25:41 EDT
(In reply to comment #5)
> Any progress?

This was discussed at today's Red Hat Bugzilla meeting. One of the problems with the current page is that mandatory groups are not shown in the list at all.

The proposed solution to both problems is that when the show bug page is loaded, we will show a list of currently enabled groups for the bug (or 'Publicly visible' if there are none), and add an '(edit)' link so that the group privileges can be edited. This is like many other fields in Red Hat Bugzilla's edit page.

No change will be made to the group pages when editing products or changing multiple bugs. This change deals with just the show_bug.cgi page.

If any one sees any problems with this change, please let me know.
Comment 7 Simon Green 2012-10-09 03:50:32 EDT
*** Bug 623139 has been marked as a duplicate of this bug. ***
Comment 9 Matt Tyson 2012-10-18 21:30:41 EDT
I've hidden the groups field behind an edit box, so that it now behaves similar to other expandable fields.

It will display a brief summary of what groups are selected, and then when you click the edit link it will expand into the normal group view.

Note You need to log in before you can comment on or make changes to this bug.