Bug 823423 - the right side text fields and the long link in comments are out of the normal frame.
the right side text fields and the long link in comments are out of the norma...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Product Browser (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Matt Tyson
tools-bugs
:
: 918722 919408 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 04:40 EDT by yawei Li
Modified: 2013-09-15 21:52 EDT (History)
7 users (show)

See Also:
Fixed In Version: 4.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 07:04:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot1 (162.19 KB, image/png)
2012-05-21 04:40 EDT, yawei Li
no flags Details
screenshot2 (125.74 KB, image/png)
2012-05-21 04:42 EDT, yawei Li
no flags Details

  None (edit)
Description yawei Li 2012-05-21 04:40:28 EDT
Created attachment 585764 [details]
screenshot1

Description of problem:
in current bugzilla version, seems the layout has some prolem in firefox and chrome.
the right up side feilds box are bigger out of the nomal browser frame.
And when there is a long link in comments, it is also out of the box.
for example: bug 735878

Version-Release number of selected component (if applicable):
4.2.1-1

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 yawei Li 2012-05-21 04:42:16 EDT
Created attachment 585765 [details]
screenshot2
Comment 2 Simon Green 2012-10-10 02:25:04 EDT
Another UI issue that we can fix for the new version. I suspect the resolution is to make it wider. After all, we cannot make the text smaller :)
Comment 3 Matt Tyson 2012-11-19 19:41:04 EST
I've fixed this by adding some CSS that tells the browser to word wrap really long lines.

These links should now fit within the div or span they are declared in.
Comment 6 Chen Chen 2013-02-18 23:39:59 EST
verified version 4.4-1 on test server --> FAIL

Verify steps:
1.Log in bugzilla and open bug 735878 details page.
  
Actual results:
The long link in comment is not word wrap within the div.

Expected results:
The long link in comment is word wrap within the div.
Comment 7 Matt Tyson 2013-02-21 22:57:04 EST
Bugzilla has CSS to prevent line wrapping on quoted text.

Taking into account the line wrapping CSS introduced in comment 3:

Firefox will not line wrap quoted text.
Chrome will line wrap quoted text.

What I am seeing is that URLs are being wrapped when they are not quoted. EG bug 735878 comment 0. (Both Firefox and Chrome)

Comment 1 of bug 735878 is wrapped in Chrome and not wrapped in Firefox.
Comment 20 Simon Green 2013-03-10 06:07:04 EDT
*** Bug 918722 has been marked as a duplicate of this bug. ***
Comment 21 Simon Green 2013-03-10 06:07:14 EDT
*** Bug 919408 has been marked as a duplicate of this bug. ***
Comment 24 Simon Green 2013-03-15 00:53:07 EDT
I forgot to cherry pick this change into the release4.4-2 branch. I have now done so.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.