Bug 828042 - [ja_JP] [RHSM Firstboot] Subscription list is blank in Confirm Subscriptions page of Firstboot
[ja_JP] [RHSM Firstboot] Subscription list is blank in Confirm Subscriptions ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Michael Stead
Entitlement Bugs
: i18n, TestBlocker, ZStream
Depends On:
Blocks: 738066 830267 833148
  Show dependency treegraph
 
Reported: 2012-06-04 02:23 EDT by Lijun Li
Modified: 2012-12-10 16:42 EST (History)
10 users (show)

See Also:
Fixed In Version: subscription-manager-1.0.4-1
Doc Type: Bug Fix
Doc Text:
In the Japanese version of Subscription Manager, the Subscriptions List screen is empty in firstboot. This is fixed in Errata RHBA-2012:13347-1.
Story Points: ---
Clone Of:
: 833148 (view as bug list)
Environment:
Last Closed: 2012-12-10 16:42:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ja_JP Subscription list is blank in Confirm Subscriptions page of Firstboot (151.55 KB, application/octet-stream)
2012-06-04 02:30 EDT, Lijun Li
no flags Details
ja_JP Subscription list is blank in Confirm Subscriptions page of Firstboot (151.55 KB, image/png)
2012-06-04 03:09 EDT, Lijun Li
no flags Details
fixed (180.87 KB, image/png)
2012-06-20 11:24 EDT, J.C. Molet
no flags Details

  None (edit)
Description Lijun Li 2012-06-04 02:23:35 EDT
Description of problem:
[ja_JP] [RHSM Firstboot] Subscription list is blank in Confirm Subscriptions page of Firstboot

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-0.99.19-1.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Install latest RHEL6.3 Server build (RC-2/RHEL6.3-20120531.0).
2. Go to first boot page or run # firstboot --reconfig on a terminal.
3. Register System using RHN account and password, but Do not select 'Skip automatic subscription selection for this system' option and click Forward.

  
Actual results:
Subscription list is blank in Confirm Subscriptions page of Firstboot.

Expected results:
The subscriptions should be listed under Subscription in Confirm Subscriptions page. 

Additional info:
It works fine in en_US locale.
Comment 2 Lijun Li 2012-06-04 02:30:56 EDT
Created attachment 589049 [details]
ja_JP Subscription list is blank in Confirm Subscriptions page of Firstboot
Comment 3 Lijun Li 2012-06-04 03:09:41 EDT
Created attachment 589053 [details]
ja_JP Subscription list is blank in Confirm Subscriptions page of Firstboot
Comment 9 Adrian Likins 2012-06-05 12:55:43 EDT
So, we seem to have tracked down the cause for this. The
rhn_review_gui screen and the rshm_confirm_subs screen
have the same translated name in japanese. Which
confuses 6.3 firstboot.

For the ja_JP cases what seems to happen bahiour wise
is the data on the confirm screen is never shown. Normally
this would show you what service level you are using, and
the susbcription chosen to fullfil it. Because of the duplicate
labels, the wrong module is updating it gui, so that info
never get's display on our screen. If you select "forward"
it seems like the right thing is happening (the system get
susbcribe to whatever should have been shown in that
screen) but because of the module reference confusion, the
rhn_finish_screen is shown with an warning. That warning
is incorrect because the correct thing did happen, and you
end up properly auto subscribed. 

So far, it only seems to affect ja_JP, though in theory,
it could affect any locale that has duplicate translated
names for the modules. That does not seem to be the case
for other modules however.
Comment 10 Lijun Li 2012-06-06 03:42:29 EDT
Verified it's only reproduced in ja_JP locale, not reproduced on other locales like:
zh_CN
zh_TW
ko_KR
de_DE
fr_FR
pt_BR
ru_RU
es_ES
it_IT
as_IN
bn_IN
...
xx_IN.
Comment 12 Michael Stead 2012-06-06 07:59:11 EDT
I suggest changing the title of rhsm_confirm_subs screen to something like:

Confirm Your Subscriptions

Is this Ok with everyone? Can anyone confirm that this would be translated differently in Japanese?
Comment 14 Michael Stead 2012-06-07 14:15:16 EDT
We will include in z-stream.
Comment 15 Michael Stead 2012-06-08 11:27:56 EDT
This was actually fixed by adding a space to the end of the "Confirm Subscriptions" translation in the ja.po, instead of the approach mentioned in comment 12.

While less optimal, this was fix was less intrusive when looking at porting to 6.3 z-stream as it would not dissrupt the working translations.

Fixed in:

master - db0f648fddf1cef8db23e9771f03ae29e161145d
Comment 17 J.C. Molet 2012-06-20 11:24:37 EDT
Created attachment 593246 [details]
fixed

Testing using the latest builds in brew:

subscription-manager-firstboot-0.99.19.3-1.el6_3.x86_64
python-rhsm-0.99.12-1.el6.noarch
subscription-manager-gnome-0.99.19.3-1.el6_3.x86_64
subscription-manager-0.99.19.3-1.el6_3.x86_64

As is shown by the screenshot this window is now populated with columns and entries.

Marking this VERIFIED
Comment 18 Deon Ballard 2012-06-29 18:09:05 EDT
Adding tech note summary.
Comment 19 Deon Ballard 2012-06-29 18:09:05 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In the Japanese version of Subscription Manager, the Subscriptions List screen is empty in firstboot. This is fixed in Errata RHBA-2012:13347-1.
Comment 20 Bryan Kearney 2012-12-10 16:42:11 EST
Bug Clean Up, these are in the current release.

Note You need to log in before you can comment on or make changes to this bug.