Bug 829218 - [abrt] qt-assistant-4.8.2-2.fc17: Process /usr/bin/assistant-qt4 was killed by signal 11 (SIGSEGV)
[abrt] qt-assistant-4.8.2-2.fc17: Process /usr/bin/assistant-qt4 was killed b...
Status: CLOSED DUPLICATE of bug 810500
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:031abb4f6750aa26958864d2bd4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 04:57 EDT by Hedayat Vatankhah
Modified: 2012-06-19 07:56 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 07:56:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (12.97 KB, text/plain)
2012-06-06 04:57 EDT, Hedayat Vatankhah
no flags Details
File: maps (63.66 KB, text/plain)
2012-06-06 04:57 EDT, Hedayat Vatankhah
no flags Details
File: backtrace (41.20 KB, text/plain)
2012-06-06 04:57 EDT, Hedayat Vatankhah
no flags Details

  None (edit)
Description Hedayat Vatankhah 2012-06-06 04:57:08 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        assistant-qt4
comment:        It runs for the first time. crashes in subsequent runs. It is possible to run it once again by removing .local/share/data/Trolltech/Assistant/qthelpcollection_4.8.2.qhc
crash_function: MainWindow::updateApplicationFont
executable:     /usr/bin/assistant-qt4
kernel:         3.3.7-1.fc17.x86_64
pid:            11637
pwd:            /home/hedayat
time:           چهارشنبه ۰۶ ژوئن ۱۲، ۱۳:۱۶:۱۵
uid:            1000
username:       hedayat

backtrace:      Text file, 42185 bytes
dso_list:       Text file, 13277 bytes
maps:           Text file, 65183 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/hedayat/2

core_backtrace:
:cd98536366bd487c4c2f4513c901eecd0165b2b5 0x48cd7 - [exe] -
:cd98536366bd487c4c2f4513c901eecd0165b2b5 0x49b98 - [exe] -
:cd98536366bd487c4c2f4513c901eecd0165b2b5 0x23112 - [exe] -

environ:
:QT_GRAPHICSSYSTEM_CHECKED=1
:KDE_IS_PRELINKED=1
:LANG=fa_IR.utf8
:DISPLAY=:0
:SHLVL=1
:LOGNAME=hedayat
:XDG_VTNR=1
:GNOME_KEYRING_PID=941
:CVS_RSH=ssh
:IMSETTINGS_MODULE=none
:XAUTHORITY=/var/run/gdm/auth-for-hedayat-pYSVfG/database
:PWD=/home/hedayat
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_SESSION_ID=2
:DESKTOP_SESSION=gnome
:GDMSESSION=gnome
:GNOME_KEYRING_CONTROL=/run/user/hedayat/keyring-V3BImb
:USERNAME=hedayat
:WINDOWPATH=1
:COLORTERM=gnome-terminal
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:CCACHE_HASHDIR=
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-RjHFbJahE4,guid=b27c94c6563d1a0edf0b340000000037
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:HISTCONTROL=ignoredups
:MAIL=/var/spool/mail/hedayat
:_=/usr/bin/assistant-qt4
:GDM_LANG=fa_IR.utf8
:OLDPWD=/home/hedayat/Projects/SOC
:HOSTNAME=hedayat-lap.hvnet
:SHELL=/bin/zsh
:WINDOWID=44040198
:TERM=xterm
:QT_IM_MODULE=xim
:HISTSIZE=10000
:KDEDIRS=/usr
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/home/hedayat/bin:/usr/local/sbin:/usr/sbin:/home/hedayat/.local/bin/
:SSH_AUTH_SOCK=/run/user/hedayat/keyring-V3BImb/ssh
:HOME=/home/hedayat
:XDG_SEAT=seat0
:XMODIFIERS=@im=none
:XDG_RUNTIME_DIR=/run/user/hedayat
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/945,unix/unix:/tmp/.ICE-unix/945
:GPG_AGENT_INFO=/run/user/hedayat/keyring-V3BImb/gpg:0:1
:USER=hedayat
:AUTOJUMP_DATA_DIR=/home/hedayat/.local/share/autojump
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:vcs_info_msg_0_=
:vcs_info_msg_1_=

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 19702                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       19702                19702                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/1
:pos:	0
:flags:	0100002
:1:/dev/pts/1
:pos:	0
:flags:	0100002
:2:/dev/pts/1
:pos:	0
:flags:	0100002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:pipe:[69640]
:pos:	0
:flags:	02004000
:5:pipe:[69640]
:pos:	0
:flags:	02004001
:6:socket:[69641]
:pos:	0
:flags:	02004002
:7:socket:[69644]
:pos:	0
:flags:	02004002
:8:socket:[69648]
:pos:	0
:flags:	02004002
:9:socket:[69650]
:pos:	0
:flags:	02004002
:10:anon_inode:inotify
:pos:	0
:flags:	02004000
:11:socket:[69652]
:pos:	0
:flags:	02000002
:12:/home/hedayat/.local/share/data/Trolltech/Assistant/qthelpcollection_4.8.2.qhc
:pos:	40
:flags:	02100002
:13:/home/hedayat/.local/share/data/Trolltech/Assistant/assistant.qch.4.8
:pos:	100
:flags:	02100002
:14:/usr/share/doc/qt4/qch/designer.qch
:pos:	100
:flags:	02100000
:15:/usr/share/doc/qt4/qch/linguist.qch
:pos:	100
:flags:	02100000
:16:anon_inode:inotify
:pos:	0
:flags:	02000000
:17:/home/hedayat/.local/share/data/Trolltech/Assistant/qthelpcollection_4.8.2.qhc
:pos:	40
:flags:	02100002
:18:/home/hedayat/.local/share/data/Trolltech/Assistant/assistant.qch.4.8
:pos:	24576
:flags:	02100002
:19:/usr/share/doc/qt4/qch/designer.qch
:pos:	100
:flags:	02100000
:20:/usr/share/doc/qt4/qch/linguist.qch
:pos:	100
:flags:	02100000
:21:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:22:socket:[69657]
:pos:	0
:flags:	02004002
:23:anon_inode:[eventfd]
:pos:	0
:flags:	02004002

var_log_messages:
:Jun  5 17:32:32 hedayat-lap kernel: [21491.186958] assistant-qt4[24399]: segfault at 1a03cc728 ip 0000000000448cd7 sp 00007fff9099ff40 error 4 in assistant-qt4[400000+eb000]
:Jun  5 17:32:32 hedayat-lap abrt[24409]: Saved core dump of pid 24399 (/usr/bin/assistant-qt4) to /var/spool/abrt/ccpp-2012-06-05-17:32:32-24399 (37732352 bytes)
:Jun  5 17:32:35 hedayat-lap kernel: [21494.869071] assistant-qt4[24432]: segfault at 19fd8c7d8 ip 0000000000448cd7 sp 00007fffd4d91e70 error 4 in assistant-qt4[400000+eb000]
:Jun  5 17:32:35 hedayat-lap abrt[24442]: Not dumping repeating crash in '/usr/bin/assistant-qt4'
:Jun  5 17:34:33 hedayat-lap kernel: [21612.716148] assistant-qt4[24545]: segfault at 1a1860898 ip 0000000000448cd7 sp 00007fff40694890 error 4 in assistant-qt4[400000+eb000]
:Jun  5 17:34:34 hedayat-lap abrt[24555]: Saved core dump of pid 24545 (/usr/bin/assistant-qt4) to /var/spool/abrt/ccpp-2012-06-05-17:34:33-24545 (37089280 bytes)
:Jun  6 13:16:15 hedayat-lap kernel: [ 6456.619054] assistant-qt4[11637]: segfault at 1a083d4d8 ip 0000000000448cd7 sp 00007fff4c746ff0 error 4 in assistant-qt4[400000+eb000]
:Jun  6 13:16:16 hedayat-lap abrt[11647]: Saved core dump of pid 11637 (/usr/bin/assistant-qt4) to /var/spool/abrt/ccpp-2012-06-06-13:16:15-11637 (36982784 bytes)
Comment 1 Hedayat Vatankhah 2012-06-06 04:57:14 EDT
Created attachment 589779 [details]
File: dso_list
Comment 2 Hedayat Vatankhah 2012-06-06 04:57:18 EDT
Created attachment 589780 [details]
File: maps
Comment 3 Hedayat Vatankhah 2012-06-06 04:57:22 EDT
Created attachment 589781 [details]
File: backtrace
Comment 4 Ali Reza Pazhouhesh 2012-06-07 07:10:52 EDT
I also have this problem on a Fedora 17 with qt-assistant 4.8.2
Comment 5 Jiri Popelka 2012-06-11 13:26:27 EDT
Crashes imediatelly after start.

backtrace_rating: 4
Package: qt-assistant-4.8.2-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Jiri Popelka 2012-06-11 13:30:15 EDT
Moving .local/share/data/Trolltech/Assistant away makes it working again.
Comment 7 Yupeng Chang 2012-06-15 05:18:14 EDT
(In reply to comment #6)
> Moving .local/share/data/Trolltech/Assistant away makes it working again.

It works if I delete .local/share/data/Trolltech/Assistant, but it only works for one time. This program will crash if the file qthelpcollection_4.8.2.qhc exists.

I did some digging on this.
The program crashed at mainwindow.cpp:949 on "widget->setFont(font);" in function void MainWindow::updateApplicationFont().

I don't think this is related to font, because I have upgraded fontconfig and freetype library, it still crashes.

The code caused crash is
const QWidgetList &widgets = qApp->allWidgets();
foreach (QWidget* widget, widgets)
    widget->setFont(font);

The only possible reason is that qApp->allWidgets() returned NULL widget in QWidgetList. This is just a guess, I haven't tested my theory.

Hope this information can help to address the issue.
Comment 8 Ngo Than 2012-06-19 07:56:11 EDT

*** This bug has been marked as a duplicate of bug 810500 ***

Note You need to log in before you can comment on or make changes to this bug.