Bug 832603 - [abrt] libreoffice-core-3.5.4.2-1.fc17: FocusManager::RemoveUnusedEventListener killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.4.2-1.fc17: FocusManager::RemoveUnusedEventListen...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:36242fe841d8a0d61168f0f78e1...
:
: 835481 844156 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 18:06 EDT by saulo
Modified: 2012-08-18 20:27 EDT (History)
8 users (show)

See Also:
Fixed In Version: libreoffice-3.5.5.3-5.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-18 20:27:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (21.74 KB, text/plain)
2012-06-15 18:06 EDT, saulo
no flags Details
File: maps (98.81 KB, text/plain)
2012-06-15 18:06 EDT, saulo
no flags Details
File: backtrace (65.11 KB, text/plain)
2012-06-15 18:06 EDT, saulo
no flags Details
File: core_backtrace (4.51 KB, text/plain)
2012-06-15 18:06 EDT, saulo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 47368 None None None 2012-08-01 03:53:10 EDT
FreeDesktop.org 51324 None None None 2012-06-25 05:35:55 EDT

  None (edit)
Description saulo 2012-06-15 18:06:16 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --impress --splash-pipe=6
comment:        exporting as jpg
crash_function: operator++
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.4.0-1.fc17.x86_64
pid:            5631
pwd:            /home/saulo
time:           Fri 15 Jun 2012 10:40:16 PM CEST
uid:            1000
xsession_errors: 

backtrace:      Text file, 66670 bytes
core_backtrace: Text file, 4618 bytes
dso_list:       Text file, 22264 bytes
maps:           Text file, 101184 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/saulo/52

environ:
:XDG_VTNR=2
:MPI_INCLUDE=/usr/include/mpich2-x86_64
:MANPATH=/usr/share/man/mpich2:/usr/share/man:/usr/local/share/man
:XDG_SESSION_ID=52
:HOSTNAME=aflitos-laptop
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=5613
:GPG_AGENT_INFO=/run/user/s/keyring-qfc8NF/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=gnome-shell-24935-aflitos-laptop-libreoffice-3_TIME432171329
:HISTSIZE=10000000
:XDG_SESSION_COOKIE=508d110410e865d9c91115f500000010-1339515764.71423-2139786443
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/run/user/s/keyring-qfc8NF
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:MPI_PYTHON_SITEARCH=/usr/lib64/python2.7/site-packages/mpich2
:USER=s
:LD_LIBRARY_PATH=/usr/java/jre1.7.0_04/lib/amd64/client:/usr/java/jre1.7.0_04/lib/amd64/server:/usr/java/jre1.7.0_04/lib/amd64/native_threads:/usr/java/jre1.7.0_04/lib/amd64:/usr/lib64/mpich2/lib
:SSH_AUTH_SOCK=/run/user/s/keyring-qfc8NF/ssh
:MPI_LIB=/usr/lib64/mpich2/lib
:USERNAME=s
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/24718,unix/unix:/tmp/.ICE-unix/24718
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-impress.desktop
:MAIL=/var/spool/mail/s
:'PATH=/usr/lib64/mpich2/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/saulo/bin:/home/saulo/Komodo-Edit-7/bin/:/usr/bin/Iomega Storage Manager/:/home/saulo/bin'
:DESKTOP_SESSION=gnome
:MPI_BIN=/usr/lib64/mpich2/bin
:QT_IM_MODULE=xim
:MPI_COMPILER=mpich2-x86_64
:PWD=/home/s
:_LMFILES_=/etc/modulefiles/mpich2-x86_64
:XMODIFIERS=@im=none
:EDITOR=nano
:KDE_IS_PRELINKED=1
:GNOME_KEYRING_PID=24716
:LANG=en_US.UTF-8
:MODULEPATH=/usr/share/Modules/modulefiles:/etc/modulefiles
:LOADEDMODULES=mpich2-x86_64
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:MPI_SYSCONFIG=/etc/mpich2-x86_64
:XDG_SEAT=seat0
:HOME=/home/s
:SHLVL=1
:MPI_SUFFIX=_mpich2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:MPI_MAN=/usr/share/man/mpich2
:PYTHONPATH=/usr/lib64/python2.7/site-packages/mpich2
:LOGNAME=s
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-VGXdHNp95P,guid=e2b2dcd6940cc078bbd77a4e000264e9
:MPI_HOME=/usr/lib64/mpich2
:MPI_FORTRAN_MOD_DIR=/usr/include/mpich2-x86_64
:MODULESHOME=/usr/share/Modules
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=2
:XDG_RUNTIME_DIR=/run/user/s
:DISPLAY=:0
:'HISTTIMEFORMAT=%s '
:XAUTHORITY=/var/run/gdm/auth-for-s-43D76g/database
:'module=() {  eval `/usr/bin/modulecmd bash $*`\n}'

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31459                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31459                31459                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:1:/home/saulo/.xsession-errors
:2:/home/saulo/.xsession-errors
:3:socket:[24256108]
:4:anon_inode:[eventfd]
:5:pipe:[24256055]
:6:pipe:[24256055]
:7:socket:[24256110]

smolt_data:
:
:
:General
:=================================
:UUID: d2458da3-c91e-4b00-baa1-86321de8cd3a
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4520.88
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     P8400  @ 2.26GHz
:CPU Stepping: 6
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2267
:System Memory: 3953
:System Swap: 2047
:Vendor: Sony Corporation
:System: VGN-FW11M C600E1A3
:Form factor: Notebook
:Kernel: 3.4.0-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4523:17251:4173:36917) pci, sky2, ETHERNET, 88E8055 PCI-E Gigabit Ethernet Controller
:(32902:10816:4173:36917) pci, None, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10817:4173:36917) pci, pcieport, PCI/PCI, Mobile 4 Series Chipset PCI Express Graphics Port
:(32902:10544:4173:36917) pci, None, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10537:4173:36917) pci, ahci, STORAGE, ICH9M/M-E SATA AHCI Controller
:(32902:10521:4173:36917) pci, None, PCI/ISA, ICH9M LPC Interface Controller
:(32902:9288:4173:36917) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(4480:2098:4173:36917) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(4480:2082:4173:36917) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(32902:10549:4173:36917) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:4173:36917) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:4173:36917) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:4173:36917) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:4173:36917) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4173:36917) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:10566:4173:36917) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10560:4173:36917) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:4173:36917) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10568:4173:36917) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:4173:36917) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:16946:32902:4865) pci, iwlwifi, NETWORK, WiFi Link 5100 AGN
:(32902:10551:4173:36917) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:4173:36917) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4098:43560:4173:36917) pci, snd_hda_intel, MULTIMEDIA, RV620 Audio device [Radeon HD 34xx Series]
:(4098:38340:4173:36917) pci, radeon, VIDEO, Mobility Radeon HD 3400 Series
:(4480:1426:4173:36917) pci, r592, BASE, R5C592 Memory Stick Bus Host Adapter
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda9 / ext4 4096 4096 3814239 1153622 962249 958464 671310 671310
:/dev/sda8 /home ext4 4096 4096 5226653 1773144 1511006 1310720 1206282 1206282
:/dev/sda6 /boot ext4 1024 1024 508745 404823 379223 128016 127712 127712
:

var_log_messages:
:Jun 15 22:40:15 aflitos-laptop kernel: [433956.342995] soffice.bin[5631]: segfault at 400000000 ip 0000003c7c904f2d sp 00007fffa2a28200 error 4 in libvcllo.so[3c7c800000+486000]
:Jun 15 22:40:18 aflitos-laptop abrt[8193]: Saved core dump of pid 5631 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-06-15-22:40:16-5631 (143638528 bytes)
Comment 1 saulo 2012-06-15 18:06:21 EDT
Created attachment 592247 [details]
File: dso_list
Comment 2 saulo 2012-06-15 18:06:24 EDT
Created attachment 592248 [details]
File: maps
Comment 3 saulo 2012-06-15 18:06:26 EDT
Created attachment 592249 [details]
File: backtrace
Comment 4 saulo 2012-06-15 18:06:28 EDT
Created attachment 592250 [details]
File: core_backtrace
Comment 5 Caolan McNamara 2012-06-18 11:12:52 EDT
Are you able to reproduce this crash ? If so how ?


I wonder if this is somehow related to http://cgit.freedesktop.org/libreoffice/core/commit/?id=ec240ea + http://cgit.freedesktop.org/libreoffice/core/commit/?id=4ae4c57 Clearly some lifecycle disaster on deleting a Window
Comment 6 David Tardon 2012-06-26 07:25:11 EDT
*** Bug 835481 has been marked as a duplicate of this bug. ***
Comment 7 David Tardon 2012-07-31 03:31:04 EDT
*** Bug 844156 has been marked as a duplicate of this bug. ***
Comment 8 Caolan McNamara 2012-07-31 11:12:11 EDT
Lets turn off c++0x mode in F-17 in case that's the problem here
Comment 9 Stephan Bergmann 2012-08-01 03:13:07 EDT
(In reply to comment #8)
> Lets turn off c++0x mode in F-17 in case that's the problem here

I do not believe that that's the problem here.  For one, accidentally picking up wrong implementations of inline functions across libraries (see <http://gcc.gnu.org/bugzilla/show_bug.cgi?id=49561#c8> "[C++0x] std::list::size complexity") cannot hit here, as the relevant code is built --fvisibility-inlines-hidden (and libvcllo.so indeed contains "std::__debug::list<Link, std::allocator<Link> >::remove(Link const&)" only non-exported).  For another, the backtrace in attachment 601026 [details] to bug 844156, where the relevant std::list instance's this=0x4f, makes it more likely that this is indeed some lifecycle disaster/memory corruption.

(Then again, turning c++0x mode off in F-17 probably cannot hurt anyway, at least as long as <http://gcc.gnu.org/bugzilla/show_bug.cgi?id=49561> is only fixed in rawhide.)
Comment 10 David Tardon 2012-08-01 03:53:10 EDT
https://bugs.freedesktop.org/show_bug.cgi?id=47368 looks like a possible culprit
Comment 11 Fedora Update System 2012-08-01 15:42:24 EDT
libreoffice-3.5.5.3-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.5.3-5.fc17
Comment 12 David Tardon 2012-08-02 04:53:11 EDT
https://bugs.freedesktop.org/show_bug.cgi?id=51324#c25 It seems that gcc -std=c++11 is innocent after all.
Comment 13 Fedora Update System 2012-08-02 07:23:44 EDT
Package libreoffice-3.5.5.3-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.5.5.3-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11418/libreoffice-3.5.5.3-5.fc17
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2012-08-09 02:56:39 EDT
libreoffice-3.5.6.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.6.2-1.fc17
Comment 15 Fedora Update System 2012-08-18 20:27:22 EDT
libreoffice-3.5.6.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.