Bug 833150 - [ja_JP] [RHSM Firstboot] Should back to Entitlement Platform Registration page instead of Set Up Software Updates page after clicking 'Back' button in Confirm Subscriptions page of Firstboot .
[ja_JP] [RHSM Firstboot] Should back to Entitlement Platform Registration pag...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: 7.0
Assigned To: candlepin-bugs
IDM QE LIST
: i18n
Depends On: 828068
Blocks: 830269 rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-06-18 13:35 EDT by Alex Wood
Modified: 2014-01-31 09:57 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 828068
Environment:
Last Closed: 2014-01-31 09:57:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 RHEL Product and Program Management 2012-06-18 13:47:19 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Sharath Dwaral 2012-06-21 14:31:16 EDT
Waiting on 

Bug 834393 - Subscription Manager GUI : In first boot, after registering with valid credentials on clicking back button it does not return to Subscription Registration page
Comment 4 Bryan Kearney 2012-08-13 09:33:23 EDT
Tested with 1.0.13 test version, and it is not there. PLease re-verity with 1.0.14 or later.
Comment 6 John Sefler 2012-09-07 18:42:22 EDT
[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager-firstboot rhn-client-tools
subscription-manager-firstboot-1.0.17-1.el5
rhn-client-tools-0.4.20-81.el5

Testing with this version and launching firstboot with LANG=ja_JP.UTF-8, clicking the 'Back' in Confirm Subscriptions panel, I am directed all the way back to the "Choose Service" panel (which has been re-designed in RHEL5.9 and is NOT currently translated in Japanese).  It's a little farther back that I expected and it is not the progress bar described in bug 834393.  Since the original bug expected to be taken back to the Subscription Registration page which seems the most logical to me, I am moving this bug back to ASSIGNED/FailedQA/NEEDINFO for acceptable backflow behavior.

Note: This backflow behavior is currently present regardless of LANG=ja_JP.UTF-8
Comment 7 Adrian Likins 2012-10-03 17:18:25 EDT
I see the behavior in comment 6 regardless of LANG. 

Not sure if that is correct, but it doesn't seem dependent on the LANG.
Comment 8 Adrian Likins 2012-10-05 11:22:38 EDT
The general consensus is this should be pushed to 6.4. The behaviour isn't new
(though it is unideal) and changes needed to fix it are high risk.
Comment 9 Bryan Kearney 2012-10-05 13:20:13 EDT
Per c8 and c6, reducing the severity and moving to RHEL 6.4
Comment 11 Sharath Dwaral 2013-01-29 16:32:39 EST
# rpm -qa | egrep 'subscription-manager|python-rhsm'

subscription-manager-migration-1.1.23-1.el6.x86_64
subscription-manager-1.1.23-1.el6.x86_64
subscription-manager-gui-1.1.23-1.el6.x86_64
python-rhsm-debuginfo-1.1.8-1.el6.x86_64
subscription-manager-debuginfo-1.1.23-1.el6.x86_64
python-rhsm-1.1.8-1.el6.x86_64
subscription-manager-firstboot-1.1.23-1.el6.x86_64

The behaviour has not changed. It behaves as stated in comment 6.

In LANG=ja_JP.UTF-8 the following menus are not translated

Before registering: Search Software Update (only title is translated)
                    Choose Services (Nothing is translated) 
                     
After Registering: Set up software updates (only title is translated)
                   Error message - Insufficient memory to enable Kdump (not translated)      

Moving bug to RHEL 6.5
Comment 14 Adrian Likins 2014-01-31 09:57:47 EST
There is no "Setup Software Updates" page in rhel7 firstboot, only RHSM pages. So going to consider this NOTABUG for rhel7.

Note You need to log in before you can comment on or make changes to this bug.