Bug 834051 - coverity: main: negative return value from "read" is not handled correctly
coverity: main: negative return value from "read" is not handled correctly
Status: CLOSED DUPLICATE of bug 609590
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
Depends On:
  Show dependency treegraph
Reported: 2012-06-20 13:57 EDT by Nathan Kinder
Modified: 2013-06-18 11:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-07-09 18:47:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nathan Kinder 2012-06-20 13:57:58 EDT
This bug is created as a clone of upstream ticket:


Description of problem:
11956 NEGATIVE_RETURNS Triaged Bug Minor Fix Required main()
File: ds/ldap/servers/slapd/tools/ldif.c

Status:         New     ?       Triaged
Classification:         Unclassified    ?       Bug
Action:         Undecided       ?       Fix Required
Severity:       Unspecified     ?       Minor

minor problem in the ldif tool - no fix required for 8.2 because this is in a
seldom used command line tool.

Note - this will need to be verified by a developer by ensuring that the coverity does not report this issue anymore.
Comment 1 Noriko Hosoi 2012-07-09 18:47:44 EDT
> This issue was fixed some time ago. We currently check for negative return value from read() in ldif.c:main():

Fixed in this commit on 06/30/2010.
commit 4739bf587db66c9d8ceabd446dabbe03bc3a0664
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Wed Jun 30 10:52:05 2010 -0600

*** This bug has been marked as a duplicate of bug 609590 ***

Note You need to log in before you can comment on or make changes to this bug.